weird idle (inconsistent) - Ranger-Forums - The Ultimate Ford Ranger Resource


4.0L OHV & SOHC V6 Tech General discussion of 4.0L OHV and SOHC V6 Ford Ranger engines.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-20-2009
VW TANK's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Feb 2008
Location: Ridgewood,NJ
Posts: 162
weird idle (inconsistent)

so for some reason my truck has a bouncing idle....its at about 900rpm for 15 seconds or so, then there is a pretty loud click noise, and the rpm jumps up to about 1200, but only for 5 seconds....then back down to 900. i did have lean codes for both banks and cleared them, but it still does it

any thoughts?
Reply With Quote
  #2  
Old 04-20-2009
rolsmojave3's Avatar
Level III Supporter
 
Join Date: Jun 2006
Location: Wisconsin
Posts: 2,852
Loud click noise seems like the AC clutch to me which is normal for it to idle a tad higher. Even if you clear the lean codes that doesn't fix the actual problem. Find the source of leak and repair it. Being that you have an OHV you probably have an intake manifold gasket leak. You'll be much happier with it repaired.
Reply With Quote
  #3  
Old 04-20-2009
VW TANK's Avatar
Member
Thread Starter
iTrader: (1)
 
Join Date: Feb 2008
Location: Ridgewood,NJ
Posts: 162
well i just doublechecked it now that im home...and it actually is the A/C compressor kicking in for some reason....why the heck would that be happening, im not using my A/C...

is that still vacuum related? if so ill get the gaskets and replace later this week
Reply With Quote
  #4  
Old 04-20-2009
rolsmojave3's Avatar
Level III Supporter
 
Join Date: Jun 2006
Location: Wisconsin
Posts: 2,852
Do you have the Defrost or feet/upper vents on?

Vacuum related is your Check Engine light being on and giving you a lean code.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
o/d light flashing inconsistent? tanner General Technical & Electrical 0 07-02-2015 03:41 PM
Weird idle problem when putting truck in neutral coming to stops. Jeremy102579 2.9L & 3.0L V6 Tech 13 03-25-2007 10:26 AM
funny idle, startup weird, and transfer case, under warranty..help erock 2.9L & 3.0L V6 Tech 2 11-17-2006 07:04 PM
RMPs weird at idle...?? Bailey 4.0L OHV & SOHC V6 Tech 23 01-10-2006 05:40 PM
weird engine idle CAW General Ford Ranger Discussion 17 09-28-2005 07:54 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:40 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.