Finally, 5.0 Swap - Page 3 - Ranger-Forums - The Ultimate Ford Ranger Resource


8-Cylinder Tech If you are one of the few with a V8 engine in your Ranger, or if you dream of a Ranger with a V8 engine, this is the sub-forum for you.

Reply
 
LinkBack Thread Tools Search this Thread
  #51  
Old 07-01-2012
PAShooter's Avatar
Member
Thread Starter
 
Join Date: Jul 2010
Location: Altoona, PA
Posts: 908
Quote:
Originally Posted by 04RangerDave View Post
what are you doing with you old cats i need one BAD not much cash???????
Which one do you need? The large one after the Y is gutted but the other two are good...If you look above i said like 50 bucks.
Reply With Quote
  #52  
Old 07-01-2012
FULLSCALE's Avatar
Level III Supporter

iTrader: (12)
 
Join Date: Mar 2009
Location: Clinton, Ontario
Posts: 8,181
That was quick... nice work!
Reply With Quote
  #53  
Old 07-01-2012
PAShooter's Avatar
Member
Thread Starter
 
Join Date: Jul 2010
Location: Altoona, PA
Posts: 908
Quote:
Originally Posted by FULLSCALE View Post
That was quick... nice work!
Thanks!

750 miles on it already. Had one vacuum leak, changing plugs today, unplugged O2 sensors. I hope this makes it run better.
Reply With Quote
  #54  
Old 07-01-2012
kanuck15's Avatar
Member
 
Join Date: Mar 2011
Location: Pennsylvania
Posts: 844
I leave the forum for a little bit and this happens? Lol looks good man. Quick work I like that. I need to start gathering more parts for mine
Reply With Quote
  #55  
Old 07-08-2012
PAShooter's Avatar
Member
Thread Starter
 
Join Date: Jul 2010
Location: Altoona, PA
Posts: 908
Quote:
Originally Posted by kanuck15 View Post
I leave the forum for a little bit and this happens? Lol looks good man. Quick work I like that. I need to start gathering more parts for mine
It was only a matter of time haha, If you need any help just PM I could probably come down and help.
Reply With Quote
  #56  
Old 07-08-2012
kanuck15's Avatar
Member
 
Join Date: Mar 2011
Location: Pennsylvania
Posts: 844
Between you and my friend who did it to his 2000 its probably an over night swap
Reply With Quote
  #57  
Old 07-14-2012
Jack_RANGER's Avatar
Member
 
Join Date: Feb 2012
Location: Guelph ont
Posts: 9
Did you have to make custom motor mounts?
Reply With Quote
  #58  
Old 07-14-2012
kanuck15's Avatar
Member
 
Join Date: Mar 2011
Location: Pennsylvania
Posts: 844
No, The v8 mounts fit right in. IIRC with a 3.0 you use the passenger V8 mount and just flip the drivers side 3.0 mount around
Reply With Quote
  #59  
Old 07-15-2012
PAShooter's Avatar
Member
Thread Starter
 
Join Date: Jul 2010
Location: Altoona, PA
Posts: 908
Quote:
Originally Posted by kanuck15 View Post
No, The v8 mounts fit right in. IIRC with a 3.0 you use the passenger V8 mount and just flip the drivers side 3.0 mount around
Correct...but I messed up and dropped the motor in without changing out the drivers side. So we just torched a new hole into the bracket. It works just is a pain haha.

Ive got 2000 miles on the swap and its running decently, im doing field work so I have no access to tools but what i could fix (spark wires and plugs) ive done and theyve helped alot.
Reply With Quote
  #60  
Old 07-15-2012
kanuck15's Avatar
Member
 
Join Date: Mar 2011
Location: Pennsylvania
Posts: 844
What kind of MPGs you getting out of this? My ranger is my DD so I have to keep this in mind
Reply With Quote
  #61  
Old 07-16-2012
87xlt's Avatar
Member
 
Join Date: Jun 2008
Location: In my truck!
Posts: 875
Running on 7 cylinders I'm sure you do not want to know!
Are you still using the stock 3.0 fuel pump?
Reply With Quote
  #62  
Old 07-16-2012
04RangerDave's Avatar
JDM> RANGER

iTrader: (3)
 
Join Date: Jul 2010
Location: RI
Posts: 5,030
Quote:
Originally Posted by PAShooter View Post
Which one do you need? The large one after the Y is gutted but the other two are good...If you look above i said like 50 bucks.
Im blind. could you some how ship the whole Y pipe
Reply With Quote
  #63  
Old 07-17-2012
PSIJOE's Avatar
Member
 
Join Date: Nov 2011
Location: Sacramento, CA
Posts: 1,311
Crossing my fingers on you getting everything sorted soon. Good luck.
Reply With Quote
  #64  
Old 07-17-2012
PAShooter's Avatar
Member
Thread Starter
 
Join Date: Jul 2010
Location: Altoona, PA
Posts: 908
Quote:
Originally Posted by kanuck15 View Post
What kind of MPGs you getting out of this? My ranger is my DD so I have to keep this in mind
Average of 16 mixed, compared to the 12 I was getting with the 3.0 im okay with 16 haha

Quote:
Originally Posted by 87xlt View Post
Running on 7 cylinders I'm sure you do not want to know!
Are you still using the stock 3.0 fuel pump?
I believe it was the spark plug wires that was causing it to misfire, I swapped them out and now its running on all 8.

Quote:
Originally Posted by 04RangerDave View Post
Im blind. could you some how ship the whole Y pipe
I could figure out how to after august 15th. Im currently doing field work so that would be the date I get back home.

Quote:
Originally Posted by PSIJOE View Post
Crossing my fingers on you getting everything sorted soon. Good luck.
Thanks man! Its a process but itll be running perfectly after I get home and have tools haha
Reply With Quote
  #65  
Old 07-17-2012
kanuck15's Avatar
Member
 
Join Date: Mar 2011
Location: Pennsylvania
Posts: 844
Idk if 16 is enough, I get 20 out of mine using it for DD use. But then again I wouldnt be turning 33s either. Id keep my small tires and whatnot
Reply With Quote
  #66  
Old 07-20-2012
MudSlanger's Avatar
Member
iTrader: (4)
 
Join Date: Jun 2007
Location: Phoenix, AZ
Posts: 1,462
Quote:
Originally Posted by 87xlt View Post
Running on 7 cylinders I'm sure you do not want to know!
Are you still using the stock 3.0 fuel pump?
Im still running my flex fuel pump from my 3.0 on my V8 swap and I havent had ANY issues at all in 2+ years
Reply With Quote
  #67  
Old 07-22-2012
kanuck15's Avatar
Member
 
Join Date: Mar 2011
Location: Pennsylvania
Posts: 844
Hey been meaning to ask about this. What was your driveshaft setup. Did you cut any of them or was it a bolt in deal?
Reply With Quote
  #68  
Old 08-05-2012
PAShooter's Avatar
Member
Thread Starter
 
Join Date: Jul 2010
Location: Altoona, PA
Posts: 908
Quote:
Originally Posted by kanuck15 View Post
Idk if 16 is enough, I get 20 out of mine using it for DD use. But then again I wouldnt be turning 33s either. Id keep my small tires and whatnot
Thats true, ive gotten 20 outta the v8 on one trip.

Quote:
Originally Posted by MudSlanger View Post
Im still running my flex fuel pump from my 3.0 on my V8 swap and I havent had ANY issues at all in 2+ years
Hmmm probably my O2 sensors then, thanks for the input

Quote:
Originally Posted by kanuck15 View Post
Hey been meaning to ask about this. What was your driveshaft setup. Did you cut any of them or was it a bolt in deal?
Ranger drive shaft with the joint on the transfer case side swapped to the ranger drive shaft. All bolt in.


BIG QUESTION:

So last week the truck started to not have oil pressure until it warms up. Im unsure what could be wrong with it because it is definitely not the gauge. When it reads no oil pressure it has some rocker knock but once it warms up and gets oil pressure the knock goes away. Any ideas? Id rather not just throw parts at it.
Reply With Quote
  #69  
Old 08-05-2012
PAShooter's Avatar
Member
Thread Starter
 
Join Date: Jul 2010
Location: Altoona, PA
Posts: 908
Also got some new meats, 305/70R16 toyo open country a/ts, 4 with 3/4 tread for 150 bucks.
Reply With Quote
  #70  
Old 08-08-2012
PAShooter's Avatar
Member
Thread Starter
 
Join Date: Jul 2010
Location: Altoona, PA
Posts: 908
Any help guys?
Reply With Quote
  #71  
Old 08-08-2012
kanuck15's Avatar
Member
 
Join Date: Mar 2011
Location: Pennsylvania
Posts: 844
How warm does the truck have to get for oil pressure? you may wanna hook up a scanner and see what your oil temp is when pressure comes up
Reply With Quote
  #72  
Old 08-08-2012
87xlt's Avatar
Member
 
Join Date: Jun 2008
Location: In my truck!
Posts: 875
Hmm sounds like the oil filter may be clogged or the oil pump needs to be replaced.
Reply With Quote
  #73  
Old 08-09-2012
PAShooter's Avatar
Member
Thread Starter
 
Join Date: Jul 2010
Location: Altoona, PA
Posts: 908
Quote:
Originally Posted by kanuck15 View Post
How warm does the truck have to get for oil pressure? you may wanna hook up a scanner and see what your oil temp is when pressure comes up
Right at the C line

Quote:
Originally Posted by 87xlt View Post
Hmm sounds like the oil filter may be clogged or the oil pump needs to be replaced.
Im thinking its one of those two but im hoping it makes it 600 miles till I can get home
Reply With Quote
  #74  
Old 09-27-2012
PAShooter's Avatar
Member
Thread Starter
 
Join Date: Jul 2010
Location: Altoona, PA
Posts: 908
Figured it out, threw on a mechanical gauge and i had 60 psi upon cold start up @1500rpms. 25psi @ hot idle and 35 psi [email protected] rpms. It was the sending unit, so I tossed on the one from my 3.0 and it works perfectly.

Im now thinking about a 5spd swap or a turbo haha.
Reply With Quote
  #75  
Old 09-27-2012
kanuck15's Avatar
Member
 
Join Date: Mar 2011
Location: Pennsylvania
Posts: 844
I got an eaton m112 sitting in the garage for mine lol. the thrill wears off quick doesnt it?

btw what did you do for an exhaust?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Transmission swap Finally started pearlkid9988 Project Logs 21 05-07-2015 10:20 PM
Finally did my 01-03 front end swap skier2880 Exterior Semi-Tech 17 04-03-2011 06:25 PM
finally finally got one!!!! atlanta426 Member Introductions 18 11-09-2010 04:47 PM
V8 engine swap finally available! RedRanger91XLT New Ideas 19 09-04-2010 09:36 PM
finally completed the swap 01 ranger 4x4 Snapshots 20 05-19-2010 12:48 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:54 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.