Amp powers, sub inop - Ranger-Forums - The Ultimate Ford Ranger Resource


Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-05-2009
xXcecinestpasXx86's Avatar
Member
Thread Starter
 
Join Date: Jun 2008
Location: Frisco, CO
Posts: 80
Amp powers, sub inop

Checked all wires to the head unit, good connections. Took sub out of box, maybe wires came loose, Nope! Has been happening lately for no apparent reason. Also door speakers connectors are trashed, time for new 6x8's!
Reply With Quote
  #2  
Old 05-05-2009
02BlkEDGE's Avatar
Member
 
Join Date: Dec 2008
Location: Crystal River, Florida
Posts: 182
maybe the rca sub outputs went out on the head unit
Reply With Quote
  #3  
Old 05-05-2009
vista4.0's Avatar
Member
iTrader: (3)
 
Join Date: Jan 2009
Location: Beaver Falls, PA
Posts: 2,824
Quote:
Originally Posted by 02BlkEDGE View Post
maybe the rca sub outputs went out on the head unit
I agree. If the sub does nothing Id say its an RCA issue.

EDIT: Also check to make sure the ground isnt loose. I went a week thinking that my RCAs were bad but totally forgot to check the ground.

Last edited by vista4.0; 05-05-2009 at 10:32 PM.
Reply With Quote
  #4  
Old 05-05-2009
skier2880's Avatar
Member
iTrader: (2)
 
Join Date: Feb 2009
Location: La Grande, OR
Posts: 320
check all the grounds
but ya the rca thing happened to me once
Reply With Quote
  #5  
Old 05-05-2009
monkeysteeler12's Avatar
Member
 
Join Date: Nov 2008
Location: vienna va
Posts: 663
get a monster cable, and connect it to your input in your amp, and the otherside to your ipod or something, if anything happens, then you know that it is your HU.

could you understand that? i think i sucked at explaining it
Reply With Quote
  #6  
Old 05-05-2009
ClemsonRanger03's Avatar
Member
iTrader: (1)
 
Join Date: Mar 2009
Location: Clemson, SC
Posts: 804
Maybe you are overheating it? Most amps have an outo shutoff if something is up. Could also be a bad or loose ground.
Reply With Quote
  #7  
Old 05-08-2009
xXcecinestpasXx86's Avatar
Member
Thread Starter
 
Join Date: Jun 2008
Location: Frisco, CO
Posts: 80
All connections are strong, guess it's the rca's
Reply With Quote
  #8  
Old 05-08-2009
monkeysteeler12's Avatar
Member
 
Join Date: Nov 2008
Location: vienna va
Posts: 663
telling you, you should just try the monster cable idea. before you go and get a new HU
Reply With Quote
  #9  
Old 05-08-2009
xXcecinestpasXx86's Avatar
Member
Thread Starter
 
Join Date: Jun 2008
Location: Frisco, CO
Posts: 80
Don't have a ipod anymore.. This jensen indash I bought has been nothing but trouble lol
Reply With Quote
  #10  
Old 05-08-2009
xXcecinestpasXx86's Avatar
Member
Thread Starter
 
Join Date: Jun 2008
Location: Frisco, CO
Posts: 80
Screen shorted out 4 months ago
Reply With Quote
  #11  
Old 05-09-2009
xXcecinestpasXx86's Avatar
Member
Thread Starter
 
Join Date: Jun 2008
Location: Frisco, CO
Posts: 80
Tested the front rca's this morning.. no go on the bump. Kinda knew I was buying a cheap unit but wanted a screen at the time. Which I would like to still have one
Reply With Quote
  #12  
Old 05-10-2009
Steph3n1's Avatar
Member
 
Join Date: Apr 2009
Location: Duluth, GA
Posts: 93
Quote:
Originally Posted by xXcecinestpasXx86 View Post
Tested the front rca's this morning.. no go on the bump. Kinda knew I was buying a cheap unit but wanted a screen at the time. Which I would like to still have one
just as a recommendation get a new headunit, but when you do i would go with a little higher quality brands like pioneer, alpine, kenwood. ive had a few buddys with jensens, duals etc and they've caused them nothing but trouble. im pretty sure pioneer had a indash screen HU for like 350$
Reply With Quote
  #13  
Old 04-03-2010
xXcecinestpasXx86's Avatar
Member
Thread Starter
 
Join Date: Jun 2008
Location: Frisco, CO
Posts: 80
Think I'll just go with a alpine head unit. wish I had another vehicle to check my amp rca inputs
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
powers window buzzing fuse? mdills General Technical & Electrical 2 10-20-2011 04:03 PM
Hella 500 inop btm757 General Technical & Electrical 4 06-09-2010 10:05 PM
power door locks remote inop mod? dblack General Technical & Electrical 2 01-27-2007 09:52 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:52 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.