anyone familiar with the 2g eclipse/talon ? - Ranger-Forums - The Ultimate Ford Ranger Resource


Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-23-2010
d0sitmatr's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Jan 2010
Location: SFL
Posts: 706
anyone familiar with the 2g eclipse/talon ?

hey all, Im having a really hard time finding a place to run an amp line from the battery.
if your familiar with these cars and their engine bays, then you know how cramped it is at the firewall (I cant even get my arm between engine and FW...)

anyways, I was hoping someone might have some experience wiring an amp up in one of these cars and can give me some help.

Im planning on putting the AMP into the spare tire bay seeing as the spare is teeny, and there is more than enough room for a full sized tire there. Im wanting to run the power line down the drivers side and bring it into the spare area from the paneling on that side. but getting the wire into the cab area in itself is creating a HUGE headache.
as far as Ive been able to tell to this point, is Im most likely going to have to get under the car ?

Reply With Quote
  #2  
Old 02-23-2010
ccernst's Avatar
Member
 
Join Date: May 2009
Location: Kansas City, MO
Posts: 380
I put a system in a 1G Eclipse, drilled a hole in the passenger footwell, way up there. not sure what the 2G looks like in that area.
Reply With Quote
  #3  
Old 02-23-2010
Downey's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
^^ yea i think i drilled a hole last time too i helped install a system in my buddys car.
Reply With Quote
  #4  
Old 02-23-2010
d0sitmatr's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Jan 2010
Location: SFL
Posts: 706
sorry, I should have thought of that
here is the engine bay by the FW
Attached Thumbnails
anyone familiar with the 2g eclipse/talon ?-talon-engine-bay-001.jpg   anyone familiar with the 2g eclipse/talon ?-talon-engine-bay-002.jpg   anyone familiar with the 2g eclipse/talon ?-talon-engine-bay-003.jpg  
Reply With Quote
  #5  
Old 02-23-2010
ranger4.0's Avatar
Member
iTrader: (1)
 
Join Date: Jul 2009
Location: cambridge, ontario
Posts: 3,922
Drill a hole And install a rubber grommet then run your wire through. Works great. If you worried about it sealing around the wire you can use some type of silicone or something so water doesn't get behind your dash
Reply With Quote
  #6  
Old 02-23-2010
d0sitmatr's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Jan 2010
Location: SFL
Posts: 706
its not that, I have no problems drilling through.
the problem is I have zero room between the engine and the fire wall :(
Reply With Quote
  #7  
Old 02-23-2010
Downey's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
drill from the inside out
Reply With Quote
  #8  
Old 02-23-2010
d0sitmatr's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Jan 2010
Location: SFL
Posts: 706
I thought of that too, I finally found where all the electrical wiring comes into the cab, on the psngr side, so I guess I'll be running my power down that side and the speaker wiring down drivers side :)
unless I cant get the power wire through there, then Im going to do as you suggest and just drill through from the inside and pray I dont hit anything important. (on DSM forums that seems to be what happens to a lot of people....)
Reply With Quote
  #9  
Old 03-02-2010
d0sitmatr's Avatar
Member
Thread Starter
iTrader: (2)
 
Join Date: Jan 2010
Location: SFL
Posts: 706
update
I got the wire all ran and the system sounds awesome !
1 caveat though...
Im getting engine noise in the sub
I drilled through the FW right between/below the brake/clutch pedal, then I ran the power down the drivers side, through the same line that houses all the stock wiring. (kind of neat, there is an actual conduit for wiring ) I ran the switch line under the drivers seat and up into the center console on the same side to a power line supplied by the HU. I ran the RCA under the psngr seat into the hatch and then across from that side into the amp, the RCA and power line never cross, but the RCA does run near the ground wire for 1/2", I ran the ground wire to a bolt in the full rear of the hatch area.

so Im wondering if anyone can recommend a filter and what I need to install it too ?
also, it seems to only happen while a CD is playing, I dont hear anything with radio. (not sure if that is common or not)
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
FS: 2000 Mitsubishi Eclipse GS Ranger? Miscellaneous Items 1 07-30-2009 03:02 AM
anyone familiar with IDS? Toreador4x4 General Technical & Electrical 14 02-05-2009 01:29 PM
Does this pic look familiar to anyone!!!??? rideac1 General Ford Ranger Discussion 13 03-03-2006 01:20 PM
Eclipse over pioneer? fletch12518 Audio & Video Tech 17 02-04-2006 09:08 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:15 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.