finished my new install (almost) - Ranger-Forums - The Ultimate Ford Ranger Resource


Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-05-2008
Member
Thread Starter
 
Join Date: Dec 2007
Location: Independence, OH
Posts: 37
finished my new install (almost)

i did a new substage install in my 06 3.0 xlt.
components:
eD 13av.2
eD NINe.1
eD enetic 4awg wire

and i already have the sony cdx-gt810u

im finished with the install as far as the actual playing sound part goes. the rest i still have to do is all cosmetics. that includes finishing the amp rack and painting the rack and sub box. i also have a led fan mounted under the amp that needs to be hooked up, and some ccfl neons that will go under the sub box.


full install pics and a short vid (before my camera went dead) at link below.
all i can say is that this sub is crazy. lowest hitting sub i know. xover at 60-65hz, and it plays loud down to 10hz easy.

my whole dash, headunit, steering wheel, etc shakes 1/8th to a 1/4th inch.


linky:

http://www.icixsound.com/vb/showthread.php?t=51032


btw, this sub is 59 lbs, a 13" underhung driver designed to play loud with very good sq. it has around 30mm one way excursion.
the NINe.1 puts out [email protected] volts, and around 1450wrms at 14 volts.
however, my stock electrical only puts ot about 11.7volts when the sub hits giving me about 1100 watts.
Reply With Quote
  #2  
Old 04-06-2008
ranger_banger's Avatar
Member
 
Join Date: Nov 2006
Location: cedar falls, iowa
Posts: 405
oh boy that looks fun haha. How much money you got invested in all that? looks like it will certainly **** off your neighbors haha.
Reply With Quote
  #3  
Old 04-06-2008
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
Looks good
Reply With Quote
  #4  
Old 04-07-2008
rstangboi's Avatar
Member
 
Join Date: Jan 2008
Location: Davis, Ca
Posts: 2,583
yay for the use of eD
how'd u like their customer service?
ive seen mixed issues wit them.....and i want their 19ov.2.....bad....
Reply With Quote
  #5  
Old 04-12-2008
Member
Thread Starter
 
Join Date: Dec 2007
Location: Independence, OH
Posts: 37
thanks guys. sorry for late replies.

eD warranty and customer service is great. they have changed a lot since the previous problems. they have live support and all.

$=
350 for sub (free shipping)
255 for amp shipped (used)
40% off wire meant i only paid 16 bux for 20+ feet. (81 cents a foot)
2 boards of 3/4 inch mdf = 14 total
some #10 screws 2 bux
12ga speaker wire= 3.50 for 15ft or so
sony HU purchased previously 250 msrp got it off ebay for 170 shipped.


its definately loud as #[email protected]!. another owner of one of these has measured 140.4 db.
best part is, its a low end monster.

on deep bass songs, i can easily get the steering wheel, dash and headunit moving around 1/8th or 1/4th inch. the back horizontal window shakes pretty violently.

and this is with my truck being in mint condition basically. nothing is worn in at all, because it only has 30k mi of grandpa driving on it. the interior is still real tightly fitted together, so its pretty hard to get things moving.

when my camera starts to function properly, ill try to get a flex video posted.

until then thanks for the replies :)
Reply With Quote
  #6  
Old 04-12-2008
RazorsEDGE's Avatar
There's no lifeguard in the gene pool
iTrader: (4)
 
Join Date: Aug 2006
Location: New Mexico
Posts: 7,501
Wow man thats one hell of a sub. 60 lbs is a lot of sub!
Reply With Quote
  #7  
Old 04-12-2008
Member
Thread Starter
 
Join Date: Dec 2007
Location: Independence, OH
Posts: 37
yes it is. plus a 32lb box and a 15 or so lb amp.

it helps rear end traction in my rwd though :)
Reply With Quote
  #8  
Old 04-12-2008
Johnbaum13's Avatar
Member
iTrader: (1)
 
Join Date: Jan 2008
Location: Dallas, TX
Posts: 2,343
Jesus Freakin Christ! Thats insane! I love it!
I wouldn't worry too much about a drop to 11.7V when it hits. My drops that low before the cap too. I think thats just what the bat alone puts out under heavy load. The cap keeps my lights from dimming too much though. With my truck running I average about 14V, and 13.4 when it hits, so check again with it running.
And get a cap! a big amp and sub like that, you need to protect your factory electricals from the abuse!
Reply With Quote
  #9  
Old 04-13-2008
Member
Thread Starter
 
Join Date: Dec 2007
Location: Independence, OH
Posts: 37
well, i got wire on the way that ill be doing a big 3 with (4 gauge wire). that should help a lot considering the factory wiring is only 8 gauge it looks like.
im just hoping to get a higher voltage to my amps is about it. they 9.1 is rated 1200wrms at 12.5 volts, so if i can keep the voltage up, i could get a bit more power.

also, i just got a deal on a eD nine.4 amp, so now i have a 4 channel amp on the way :)

i like to spend money i guess.....
Reply With Quote
  #10  
Old 04-13-2008
meemooer's Avatar
Member
 
Join Date: Mar 2005
Location: Brunswick, Ohio
Posts: 336
damn dude, that is killer. Makes me want a system sometime soon.
Reply With Quote
  #11  
Old 04-21-2008
justdareme4's Avatar
Member
 
Join Date: Mar 2008
Location: Calumet MI
Posts: 44
very impressive
Reply With Quote
  #12  
Old 04-21-2008
WowMike2001's Avatar
Member
 
Join Date: Oct 2007
Location: Stevenson, WA
Posts: 2,583
Good stuff, youve got the same headunit I have... I've been using my Sansa MP3 player in the USB slot fo ra whiel now.. works perfectly

Nice sub by the way.. going sealed was the way to go
Reply With Quote
  #13  
Old 04-21-2008
Member
Thread Starter
 
Join Date: Dec 2007
Location: Independence, OH
Posts: 37
Quote:
Originally Posted by WowMike2001 View Post
Good stuff, youve got the same headunit I have... I've been using my Sansa MP3 player in the USB slot fo ra whiel now.. works perfectly

Nice sub by the way.. going sealed was the way to go
thanks

the headunit is nice, i may upgrade to a nice eclipse or something though so i can get more than a 3 band eq and bluetooth.

main reason for going sealed was space (will be moved into an s2000), and being able to play as low as i want (versus not being able to play much below port tuning).

i have a NINe.4 4 channel amp in my room but i need speakers.
also, last night i ran the wires for the new amp, and some 8 ga for a power inverter.

Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
almost(ALMOST) too good of a deal to pass up haha darangerdanger General Ford Ranger Discussion 17 08-25-2010 02:29 PM
Almost done pics...almost...new paint! wvcat Snapshots 38 06-18-2009 06:13 AM
Almost finished the Body Lift today... vansnxtweek 1" & 3" Body Lifts 45 03-22-2008 11:15 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:25 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.