Help!? For Real! - Ranger-Forums - The Ultimate Ford Ranger Resource


Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-22-2005
Member
Thread Starter
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
Help!? For Real!

Ok here we go. I got my component speakers in to day and of course tried hooking them uo through my amp. Got nothing but a fuzzy noise out of them? I Have a 4 channel rockford fosgate p4004 amp. When i saw that they were not working I then unpluged my subs and took the tweeters right to the connection where my subs "just had power" and still nothing? Wires and all connections are fine and right. tripple checked em'!! Is my next step to hook them up to the door speakers? Please help me if ya can!!! thanks!
Reply With Quote
  #2  
Old 11-22-2005
RF Veteran
 
Join Date: May 2005
Location: College Station, TX
Posts: 5,782
Check your grounds? Did you get components with seperate mids and tweeters? Or just buy tweeters and try to add them to your existing speakers? You might need crossovers if it's the latter.
Reply With Quote
  #3  
Old 11-23-2005
Member
Thread Starter
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
Quote:
Originally Posted by Gearhead61
Check your grounds? Did you get components with seperate mids and tweeters? Or just buy tweeters and try to add them to your existing speakers? You might need crossovers if it's the latter.
Yeah i just bought the tweeters nothing else. Grounds are fine. Rca's are hooked up right. just nothing????? Do do i just hook them up to the door speakers???? dunno?
Reply With Quote
  #4  
Old 11-23-2005
rangerxlt06's Avatar
Member
 
Join Date: Oct 2005
Location: Woodstock,CT
Posts: 109
Make sure you use cross overs or bass blockers, otherwise you will blow them.
Reply With Quote
  #5  
Old 11-23-2005
Member
Thread Starter
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
Cross overs are already with em?
Reply With Quote
  #6  
Old 11-23-2005
Member
Thread Starter
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
Yes I even followed my instruction on my amp booklet and still nothing???? hmmmmm
Reply With Quote
  #7  
Old 11-23-2005
Member
Thread Starter
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
Anyone know of a place to ask then?
Reply With Quote
  #8  
Old 11-23-2005
RF Veteran
 
Join Date: May 2005
Location: College Station, TX
Posts: 5,782
Don't go to best buy! See if you have an earmark audio, cartoys, or tweeter around and ask them. You will need to get some crossovers in order to make them work right like rangerxlt06 said
Reply With Quote
  #9  
Old 11-23-2005
Member
Thread Starter
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
but i said i already have cross overs on them
Reply With Quote
  #10  
Old 11-23-2005
KARPE's Avatar
Member
 
Join Date: Apr 2005
Location: Valrico, Fl 33594
Posts: 4,748
hook em up to the headunit first just to make sure the product works, then I'll try thinking about what could be the problem. I garuntee its something so simple you wouldnt even think to check it, cuz that always happens to me with my rockfords
Reply With Quote
  #11  
Old 11-23-2005
Member
Thread Starter
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
Quote:
Originally Posted by KARPE
hook em up to the headunit first just to make sure the product works, then I'll try thinking about what could be the problem. I garuntee its something so simple you wouldnt even think to check it, cuz that always happens to me with my rockfords
Yeah they work. Its just i have a 4 channel amp and I can also bridge it. But its weird cus I unhooked my subs and hooked the tweeters right up to where the sube were just pluged in and......nothing? I even fooled with the gain and passover? nothing
Reply With Quote
  #12  
Old 11-23-2005
dangerranger's Avatar
Member
 
Join Date: Aug 2005
Location: muskego, wi
Posts: 536
Rockford=
Reply With Quote
  #13  
Old 11-23-2005
Member
Thread Starter
 
Join Date: Oct 2005
Location: Havre De Grace,Md
Posts: 3,262
Ill agree with that sometime but overall their stuff is great! Just frickin stumped right now!
Reply With Quote
  #14  
Old 11-23-2005
Strider0O0's Avatar
Member
 
Join Date: Jul 2004
Location: Philadelphia, PA
Posts: 3,588
got a link or something like that so we can see the tweeters you've got? i may have misread something, but im a bit confused.. you've got just the tweeters, and a set of cross overs you're wanting to add?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Help real quick motosik831 Drivetrain Tech 2 06-08-2010 08:38 PM
Real Time Help Lowering Spare Tire MarkReye1 General Ford Ranger Discussion 3 05-03-2008 09:01 PM
torsion bar help. imma real noob! rangerboy101 Suspension Tech 13 11-07-2007 06:35 PM
wheel help....not real help...lol crawly1025 Wheels & Tires Semi-Tech 10 02-15-2007 01:13 PM
Need Math Help - 32" tires, Inaccurate speedo for 20K miles = how many real miles? TommyC General Ford Ranger Discussion 7 07-27-2006 06:12 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:24 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.