I broke a sub!!!! - Ranger-Forums - The Ultimate Ford Ranger Resource

Audio & Video Tech General discussion of audio and video for the Ford Ranger.

I broke a sub!!!!

Reply

 
 
 
  #1  
Old 11-17-2006
SouthernMudSlinger's Avatar
Member
Thread Starter
Join Date: Aug 2006
Location: Demorest,Ga
Posts: 1,724
I broke a sub!!!!

I was driving down the road today, and my subs started sounding weird, like something was hitting the subs. I couldn't figure out what was going on, until a while ago, and pulled the seat forward to watch them as the bass hit, and the rivit looking part of the sub on the inner part of the sub that connects the foam/rubber isolator from the frame of the sub to the cone had split apart. What happed? They are 12" Rockford Fosgate P1's. I wasn't over powering them either, each sub had about 125rms going to them, and the max rms is like 150. I've had them for about a year, and haven't had any problem with them. Although, that area does look kinda weak of a design. Luckily I still have my Lighning audio subs I can stick in there.

Heres a pic showing where it came apart.
Name:  x575P112S4-f.jpg
Views: 33
Size:  57.1 KB
 

Last edited by SouthernMudSlinger; 11-17-2006 at 06:21 PM.
Reply With Quote
  #2  
Old 11-17-2006
RockysFord's Avatar
Member
Join Date: May 2005
Location: Columbus Ohio
Posts: 2,782
Warrantee should cover it....But the cone is separating...Happens on alot of low end sups, i dont know why it would do it on a RF, specailly that low of RMS

Send it back to the store

Rocky
 
Reply With Quote
  #3  
Old 11-17-2006
SouthernMudSlinger's Avatar
Member
Thread Starter
Join Date: Aug 2006
Location: Demorest,Ga
Posts: 1,724
I bought them from crutchfield. Do you have to send anything in to get the warrenty?
 
Reply With Quote
  #4  
Old 11-17-2006
RockysFord's Avatar
Member
Join Date: May 2005
Location: Columbus Ohio
Posts: 2,782
Ummm i beleive you just ship it back to them or something....If it were me i would get on thier webcite and find the customer service number and talk to them....Because i would NOT pay the shipping to ship it back to them, its a defect in thier subwoofer

Rocky
 
Reply With Quote
  #5  
Old 11-17-2006
RockysFord's Avatar
Member
Join Date: May 2005
Location: Columbus Ohio
Posts: 2,782
Call 1-888-955-6000

It says they are open from 8am till midnights 7days a week

Rocky
 
Reply With Quote
  #6  
Old 11-17-2006
Member
Join Date: May 2004
Location: McKinney, TX
Posts: 2,123
After a year of use, I'd chalk it up sub par Rockford punch quality.
 
Reply With Quote
  #7  
Old 11-17-2006
GrafixGuy's Avatar
RF Veteran
iTrader: (3)
Join Date: Jan 2005
Location: Montgomery, AL
Posts: 8,703
you got a 12" in your single cab? man thats nice...
 
Reply With Quote
  #8  
Old 11-17-2006
SouthernMudSlinger's Avatar
Member
Thread Starter
Join Date: Aug 2006
Location: Demorest,Ga
Posts: 1,724
you got a 12" in your single cab? man thats nice...
got 2 of em.

Ok, I put one of my old lightning audio subs in, and I think they are out of phase of each other or something. The P1 doesn't look like its comming out at the same time when the bass hits, also noticed the lightning audio sub travels more than the P1. hmmmmmmmm
 
Reply With Quote
  #9  
Old 11-18-2006
Bhavesh's Avatar
Member
Join Date: Oct 2006
Location: City, State
Posts: 507
ehh...the latter problem could be many things...depends on the subs, the box, depends on the way it's wired, etc.
 
Reply With Quote
  #11  
Old 11-18-2006
l2en's Avatar
Member
Join Date: Dec 2005
Location: The Keystone State
Posts: 4,521
Originally Posted by Mnemonic
After a year of use, I'd chalk it up sub par Rockford punch quality.
x eleventy billion
 
Reply With Quote
  #12  
Old 11-18-2006
bamaboy's Avatar
Member
Join Date: Jun 2005
Location: ALabama
Posts: 531
i dont reccommend mixing subs
 
Reply With Quote
  #13  
Old 11-18-2006
SouthernMudSlinger's Avatar
Member
Thread Starter
Join Date: Aug 2006
Location: Demorest,Ga
Posts: 1,724
Im going to put my other lightning audio sub in because it will probably be awhile before I get the sub situation worked out (get it replace under warrenty or whatever). They just dont seem to be working too good together (the Lighning audio and P1 sub in the same box).
 
Reply With Quote
  #14  
Old 11-18-2006
KARPE's Avatar
Member
Join Date: Apr 2005
Location: Valrico, Fl 33594
Posts: 4,748
I have the same subs, and yeah they feel kinda cheap but they were buy one get one like 2 years ago and I was poor, they hit plenty hard for me, but I'm kinda hoping one breaks too so I have an excuse to upgrade!
 
Reply With Quote
  #15  
Old 11-18-2006
SouthernMudSlinger's Avatar
Member
Thread Starter
Join Date: Aug 2006
Location: Demorest,Ga
Posts: 1,724
I have the same subs, and yeah they feel kinda cheap but they were buy one get one like 2 years ago and I was poor, they hit plenty hard for me, but I'm kinda hoping one breaks too so I have an excuse to upgrade!
I think what did it was that the box is so tightly sealed, when you try to push both in at the same time, it wont hardly go in at all.
 
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bigandrw
Audio & Video Tech
43
07-15-2012 07:16 AM
pushdeck
Interior, Exterior, Electrical, & Misc.
1
05-02-2010 11:39 AM
crucialcolin
Audio & Video Tech
13
06-21-2008 10:13 PM
SouthernMudSlinger
Audio & Video Tech
29
11-30-2006 09:55 AM
mx98ranger
Audio & Video Tech
4
12-21-2005 09:45 PM


Thread Tools
Search this Thread
Quick Reply: I broke a sub!!!!


Contact Us Sitemap Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.