I got a setup how good is this amp? - Ranger-Forums - The Ultimate Ford Ranger Resource


Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-25-2007
Member
Thread Starter
 
Join Date: Jul 2007
Location: Sidman, PA
Posts: 24
I got a setup how good is this amp?

Well to start off i don't know alot about car audio. But i picked up 2 12" Polk audio subs in a ported box and a Alpine 2/1 channel MRV-T500 it's the V12 series. How good is that amp? The guy told me it's supose to be a 1000 watt amp for 2 ohms. I bought it all from the same guy. Then i picked up so 5 gage wiring from walmart. What do you guys say this setup is worth?



Reply With Quote
  #2  
Old 07-25-2007
redranger04g's Avatar
Member

iTrader: (2)
 
Join Date: Apr 2007
Location: Placentia, CA
Posts: 928
alpine sells good amps, but that V12 is really old, i havent seen one like that for a long time
Reply With Quote
  #3  
Old 07-25-2007
Silver's Avatar
Member
 
Join Date: Jun 2006
Location: edenton,nc
Posts: 2,708
last alpine amp i had ran for 9 years no problems and still in my old truck from what i been told
ill be getting one for my set up im working on now
Reply With Quote
  #4  
Old 07-25-2007
Lord Of War's Avatar
Member
iTrader: (2)
 
Join Date: Jan 2006
Location: Thornton, Colorado
Posts: 4,599
Polk is the ****. Alpine also make pretty good stuff. Nice set up.
Reply With Quote
  #5  
Old 07-25-2007
bryanjints's Avatar
Member
iTrader: (1)
 
Join Date: Dec 2005
Location: Mount Holly, NJ
Posts: 1,857
My friend had that amp it kicked 10's hard then I used it to kick some 12's worked good for them also.

That amp should work great for you. It is old but well made it should last you for a long time.
Reply With Quote
  #6  
Old 07-25-2007
07Ranger's Avatar
Member
 
Join Date: Mar 2007
Location: lima/dublin, ohio
Posts: 1,267
5guage? haha what!
Reply With Quote
  #7  
Old 07-25-2007
skh711's Avatar
Member
 
Join Date: Jun 2007
Location: Colora, Maryland
Posts: 34
yeah...walmart sells scoche or somethin like that and they use 5 gauge wire! kinda funny but its what i use too and it works just fine!
Reply With Quote
  #8  
Old 07-25-2007
Member
Thread Starter
 
Join Date: Jul 2007
Location: Sidman, PA
Posts: 24
Thanks for the replys the guy said it's a good amp. I bought the polks from him first and hooked them up to my friends amp and they work great they still have that new box smell. The wiring is the cheap Walmart stuff picked it up for $32.99 and a alittle light up red toggel switch. I wasn't about to pay top dollar for 4 gage from Circuit City. They wanted $79.99 plus 25.99 for RCA hook ups. So how many watts is this amp? I am guessing 500 by the name numbers and 1000 when its bridged. Next thing how much would you guys spend for the subs/box and amp? Also what year would you say the amp is? It was that Alpine amp or a 750 watt lighting audio amp.
Reply With Quote
  #9  
Old 07-25-2007
LowMaz's Avatar
Member
 
Join Date: Feb 2007
Location: Sterling/ Amherst, MA
Posts: 788
good choice on the wiring kit. it was rediculous what best buy charged for a wiring kit when i worked there.

i like the alpine amp, but lightning audio sells good products for little money!
Reply With Quote
  #10  
Old 07-25-2007
Member
 
Join Date: Jul 2007
Location: Plantersville, Tx
Posts: 21
alpines are very good amps, i have to say some of the best. defintly in my top 3 of brands. but myself personally i run strickly Rockford fosgate on amps.
Reply With Quote
  #11  
Old 07-26-2007
Member
Thread Starter
 
Join Date: Jul 2007
Location: Sidman, PA
Posts: 24
How old would you say my amp is? When i did a google search i got around 1996. Does that sound right? Do these prices sound right $160 for the subs/box and $90 for the amp then i payed $32.99 and $3.99 for the wiring and toggel switch plus tax?
Reply With Quote
  #12  
Old 07-26-2007
LowMaz's Avatar
Member
 
Join Date: Feb 2007
Location: Sterling/ Amherst, MA
Posts: 788
good deal on the subs/box. and as long as the amp bumps hard thats not a bad price. look how much newer 500w amps go for!
Reply With Quote
  #13  
Old 07-26-2007
seminaryranger's Avatar
Member
 
Join Date: Apr 2006
Location: Ganado, TX
Posts: 356
I own 2 different Alpine V12 mono amps and really like them. They do more than rated RMS power at 14 volts, and they run cool when pushed. Neither one has ever gone into protection mode because of heat.

I own a MRV-100M (200wrms @ 2ohm) I got in '98 and a MRD-M605 (600wrms @2ohm) I got a few months ago.
Reply With Quote
  #14  
Old 07-26-2007
Member
Thread Starter
 
Join Date: Jul 2007
Location: Sidman, PA
Posts: 24
I got my system finished today it pounds really hard. Bridged the amp i am running 1000 watts. Inside of my jeep it sounds awsome sounds better than my friends kicker L5 12 inch with a 600 watt amp even when he has his back seat folder down in his cavalier. I was really mad my sony explode head unit didn't have RCA hook ups so i bought a higher up Sony with a remote and sub controll. It's a real nice head unit for the money and lights up red to match my jeep better. Last thing to do is hook up a toggel switch to turn the amp off. I am very happy with the system. Total subs/box, amp, 4 speakers, and the head unit i have around $535. I proved to my friends you don't have to spend big bucks to have a good setup.
Reply With Quote
  #15  
Old 07-26-2007
Member
 
Join Date: Jul 2007
Location: hammond indiana
Posts: 71
nice setup you got. i plan on upgrading mine some more pretty soon
Reply With Quote
  #16  
Old 07-27-2007
Bumpncarstereo's Avatar
Member
iTrader: (3)
 
Join Date: Aug 2006
Location: btwn the Buff and the Roc
Posts: 1,302
not to bad, the only thing holding you back is what appears to be a prefab box that you have those subs in.
Reply With Quote
  #17  
Old 07-31-2007
Member
Thread Starter
 
Join Date: Jul 2007
Location: Sidman, PA
Posts: 24
Alright guys i need some more help. I thought the amp was 500 watts and when i birdged it that it was 1000 watts then. I opened my big mouth on another forum and now i need to find alittle out to back it up. Are these the specs for this amp?

Alpine MRV-T500
Output Power at 12V (20Hz ∼ 20kHz):
2 x 50W @ 4 ohms (0.08% THD)
2 x 100W @ 2 ohms (0.3% THD)
1 x 200W @ 4 ohms bridged (0.3% THD)
Output Power at 14.4V (20Hz ∼ 20kHz):
2 X 75W @ 4 ohms (0.08% THD)
2 x 100W @ 2 ohms (0.3% THD)
1 x 300W @ 4 ohms bridged (0.3% THD)
Freq. Response: 10Hz ∼ 50kHz (+0/-1 dB)
S/N Ratio: 100dBA (at rated power)

So how many watts am i running?
Reply With Quote
  #18  
Old 07-31-2007
JD JD is offline
Member
 
Join Date: Jun 2005
Location: Yukon, OK
Posts: 40
Who cares? Do you like the sound? If you feel you got a good deal, then it is a good value. Polks demo car has that box in it. It is actually a very well designed box tunned for the subwoofers that are in it. The front panels are paintable also.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
a good write-up of solid axle setup ( not ranger related ) cheese_man Suspension Tech 0 08-20-2010 04:13 PM
Want to Buy: 3.0l Good Clutch-Fan or E-Fan setup. Skuce Engine & Drivetrain 6 09-08-2009 10:46 PM
K&N Filter Setup... Bigwill41 Ranger-Forums Office 12 03-17-2005 01:31 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 01:34 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.