Just got Noise Filters!!!! - Ranger-Forums - The Ultimate Ford Ranger Resource


Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-15-2006
GrafixGuy's Avatar
RF Veteran
Thread Starter
iTrader: (3)
 
Join Date: Jan 2005
Location: Montgomery, AL
Posts: 8,703
Just got Noise Filters!!!!

Hey I just got these today so far I've installed the FM filter and it didn't help....and this other filter is kinda confision on how to wire it, gonna see if anyone could help me with it...

FM filter


Noise Filter
Name:  l003S25A.jpg
Views: 1
Size:  4.8 KB

see this morning I tried to install it I spliced into Radios power and the ground, well when I did that the radio would never cut off so I just removed everything and I'm using only the FM filter :(
Reply With Quote
  #2  
Old 04-15-2006
Rolldogg's Avatar
Member
 
Join Date: Jan 2006
Location: Ottawa, Ontario
Posts: 3,424
I've seen those, but I just think they're right up there with the Turbonator air turbine.....just a POS gimmick.
Reply With Quote
  #3  
Old 04-15-2006
jrpro130's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2005
Location: Florida
Posts: 5,057
it didn't work for me, i had those since i first installed my HU
Reply With Quote
  #4  
Old 04-15-2006
quest51210
Unregistered User
 
Posts: n/a
they work, but they are a patch for a bigger problem. if they didnt work rerun everything
Reply With Quote
  #5  
Old 04-16-2006
Member
 
Join Date: Feb 2005
Location: Edmonton, Alberta
Posts: 1,027
go get scosche RCA ground loop connectors if your having an alternator type noise coming out of the radio/stereo...they work awsome also check your grounds if you have amps.
Reply With Quote
  #6  
Old 04-16-2006
FireRanger's Avatar  
Join Date: May 2004
Location: CT
Posts: 0
RED = +12
Black = Ground
Blue = To devices +12 input (where the red used to go).

RF noise is a pain in the *** and filtration isn't always the option. If the noise is raditated (picked up by the antenna), than killing the souce is the only solution. It can be many things (plugs, wires, coil, alternator, etc).

If the noise is picked up in the power, then the filters sometimes help reduce it. Sometimes it is just more than a filter can block. Also, fixing the source would be a better solution.
Reply With Quote
  #7  
Old 04-16-2006
TheForce02's Avatar
Member
 
Join Date: Jun 2004
Location: Chino, CA
Posts: 846
when i hooked up my ipod with RC cables i was having this problem. i was using the Belkin charger with built in amp. and after some playing around i finally got rid of the noise.

i ended up hooking the ground for the 12v outlet(the one on my explorer center console) to the ground on my radio. now it is almost perfect, the only time i can hear it is with the sound on the ipod off, the radio and belkin amp all the way up, but i never need to run it like this so all is ok now.
Reply With Quote
  #8  
Old 04-16-2006
GrafixGuy's Avatar
RF Veteran
Thread Starter
iTrader: (3)
 
Join Date: Jan 2005
Location: Montgomery, AL
Posts: 8,703
well I don't have an amp, all I got is a Kenwood H/U and Pioneer 6x8s....I'm running BOSCH wires with Autolite plugs, will the interference happen when the spark plugs are gapped wrong? Also is there a better interference blocker? I'm taking the truck for paint this week so...I cant work on it :( I Know its not my fuel pump, I'nm seroisly comsidering XM radio or something b/c this popping is so annoying. See 1st thing in morning its horrible, after a day of crusing its sonds iight, that whats leading me torward it being the alternator....BTW just wanna say thanks for yall helping me on this...no one else knows what it is, they all say "hmm I dunno maybe its your aftermarket antenna" I know it aint b/c Ive had it for a year and half.....
Reply With Quote
  #9  
Old 04-16-2006
TheForce02's Avatar
Member
 
Join Date: Jun 2004
Location: Chino, CA
Posts: 846
i should have explained a little better what i was getting at.

did the noise begin when you got the aftermarket HU?
did you did the install or a shop?

if the noise began when you got the HU then check how the ground is hooked up for it. i think mine is just hooked up from the stock stereo wiring loom, but i don't know. when i was dealing with my ground issue i tried grounding it all over the truck, but going of the HU ground was the only one that worked. maybe it's shielded diff. i don't know
Reply With Quote
  #10  
Old 04-17-2006
GrafixGuy's Avatar
RF Veteran
Thread Starter
iTrader: (3)
 
Join Date: Jan 2005
Location: Montgomery, AL
Posts: 8,703
Well eben my factory did it when I plugged it in yesterday...It chages with the engine speed. After a day of crusing it gets better, like its the alternator, I'm gonna go to autozone or napa to get a new alternator prolly a bigger amp one, is there a specific model I should look for or ya'll recomend?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
K&N Filters will clogg your MAF! a311fanam Ranger Products, Company, & Member Reviews 32 11-16-2006 10:30 AM
Cold air intake/filters RNGMSTR 2.3L & 2.5L I4 Tech 0 03-26-2006 10:54 AM
K&N Air Filters???? bmb005 General Ford Ranger Discussion 29 01-16-2006 11:49 AM
Rough starting and fuel filters jbadd99 4.0L OHV & SOHC V6 Tech 15 11-25-2005 11:17 AM
k and n filters and intakes- are they worth the money? james13f 2.9L & 3.0L V6 Tech 31 04-27-2005 12:17 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:26 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.