kicker sub help - Ranger-Forums - The Ultimate Ford Ranger Resource


Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-08-2008
vic101's Avatar
Member
Thread Starter
 
Join Date: Feb 2008
Location: vancouver
Posts: 20
kicker sub help

have kicker solo-baric l5 sub in my truck right and when i paly my songs like hip hop and stuff it will have goodd bass .then the bass gaves out .so i have no load bass. guys know why is the sub f*ked?
Reply With Quote
  #2  
Old 02-12-2008
0sixsport's Avatar
Member
 
Join Date: Aug 2006
Location: Logan, Utah
Posts: 860
Could be an underpowered amp or loose ground cables.
Reply With Quote
  #3  
Old 02-12-2008
lifted97ranger's Avatar
Member
 
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1
sounds like an amp problem....
Reply With Quote
  #4  
Old 02-12-2008
schatten789's Avatar
Member
 
Join Date: Feb 2007
Location: Matagorda County, Texas
Posts: 735
I had the same problem, I just ran a bigger ground and a bigger power wire and that fixed it.

I also have the l5 sub, alot of bass, wile still sounding clean once its tunned.
Reply With Quote
  #5  
Old 03-18-2008
tj
Unregistered User
 
Posts: n/a
get anew sub
Reply With Quote
  #6  
Old 03-18-2008
elementsenjoi's Avatar
Member
iTrader: (2)
 
Join Date: Aug 2007
Location: 352 Florida
Posts: 1,301
how big is your amp? ^wtf?

Last edited by elementsenjoi; 03-18-2008 at 06:33 PM.
Reply With Quote
  #7  
Old 03-18-2008
vic101's Avatar
Member
Thread Starter
 
Join Date: Feb 2008
Location: vancouver
Posts: 20
its a 1000
Reply With Quote
  #8  
Old 03-18-2008
kyledm18's Avatar
Member
 
Join Date: Nov 2006
Location: Thornton N.H.
Posts: 519
what kinda amp is it?
Reply With Quote
  #9  
Old 03-19-2008
Urandaman's Avatar
Member
 
Join Date: Oct 2006
Location: wher ever uncle sam wants
Posts: 1,193
is your amp getting hot? it could be going into a protection mode to keep from frying...


And TJ.... i dont think your avatar is going to fly hahah
Reply With Quote
  #10  
Old 03-19-2008
vic101's Avatar
Member
Thread Starter
 
Join Date: Feb 2008
Location: vancouver
Posts: 20
no it not get hot.do u think the amp is ***?
Reply With Quote
  #11  
Old 03-19-2008
elementsenjoi's Avatar
Member
iTrader: (2)
 
Join Date: Aug 2007
Location: 352 Florida
Posts: 1,301
is the l5 a 12". i have an l7 15" that i had 1000 watt on and it did the same thing, i put a 2000w amp on it and now it is fine. the peak power for my 15" is 2000watts though. idk about the l5.
Reply With Quote
  #12  
Old 03-19-2008
schatten789's Avatar
Member
 
Join Date: Feb 2007
Location: Matagorda County, Texas
Posts: 735
Quote:
Originally Posted by elementsenjoi View Post
is the l5 a 12". i have an l7 15" that i had 1000 watt on and it did the same thing, i put a 2000w amp on it and now it is fine. the peak power for my 15" is 2000watts though. idk about the l5.
I dont remember exactly but I think it was 600rms and 1000 max or 1200max dont remember which. I have a 750 watt amp on mine and it works fine every since I put the right guage wire on it. Hits hard enough to make the crack in my windshield bigger.
Reply With Quote
  #13  
Old 03-19-2008
timpat92855's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2006
Location: Lousiville, MS
Posts: 1,067
the l5 depends on model...my old one was 450rms but the new ones are 600rms...sounds like your amp is going into protection mode...either power shortage, bad ground or heat buildup...is the amp where it can get air? does the amp have a internal cooling fan? what gauge wire did u run?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
amps to go with kicker sub. DeMar17 Audio & Video Tech 7 06-04-2009 12:41 PM
Kicker L5 10" sub in ported box, Kicker KX600.1 Amp FS in Fort Lauderdale Florida jrpro130 Interior, Exterior, Electrical, & Misc. 12 05-06-2009 11:04 PM
Wiring a kicker 2 ohm sub ChicksDigIt Audio & Video Tech 12 03-03-2009 09:12 PM
Kicker SSMB8 SS Series Mid bass Sub Bence Audio & Video Tech 0 07-13-2008 01:59 PM
Kicker Sub Help!!! chiodosbpb Audio & Video Tech 10 07-02-2008 10:10 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:20 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.