My new subs :) - Ranger-Forums - The Ultimate Ford Ranger Resource


Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-03-2007
07Ranger's Avatar
Member
Thread Starter
 
Join Date: Mar 2007
Location: lima/dublin, ohio
Posts: 1,267
My new subs :)

i have the 2 8's installed, the box will be carpeted tonight, and so will the amp rack. i got excited and forgot to include the rack but w/e here it is, pics up later when cosmetics are finished. i have vids uploading too. i have an optima yellow top on the way, soon i will do the big 3, big 4 including the battery!


Name:  DSC00408.jpg
Views: 2
Size:  33.6 KB
Name:  DSC00411.jpg
Views: 2
Size:  54.5 KB
Name:  DSC01175.jpg
Views: 2
Size:  53.9 KB
Name:  DSC01176.jpg
Views: 1
Size:  80.9 KB
Reply With Quote
  #2  
Old 10-03-2007
Red_Ak_Ranger's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2004
Posts: 17,221
sweet lookin
Reply With Quote
  #3  
Old 10-03-2007
07Ranger's Avatar
Member
Thread Starter
 
Join Date: Mar 2007
Location: lima/dublin, ohio
Posts: 1,267
heres a video, more uploading




Last edited by 07Ranger; 10-03-2007 at 11:16 PM.
Reply With Quote
  #4  
Old 10-04-2007
Member
 
Join Date: Mar 2007
Location: Perry, Florida
Posts: 95
how much power rms are you giving those 8s. i have a 12 on 457rms and my lights don't dim...j/w
Reply With Quote
  #5  
Old 10-04-2007
5speedin2.3's Avatar
Member
 
Join Date: May 2005
Location: Livonia, Mi
Posts: 12
nice, i had one of them subs, it was very loud and clean.
then one of the flexible wire things on the sub broke off and it wasn't repairable.
Reply With Quote
  #6  
Old 10-04-2007
Legion's Avatar
Member
 
Join Date: Mar 2007
Location: Austin, TX
Posts: 288
boom boom boom =]
Reply With Quote
  #7  
Old 10-04-2007
RockysFord's Avatar
Member
 
Join Date: May 2005
Location: Columbus Ohio
Posts: 2,782
Hey ill sell you my 400 watt mono alpine amp... :-)

Rocky
Reply With Quote
  #8  
Old 10-04-2007
07Ranger's Avatar
Member
Thread Starter
 
Join Date: Mar 2007
Location: lima/dublin, ohio
Posts: 1,267
Quote:
Originally Posted by Mazdaman99
how much power rms are you giving those 8s. i have a 12 on 457rms and my lights don't dim...j/w

500 each its wired to 1000x1 @ 1ohm
Reply With Quote
  #9  
Old 10-05-2007
ranger_banger's Avatar
Member
 
Join Date: Nov 2006
Location: cedar falls, iowa
Posts: 405
Quote:
Originally Posted by 5speedin2.3
nice, i had one of them subs, it was very loud and clean.
then one of the flexible wire things on the sub broke off and it wasn't repairable.
On my L5 (traded it for my half blow up audiobahn) the #2 negative lead broke off and my dad soldered it back on.

and on my JL's i kept braking them off the cone like every week, Xacto knifed the cone off and resolded it.

Nice choic on the 8's, i want to do 2 8's in a custom Center console eventually.
Reply With Quote
  #10  
Old 10-05-2007
bryce-man's Avatar
Member
 
Join Date: Nov 2006
Location: beach cities,CA
Posts: 154
yeah you deff need the big three and that new batt if 1000 watts is doing that to your electrical

did you set the gains right? DMM?
and please tell me your not using bass boost LOL!
Reply With Quote
  #11  
Old 10-05-2007
07Ranger's Avatar
Member
Thread Starter
 
Join Date: Mar 2007
Location: lima/dublin, ohio
Posts: 1,267
Quote:
Originally Posted by bryce-man
yeah you deff need the big three and that new batt if 1000 watts is doing that to your electrical

did you set the gains right? DMM?
and please tell me your not using bass boost LOL!
hah no bass boost here. amp doesn have it anyway. never used it. it was completely tuned on the vid, but the gains were set lower becuase i didnt know what this could handle. i had to research the subs first, the gains are accurate now though, i can take another vid if you would like but i think the turnout will be the same.
Reply With Quote
  #12  
Old 10-15-2007
07Ranger's Avatar
Member
Thread Starter
 
Join Date: Mar 2007
Location: lima/dublin, ohio
Posts: 1,267
everything is hooked up and the box is carpeted. the dimming went away!
Reply With Quote
  #13  
Old 10-15-2007
5speedin2.3's Avatar
Member
 
Join Date: May 2005
Location: Livonia, Mi
Posts: 12
Quote:
Originally Posted by ranger_banger
On my L5 (traded it for my half blow up audiobahn) the #2 negative lead broke off and my dad soldered it back on.

and on my JL's i kept braking them off the cone like every week, Xacto knifed the cone off and resolded it.

Nice choic on the 8's, i want to do 2 8's in a custom Center console eventually.
yeah, i did that twice, oh well, its in the trash now.
Reply With Quote
  #14  
Old 10-15-2007
gatorblue92's Avatar
RF Veteran
 
Join Date: Jun 2004
Location: Delaware
Posts: 8,238
looks pretty good
Reply With Quote
  #15  
Old 10-15-2007
eguy208's Avatar
Member
 
Join Date: Feb 2006
Location: Ga
Posts: 311
I have the same subs, they pretty darn hard for 8's.

Nice videos....

-Levino
Reply With Quote
  #16  
Old 10-15-2007
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
Nice set up, I think i'm gonna go with 1 12", but if i dont its defn 2 8"s. Set-up looks great!
Reply With Quote
  #17  
Old 10-15-2007
07Ranger's Avatar
Member
Thread Starter
 
Join Date: Mar 2007
Location: lima/dublin, ohio
Posts: 1,267
yea i love them!
Reply With Quote
  #18  
Old 10-15-2007
taknotes's Avatar
Member
iTrader: (4)
 
Join Date: Aug 2006
Location: nc
Posts: 2,104
Quote:
Originally Posted by 04blackedge
Nice set up, I think i'm gonna go with 1 12", but if i dont its defn 2 8"s.
thats what she said!!!! PWNT!!!!!!!!!!!!!!!!!
Reply With Quote
  #19  
Old 10-15-2007
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
hahah thats so wrong, in many ways.
Reply With Quote
  #20  
Old 10-15-2007
taknotes's Avatar
Member
iTrader: (4)
 
Join Date: Aug 2006
Location: nc
Posts: 2,104
oh but you said it!!! lol
Reply With Quote
  #21  
Old 10-15-2007
07Ranger's Avatar
Member
Thread Starter
 
Join Date: Mar 2007
Location: lima/dublin, ohio
Posts: 1,267
haha your all wrong!
Reply With Quote
  #22  
Old 10-15-2007
b-n-t09's Avatar
Member
 
Join Date: Apr 2007
Location: Arkansas
Posts: 184
what kind of cd player is that? I like how it takes up the whole space where it goes like stock. Mine has that ghey cubby hole under my cd player
Reply With Quote
  #23  
Old 10-15-2007
07Ranger's Avatar
Member
Thread Starter
 
Join Date: Mar 2007
Location: lima/dublin, ohio
Posts: 1,267
mine has a cubby too
Reply With Quote
  #24  
Old 10-15-2007
b-n-t09's Avatar
Member
 
Join Date: Apr 2007
Location: Arkansas
Posts: 184
Oh ok for some reason it looked like it was a double din
Reply With Quote
  #25  
Old 10-15-2007
07Ranger's Avatar
Member
Thread Starter
 
Join Date: Mar 2007
Location: lima/dublin, ohio
Posts: 1,267
haha no
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Got some new subs... kinda Lord Of War Snapshots 20 02-14-2010 11:56 PM
New Subs and Niteshade wyldechild Snapshots 19 11-04-2009 07:35 PM
Just looking for ideas for now on new subs... fletch12518 Audio & Video Tech 38 11-01-2006 10:53 AM
New subs and box. Got a question. fletch12518 Audio & Video Tech 22 05-29-2006 06:46 PM
RE's new subs info bamaboy Audio & Video Tech 16 02-16-2006 03:53 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:59 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.