Radio static driving me nuttz! Help!! - Ranger-Forums - The Ultimate Ford Ranger Resource


Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-17-2011
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2010
Location: hawaii
Posts: 48
Radio static driving me nuttz! Help!!

So I bought my truck new last year and I installed a full alpine system in it including there Bluetooth. After installing everything it all worked great but I noticed while driving on day my reception for my am and fm stations greatly lost reception strength, so I tore the complete system apart hoping to find a loose connection or something but I didn't. Has any one experienced something like this?!? Please help
Reply With Quote
  #2  
Old 04-17-2011
04RangerDave's Avatar
JDM> RANGER

iTrader: (3)
 
Join Date: Jul 2010
Location: RI
Posts: 5,030
do u have hids?
Reply With Quote
  #3  
Old 04-17-2011
rangerrunner11's Avatar
Member
 
Join Date: Feb 2011
Location: .
Posts: 1,018
I have heard of this before and I believe someone recommended a part or piece from Radioshack that cut down on FM static. He said rangers are notorious for ths problem and the part is something easily added on ad cheap. I do not however know what it is called. Use google I guess but I have seen this before!!!
Reply With Quote
  #4  
Old 04-17-2011
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2010
Location: hawaii
Posts: 48
No hids, I just remembered that I have a life time support at crutchfield and im going to give them a call and hopefully they know what's the problem.
Reply With Quote
  #5  
Old 04-18-2011
trextegra's Avatar
Member
 
Join Date: Apr 2010
Location: Beacon Falls CT
Posts: 304
check your grounds i dont use am or fm im a serious guy buy after installing my pioneer my reception got better and in my experience as an a/v installer a couple years ago i kno that alpine normally will do the same could be a faulty unit
Reply With Quote
  #6  
Old 04-18-2011
RLong31's Avatar
The Ban Hammer
iTrader: (5)
 
Join Date: Jul 2009
Location: Monrovia, IN
Posts: 2,629
When I worked at best buy in car audio, we would always have people complain about losing reception of their favorite stations after switching from a stock stereo to aftermarket. What I was told was the antenna strength in the aftermarket radios was not as strong as stock stereos. That was 5 years ago, so maybe things have changed. Or maybe it's not true at all

Also, I would check for bad grounds... power wires running next to audio wires can cause some issues too. Hope you get it figured out.
Reply With Quote
  #7  
Old 04-18-2011
trextegra's Avatar
Member
 
Join Date: Apr 2010
Location: Beacon Falls CT
Posts: 304
no offense but best buy doesnt have the best stuff and it doesnt supprise me they would tell you to say that they dont want to pay you to diagnose problems they want to get as many customers in and out... im out of the car audio business now and am work in high end home theatres and you wouldnt believe how many geek squad take overs we get and what a crappy job they do and terrible customer service they have
Reply With Quote
  #8  
Old 04-18-2011
Member
Thread Starter
iTrader: (1)
 
Join Date: Mar 2010
Location: hawaii
Posts: 48
whats the point of crutch fields tech support? The guy tells me to remove my radio and stick a metal clothes hanger in the antenna port on the deck and see if it fixes it and that eliminates the wiring, and if its the deck call alpine. i mean that makes since to stick the clothes hanger but why dont they just tell you from the beginning to call alpine cause we dont know how to help you other then to stick a clothes hanger and see if it fixes it.
Reply With Quote
  #9  
Old 04-18-2011
trextegra's Avatar
Member
 
Join Date: Apr 2010
Location: Beacon Falls CT
Posts: 304
hahahhahahahhahahahhah get the f*ck outta here hahahahahhah
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Hydro static lock & hydro seizing help! DaisyDuke General Technical & Electrical 39 06-12-2009 10:31 PM
Static Cling window tint? SouthernMudSlinger General Ford Ranger Discussion 36 03-18-2007 12:25 PM
Help with static shock from seat covers sem1845 General Ford Ranger Discussion 19 02-16-2007 11:06 AM
FM radio static from Hid balists MonsterGuy General Technical & Electrical 25 11-14-2006 04:04 PM
Static W/new HU rangerxlt06 Audio & Video Tech 7 10-31-2005 09:36 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:31 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.