Stupid Question - Ranger-Forums - The Ultimate Ford Ranger Resource


Audio & Video Tech General discussion of audio and video for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-31-2004
Skyjacker_44's Avatar
Member
Thread Starter
 
Join Date: Jul 2004
Location: Hillsboro,Texas
Posts: 1,079
OK guys i'v been rolling around town with a system but it hasn't been working..and i'v been rewireing and looking and regrounding and all that kind of good stuff.but i noticed my RCA cables have a slash in them....i'm not sure if it still works with a slash in the cable could i splice the cable and reconnect it and would it still work...i'm not real fond of RCA cables and i'm not sure if they'll work spliced..any help would be greatful
Reply With Quote
  #2  
Old 08-31-2004
Member
 
Join Date: May 2004
Location: McKinney, TX
Posts: 2,123
Yeah, you can splice them, but don't count on getting great signal quality from them again.
Reply With Quote
  #3  
Old 08-31-2004
Skyjacker_44's Avatar
Member
Thread Starter
 
Join Date: Jul 2004
Location: Hillsboro,Texas
Posts: 1,079
well lol i'm makeing a trip to waco to get some new suff anyway and i'm gonna get my amp and sub checked. to make sure i didn't fry anything the otehr day...thanks for the help
Reply With Quote
  #4  
Old 08-31-2004
Member
 
Join Date: May 2004
Location: McKinney, TX
Posts: 2,123
I hear ya. When I traded in my 03 ranger for an 04 ranger, I didn't have my torx bolts to unbolt my seats. I had 6 channels of Monster cable RCA's running between my seats under the mat. They were worth about 160 bucks. No way was I gonna leave them in there, but no way could I get them out. So I sniped them off. Oh well... I was in a rush...
Reply With Quote
  #5  
Old 08-31-2004
aftermarket's Avatar
Member
 
Join Date: Jul 2004
Location: ab, ab
Posts: 655
Just drop in and see a tech installer at a local car audio shop. For a few dollars, he'll be able to pinpoint what exactly you need to fix, save you a lot of time, effort and fustration.
Reply With Quote
  #6  
Old 08-31-2004
Skyjacker_44's Avatar
Member
Thread Starter
 
Join Date: Jul 2004
Location: Hillsboro,Texas
Posts: 1,079
Yeah thats what i plan on doing..i didn't make it up down to waco today but i'm gonna go this weekend. i live in a very small town and the closes shop is in Waco 30 miles away so i'm just gonna see what happends....but the thing thats tripping me out is the light on the amp is working saying that every things hooked up right but nothing is comeing out of the speaker unless i'm messing with the High-low freq on the amp and when it goes to low it goes "bump" and thats all that happends..so i'm clueless
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Stupid leak, stupid question puntadigital 2.9L & 3.0L V6 Tech 8 03-24-2011 09:13 PM
STUPID!STUPID!STUPID! jtfoxman General Ford Ranger Discussion 14 07-30-2009 12:42 AM
Stupid wind. Stupid tree. Sixt9coug General Ford Ranger Discussion 9 01-30-2009 03:16 PM
stupid, stupid truck purekaos26 General Ford Ranger Discussion 10 12-24-2005 10:01 AM
Stupid, stupid man.... aftermarket Suspension Tech 16 07-20-2005 03:41 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:29 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.