4wd clicking in cab?!?!?! - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-30-2010
02rangermayhem's Avatar
Member
Thread Starter
 
Join Date: Jan 2008
Location: C.Springs
Posts: 573
4wd clicking in cab?!?!?!

this morning i noticed a clicking noise coming from the passenger floor board somewhere under the dash. it had been driving me crazy all day trying to locate it. i played with all the ac controls thinking the ac(given its in the same location) may have something to do with the noise.... nothing.

i then moved the 4wd switch to 4H..... nothing. put the truck in 4L..... nothing. it then dawned on me what that sound is. its the same clicking i hear from switching my transfer case between gears.

i used my 4wd to aid the trailer i was towing into position this morning(before all this) and it worked perfect.

i have already searched this problem and i dont have any flashing/solid 4wd lights on my dash. i dont know if its the motor but i would assume its not cause i have a constant clicking about ever few seconds.

(click...(2sec)...click...(5sec)...click...(2sec). ..click...(5sec)... so on and so forth.....

could this be a result to a faulty motor? something electrical?
Reply With Quote
  #2  
Old 08-03-2010
02rangermayhem's Avatar
Member
Thread Starter
 
Join Date: Jan 2008
Location: C.Springs
Posts: 573
3 days.... no responses?......


any way, replaced the t-case motor and still having the same problem and no 4wd. help?
Reply With Quote
  #3  
Old 08-17-2010
Keeferes's Avatar
Member
 
Join Date: Aug 2010
Location: Baltic
Posts: 32
Mine was because my vacuum lines between the hubs were bad. I got the clicking and flashing to stop, but now I think I may have a bum hub cause I have the 4 hi and 4 lo light working, but not actually driving the front wheels. I am going to replace the entire line first and make sure the spongyness isnt what is kicking it out. I can get power on flat level surface, but as soon as I incline the fronts stop.

Hope it helps.
Reply With Quote
  #4  
Old 08-18-2010
02rangermayhem's Avatar
Member
Thread Starter
 
Join Date: Jan 2008
Location: C.Springs
Posts: 573
turns out it was my ecm. and i jus got a 1354m so good bye elec. tcase
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
4WD High and 4WD Low lights flash while driving in 2WD bleech1 General Technical & Electrical 9 11-27-2016 01:30 PM
How can I tow a 4wd ranger with a 4wd ranger? wvcat General Ford Ranger Discussion 12 06-23-2007 04:31 PM
attn: 4wd guys, trucks pulls L/R in 4wd? 01xltranger4x4 Drivetrain Tech 27 06-06-2007 09:13 PM
4WD and 4WD low lights flash periodically HarryTasker Drivetrain Tech 10 01-19-2007 07:16 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:31 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.