4wd problem again! - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-22-2010
Member
Thread Starter
 
Join Date: May 2009
Location: Lawrenceville GA
Posts: 4
4wd problem again!

ok guys im somewhat a newbie to this forum, not a newbie to 4wds or rangers,

I picked up a ranger from a family member not too long ago, its a 1999 4.0 ohv supercab 4x4 with open 4.10 gears 5 speed auto,

heres the problem, i had the notorious 4wd low and 4wd high light flashing 6 times when i start it and like every 2 minutes, I thought hey maybe its the transfer case motor, so i tried another one, started it up, still had the flash, so i put the old one back on, about a day later the lights stopped flashing and the transfer case became functional!!! i was stoked!

Took it offroading and damn,, no 4wd, front driveshaft turning and so were the cv's, but the hubs werent locking, so I did the pvh mod by removing the spring, tried it out, PERFECT 4WD!!!

this was two days ago, just now, about 45 miles later, the light starts flashing again.. no 4wd... any ideas??? I have the urge to go wheeling SOOOO bad but i just cant knowing im stuck at 2wd...

any help will be seriously appreciated
Reply With Quote
  #2  
Old 07-22-2010
pcollins's Avatar
Member
 
Join Date: Apr 2010
Location: Walworth, NY
Posts: 493
get down there and tap on the motor with a hammer. if it starts to work, then you have a bad motor. theres a procedure for cleaning and fixing it. or get a new one.
Reply With Quote
  #3  
Old 07-22-2010
Member
Thread Starter
 
Join Date: May 2009
Location: Lawrenceville GA
Posts: 4
Ok guys took the transfer case motor off and pulled the blue disc apart and cleaned the nasty contacts, cleaned the cog and worm gear, lined it all back up and reinstalled it, 4wd worked!!!!

This was on my lunch break, just got in the truck to go home, no flashing lights, got back in it again to go get some food, light are flashing again with no 4wd!!!

Was it me unplugging the motor that may have reset something and let it work, or was it me cleaning the motor? Either way it was working again. Now it's not! Help me please?!!
Reply With Quote
  #4  
Old 07-22-2010
Member
Thread Starter
 
Join Date: May 2009
Location: Lawrenceville GA
Posts: 4
Just got home and had it bind up turning in, andddd I was thinking my 4wd didn't work, I was wrong it's stuck in 4wd high, I tried taking the motor off and manually turning it to 2wd. Didn't work, now what?!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
The Ranger WIll Be 4wd Again Soon.. SteveOh General Ford Ranger Discussion 4 09-20-2009 06:14 PM
on again off again zorki1 DOHC - 2.3L Duratec / Mazda L Engines 6 02-02-2009 03:02 PM
How can I tow a 4wd ranger with a 4wd ranger? wvcat General Ford Ranger Discussion 12 06-23-2007 04:31 PM
attn: 4wd guys, trucks pulls L/R in 4wd? 01xltranger4x4 Drivetrain Tech 27 06-06-2007 09:13 PM
4WD and 4WD low lights flash periodically HarryTasker Drivetrain Tech 10 01-19-2007 07:16 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:45 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.