Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

4x4 problem

  #1  
Old 06-03-2006
Member
Thread Starter
Join Date: Jun 2006
Location: LP, FL
Posts: 5
4x4 problem

i was playing in the sand hills and when i went to put it iin 2wd it made a continus click sound(like it does when you shidft form 2wd to 4wd) but it did it like 5 times. Now when i drive my 4h and 4lo light blink, and the truck will not go into 4x4. I have an electric shift (the one with the **** next to the radio). Any ideas what hte problem is, or how much $$$ to fix it?it is a 1999 ford ranger.


Thanks
 
  #2  
Old 06-03-2006
Red_Ak_Ranger's Avatar
RF Veteran
iTrader: (1)
Join Date: Oct 2004
Posts: 17,221
might wanna take it to the dealer. I had a similiar problem. Might be the auto transfercase.

Aaron
 
  #3  
Old 06-03-2006
Member
Join Date: Nov 2005
Location: Aberdeen and Salisbury MD
Posts: 1,840
get manual locking hubs from warn or something. my 97 did the same thing. it ended up taking like 10 mins to change the hubs out.
 
  #4  
Old 06-03-2006
Red_Ak_Ranger's Avatar
RF Veteran
iTrader: (1)
Join Date: Oct 2004
Posts: 17,221
Originally Posted by tonkaranger04
get manual locking hubs from warn or something. my 97 did the same thing. it ended up taking like 10 mins to change the hubs out.

97 and 99 are mucho different.

Also, we 99'ers have REALLY CRAPPY FRONT HUBS. They do go out, and ford will replace them with newer hubs. Just to let you know, Pulse Vacuum Hubs suck.

Aaron
 
  #5  
Old 06-03-2006
Member
Thread Starter
Join Date: Jun 2006
Location: LP, FL
Posts: 5
how much do hubs cost, and how hard are they to change.....i am 16 years old and always broke......and i dont have acess to much tools.....the truck is not under warenty so i wantto avoid the dealer at all posibility.
 
  #6  
Old 06-03-2006
Red_Ak_Ranger's Avatar
RF Veteran
iTrader: (1)
Join Date: Oct 2004
Posts: 17,221
Junkyards would be your friend.
 
  #7  
Old 06-03-2006
Member
Join Date: Nov 2005
Location: Aberdeen and Salisbury MD
Posts: 1,840
Originally Posted by Red_Ak_Ranger
97 and 99 are mucho different.

Also, we 99'ers have REALLY CRAPPY FRONT HUBS. They do go out, and ford will replace them with newer hubs. Just to let you know, Pulse Vacuum Hubs suck.

Aaron
word thanx man did not know that they changed the hubs. could he still get manual hubs or not. god i love this site i learn something new everyday
 
  #8  
Old 06-03-2006
Red_Ak_Ranger's Avatar
RF Veteran
iTrader: (1)
Join Date: Oct 2004
Posts: 17,221
Yes he could. Let me do a search and i'll find some stuff on it.

Aaron
 
  #9  
Old 06-03-2006
Red_Ak_Ranger's Avatar
RF Veteran
iTrader: (1)
Join Date: Oct 2004
Posts: 17,221
Here's a tech guide for tcase trouble shooting, kinda short but there's more on site.

http://www.therangerstation.com/tech...leshooting.htm

*******
99 hub swap.
http://www.therangerstation.com/tech.../99hubswap.htm

*******

this is how you would "manualize" the pre 98s. http://www.therangerstation.com/Maga...r2002/hubs.htm

Aaron
 
  #10  
Old 06-04-2006
Member
Thread Starter
Join Date: Jun 2006
Location: LP, FL
Posts: 5
thanks...i guess i am just gonnna end up taking it to the dealer
 
  #11  
Old 06-05-2006
Member
Thread Starter
Join Date: Jun 2006
Location: LP, FL
Posts: 5
is there a way i can make the 4hi and 4lo lights quit blinking
 
  #12  
Old 06-06-2006
Member
Join Date: Sep 2005
Location: Charlotte, NC
Posts: 561
I would start by checking the shift motor and go from there. Heres a teardown guide.

http://www.therangerstation.com/tech...shiftmotor.htm
 
  #13  
Old 06-06-2006
Kanoeking's Avatar
Member
Join Date: Nov 2005
Location: Murderapolis
Posts: 748
Originally Posted by Cape Fear
I would start by checking the shift motor and go from there. Heres a teardown guide.

http://www.therangerstation.com/tech...shiftmotor.htm

+1. Mine did the same thing. I tore apart the shift motor and douched out the grime. Works like a charm now!

As for manual hubs on a 99....well they do have them in the USA now...they are made by AVM of Brazil.

Clicky -----> http://www.therangerstation.com/foru...howtopic=45606
 
  #14  
Old 06-06-2006
Member
Join Date: Nov 2004
Location:
Posts: 3,115
I had the opposite problem one time. I could not get mine to go into 4lo it would click and shift in but then shift back out. Mine was an electronic contact that tells the truck what t-case is shifted into(something like that).
 
  #15  
Old 06-06-2006
Kanoeking's Avatar
Member
Join Date: Nov 2005
Location: Murderapolis
Posts: 748
Originally Posted by Ranger1
I had the opposite problem one time. I could not get mine to go into 4lo it would click and shift in but then shift back out. Mine was an electronic contact that tells the truck what t-case is shifted into(something like that).
Yeah with the BW 1354e the range position sensor, located on the side of the t-case...I think there are 3 wires for it, is controlled/regulated throught the blue shift motor which in turn is controlled by a flip of a switch controlled by you... either one can go bad, and if it is the range position sensor you better flush your t-case and your tranny and all the coolers, ect. The sensor gets effed up by metal contaminent shavings in the atf. So I suggest pulling the sensor, looking for metal shavings and if you find then, flush the system and change filters.
 
  #16  
Old 07-24-2006
Member
Thread Starter
Join Date: Jun 2006
Location: LP, FL
Posts: 5
ok, i finally saved up some money and took it to the dealer..they said it was the electronic shift motor and that it needs to be replaced....but is it $700 for parts and labor, does that sound right, i ma not sure how much a shift motor is supposed to call, i just got a voicemail, i have to call back in the morning and i was just wondering if i should go for it or if anyone thinks that is a little pricy
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
2003Ranger
General Technical & Electrical
13
08-24-2011 02:40 AM
ChargerOnDavins
General Technical & Electrical
4
10-03-2010 05:58 AM
1993_ranger
Drivetrain Tech
0
09-18-2008 09:22 AM
Bourgeois88
Drivetrain Tech
8
08-23-2006 09:25 AM
QWIKSNK
Drivetrain Tech
11
06-13-2006 01:02 PM


Thread Tools
Search this Thread
Quick Reply: 4x4 problem


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.