97 2.3 5spd manual, Clutch engages halfway?? - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-01-2011
Hellion's Avatar
Member
Thread Starter
 
Join Date: Aug 2007
Location: El Cajon, CA
Posts: 370
97 2.3 5spd manual, Clutch pedal Really sloppy for first half of movement.??

So anyways i was in a risky spot with traffic and had to dump clutch to get out there, worked fine. shifted to second, and then it felt like the clutch pedal was being pressed in nearly all the way when it wasnt, give it gas and it would just feather alot. barely any truck movement.

sat on the side of the road and checked for leaks or breaks on anything and didnt find any, thought it might be a stuck release bearing so i thumped the clutch pedal for a min, worked kinda, now i get half clutch engagement....MAX. still shifts fine, but has very low friction now, and the clutch pedal pushes to about 1 inch off the floor and gets kinda tough to press the rest of the way, (To engage the neutral safety switch to start it i have to do this.)

So anyways, im kinda at a loss for verification, i KNOW its not the friction plate or pressure pad, and the release bearing and slave are one unit, but is it my master cylinder or slave?
No Air bubbles noticed, fluid level hasn't dropped in the slightest, poped the view port on tranny and had girly pump pedal and could physicaly see things moving. SO CONFUSED!

Last edited by Hellion; 04-04-2011 at 03:37 PM. Reason: Different symptom, same story
Reply With Quote
  #2  
Old 04-02-2011
Hellion's Avatar
Member
Thread Starter
 
Join Date: Aug 2007
Location: El Cajon, CA
Posts: 370
*Shameless self bump, nothin yet huh?
Reply With Quote
  #3  
Old 04-02-2011
djfllmn's Avatar
Moderator
 
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
try bleeding it and see what happens
Reply With Quote
  #4  
Old 04-04-2011
Hellion's Avatar
Member
Thread Starter
 
Join Date: Aug 2007
Location: El Cajon, CA
Posts: 370
well i ended upreplacing the slave and it fixed the problem, and before i hooked it up i flushed the master, then bleed the two of them with all fresh fluid. Clutch starts to grab firction really quick from the floor, before i had to let it out nearly half way just to feather it.... odd thing now though when i go to depress the pedal it feels like the first half of the pedal movement barely even has resisntance at all. any ideas why?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Clutch engages at the top Sbcjeep Drivetrain Tech 20 07-12-2017 04:22 PM
Power window only goes up halfway... Zebrahead General Technical & Electrical 2 11-15-2013 01:51 AM
Halfway Done Blackout01 Exterior Semi-Tech 3 09-11-2011 11:47 PM
Help Needed: Windows Stuck Halfway Down larsmiller08 General Technical & Electrical 1 09-02-2011 04:55 PM
1998 3.0L Starter Randomly engages. HELP jmalibuss General Technical & Electrical 9 11-13-2007 08:15 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:37 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.