Bad CV half shaft or bad hub? - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-17-2013
Chienlaid's Avatar
Member
Thread Starter
 
Join Date: Jun 2007
Location: Sudbury, Ontario
Posts: 20
Bad CV half shaft or bad hub?

I went to leave for work this morning and I heard this weird squeal coming from the driver's side front wheel. I thought maybe I had lost a caliper bolt or something.

Turned around jacked it up and turned the wheel by hand. It turned free and all of a sudden I got a spot with some resistance, then it would go free again. Checked my brakes everything is good there. Put the truck back on the ground and drove it up and down the street a couple times and the noise comes and goes. The noise is there in 2wd, 4x4 high and low and it sounds like it's on the outside close to the wheel...doesn't sound like it comes from near the transfer case.

I'm thinking half shaft. Could it be the hub??
Reply With Quote
  #2  
Old 05-17-2013
02slammedranger's Avatar
Member
iTrader: (8)
 
Join Date: Jul 2009
Location: Dearborn, MI
Posts: 593
Take the truck out and take a turn onto that wheel and if the noise goes away theres a good chance its a hub bearing. or jack it up and grab the tire and 12 and 6. if theres movement its a bad hub bearing also
Reply With Quote
  #3  
Old 05-17-2013
Clinton's Avatar
Member
iTrader: (19)
 
Join Date: Dec 2010
Location: PA.
Posts: 1,417
Usually with a bad cv, from my own experience, will grind and bang around. Check your brake pads, it may be the warnings going off for being too low, or a caliper clip, brake pad clip, may have popped hitting the rim or the rotor itself. If that isn't it, check the CV boot to make sure it isn't torn. If it is torn it will let all the grease out eventually blowing that end of the CV.
Reply With Quote
  #4  
Old 05-19-2013
Chienlaid's Avatar
Member
Thread Starter
 
Join Date: Jun 2007
Location: Sudbury, Ontario
Posts: 20
Just an update. The seal on the hub bearing was trashed and crap was getting in there for awhile by the looks of it. Surprisingly enough the bearing never made any noise until the other day, usually the bearing will hum when it's on it's way out.

Turns out I fixed 2 problems at once. I had some problems with my ABS, whenever I would drive in reverse, turn left at slow speed and brake the ABS would activate. Now it's working fine.
Reply With Quote
  #5  
Old 05-19-2013
Clinton's Avatar
Member
iTrader: (19)
 
Join Date: Dec 2010
Location: PA.
Posts: 1,417
That's good news! Good job!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Drive shaft broke in half! Rangero Drivetrain Tech 12 04-24-2014 10:18 PM
Hub, Cv or axle shaft? 04RangerDave Drivetrain Tech 0 12-05-2010 11:47 PM
For Sale: Dana 35 hub - Dana 28 hub - Dana 35 axle piece - Kansas 1996Ranger4x4SuperCabSTX Engine & Drivetrain 4 11-30-2009 10:05 AM
For Sale: Dana 28 hub - Dana 35 hub - Dana 35 axle piece 1996Ranger4x4SuperCabSTX Engine & Drivetrain 6 11-06-2009 11:46 AM
IFS Ranger half shaft/CV joint question Quasi242 Drivetrain Tech 4 03-06-2009 08:33 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:00 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.