Modulator questions for the Ford A4LD - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-27-2014
LonesomeSTX's Avatar
Member
Thread Starter
 
Join Date: May 2013
Location: Columbus, GA
Posts: 150
Modulator questions for the Ford A4LD

My 87 Ranger has an A4LD automatic in it. Since I got the truck it has shifted rough. It slams into gear when I put it in drive and reverse. It also shifts in and out of gear when I am on hills. It does it on flat ground as well but not as bad nor as often. I dropped the pan and it looked decent inside without any junks. Just normal material build up. Even though I do not have any fluid coming out of it, I bought a new modulator in hopes that is the problem. While I am doing some exhaust work I was going to replace it. However, do those symptoms sound like and adjustment problem instead? I am assuming the line pressure is too great and that is why it slams into drive. I have not had to deal with these very much over the years so please chime in on other possibilities you may think of.
Reply With Quote
  #2  
Old 10-27-2014
djfllmn's Avatar
Moderator
 
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
the slamming into reverse and drive sounds like engine idle is too high IMO, check the vac line for the modulator to see if its cracked or blown off somewhere(had that happen in my Tbird)
Reply With Quote
  #3  
Old 10-28-2014
LonesomeSTX's Avatar
Member
Thread Starter
 
Join Date: May 2013
Location: Columbus, GA
Posts: 150
I thought so as well. But it still did it even after I adjusted the idle.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
A4LD to M5OD Swap Questions (Yes, I have searched. Extensively) liquidcougar Drivetrain Tech 2 03-14-2015 06:01 PM
94 4.0 trasmission modulator deftones1868 Drivetrain Tech 0 04-22-2011 05:07 PM
manual tcase mate with A4LD? Sonic04Edge Drivetrain Tech 6 01-03-2009 02:08 AM
94 3.0 A4LD slipping sapmandu Drivetrain Tech 0 07-08-2008 10:52 AM
A4LD vs. 5R55E/5R44E output shaft (4x4) question n3elz Drivetrain Tech 35 12-06-2006 06:06 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:30 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.