Shift problem - Need Help! - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-26-2008
Member
Thread Starter
 
Join Date: Mar 2007
Location: Auburn, PA
Posts: 12
Shift problem - Need Help!

94RangerXLT (4.0/5sp.). My son went out the other morning to go to school and tried to put his truck into 4-wheel. Came back in and claimed it would not engage. The automatic hubs have been replaced with manual ones. I went out to see what the problem was and discovered that even though neither the 4X4 or 4-low light were illuminated the truck is in 4-low and I cannot get it to disengage. I cannot get either light to come on or get it to shift by pressing either button. I thought it might be the switch and put in another one from the salvage yard, but the problem remains. My next thought is that it might be the shift motor on the transfer case, but I'm not sure. I'm somewhat new to this vehicle. Does this motor shift it in and out of 4-wheel as well as 4-high to 4-low? I don't want to start throwing parts at it until I understand how everything works. Thanks for all the help.
- Bill
Reply With Quote
  #2  
Old 02-26-2008
Member
 
Join Date: Nov 2005
Location: Elizabeth City, NC
Posts: 767
Reply With Quote
  #3  
Old 02-26-2008
lifted97ranger's Avatar
Member
 
Join Date: Nov 2005
Location: Charlestown, IN
Posts: 1


or just replace the motor.....you can get them for about $100 new....
Reply With Quote
  #4  
Old 02-26-2008
Member
Thread Starter
 
Join Date: Mar 2007
Location: Auburn, PA
Posts: 12
Thanks for the info. Looks like the motor is the culprit.
- Bill
Reply With Quote
  #5  
Old 02-26-2008
04 EDGE
Unregistered User
 
Posts: n/a
hey bill, i have a brand new ford motor in the box i can part with.

PM me
Reply With Quote
  #6  
Old 02-26-2008
Member
Thread Starter
 
Join Date: Mar 2007
Location: Auburn, PA
Posts: 12
How much? Also, before I replace the motor, how do I know it is not the 4X4 module? Where is it located? It is an extened cab. The lights never flashed at me but come on dimly only when the switch is being depressed. Also, I can hear a faint "click" behind the dash somewhere when I press the 4X4 button. I do not believe the lights come on when I start the truck, but I will have to confirm this when I get home tonight.
Thanks again - Bill
Reply With Quote
  #7  
Old 02-26-2008
04 EDGE
Unregistered User
 
Posts: n/a
60 bucks shipped.
Reply With Quote
  #8  
Old 02-26-2008
Member
Thread Starter
 
Join Date: Mar 2007
Location: Auburn, PA
Posts: 12
Mark, sounds great. I'll take you up on that as soon as I confirm it's not the module. I'm assuming your motor will fit my 94? I won't be able to look at it until this weekend, but I will let you know and hopefully you will still have it. I'm still hoping to get some more info on the module and where it is located and how to test it.
Thanks - Bill
Reply With Quote
  #9  
Old 02-26-2008
04 EDGE
Unregistered User
 
Posts: n/a
its not going anywhere, i have had it for 2 years, no one wants it because it has the "older" style plug and should be right for your truck.
Reply With Quote
  #10  
Old 02-27-2008
Member
Thread Starter
 
Join Date: Mar 2007
Location: Auburn, PA
Posts: 12
Mark. Sent you a pm.
- Bill
Reply With Quote
  #11  
Old 02-27-2008
kevinsranger's Avatar
Member
 
Join Date: Feb 2008
Location: jersey
Posts: 388
Quote:
Originally Posted by helievacpilot View Post
Mark, sounds great. I'll take you up on that as soon as I confirm it's not the module. I'm assuming your motor will fit my 94? I won't be able to look at it until this weekend, but I will let you know and hopefully you will still have it. I'm still hoping to get some more info on the module and where it is located and how to test it.
Thanks - Bill
check the module behind the drivers side rear jump seat, unplug the two harnesses closest to the drivers seat and then turn the ignition on and press the white test button, if it blinks 4 or five times then its good
Reply With Quote
  #12  
Old 02-27-2008
Member
Thread Starter
 
Join Date: Mar 2007
Location: Auburn, PA
Posts: 12
Thanks for the how-to. I will test it.
- Bill
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Very hard to shift into gear, manual shift. Enduro General Ford Ranger Discussion 13 09-09-2015 08:25 AM
Hard shift 2nd 3rd gear, but down shift "clunk" fixed dschmitz Drivetrain Tech 0 07-15-2012 12:08 PM
shift problem 1st to 2nd. help! rangertamer Drivetrain Tech 0 07-01-2011 11:35 AM
4x4 shift problem GrizzRacer Drivetrain Tech 0 03-31-2008 07:55 AM
Shift Problem Solved! helievacpilot Drivetrain Tech 2 03-06-2008 06:24 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:38 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.