Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Thumping?

  #1  
Old 05-24-2006
webs820's Avatar
Member
Thread Starter
Join Date: Apr 2006
Location: NY
Posts: 23
Thumping?

I've got 30000 miles on my truck and heard a thumping. Rotated the tires...thought it was tire wear...now its thumping worse than ever. Do you think the tires are out of balance? Its the worst around 15-35mph.
 
  #2  
Old 05-24-2006
05rangeredge's Avatar
Member
Join Date: Feb 2006
Location: Fresno, CA
Posts: 311
is it comming from the front or the rear?
 
  #3  
Old 05-25-2006
webs820's Avatar
Member
Thread Starter
Join Date: Apr 2006
Location: NY
Posts: 23
front
 
  #4  
Old 05-25-2006
Join Date: Nov 2005
Location: Royal Oak, Michigan
Posts: 1,022
you could of lost a wheel weight....thats keeps them balanced...i know i have done that before....go take a look and see...
 
  #5  
Old 05-29-2006
webs820's Avatar
Member
Thread Starter
Join Date: Apr 2006
Location: NY
Posts: 23
weights are all there. i have no idea
 
  #6  
Old 05-29-2006
zabeard's Avatar
who?
iTrader: (8)
Join Date: Nov 2004
Location: IN
Posts: 26,045
is it in 4wd? only 15-30mph?

are you accellerating?
stopping?
 
  #7  
Old 05-30-2006
webs820's Avatar
Member
Thread Starter
Join Date: Apr 2006
Location: NY
Posts: 23
its in 2wd. now it seems like its the worst around 30mph just cruising along. when I get around 65 or so, it kinda goes away. I did notice that on the right front axle there seems to be some grease coming out and spraying down the frame. I'm not a mechanic but I know something is wrong. I'm bringing it to Ford today. I'll let you know what they say. Thanks for the input!
 
  #8  
Old 05-30-2006
zabeard's Avatar
who?
iTrader: (8)
Join Date: Nov 2004
Location: IN
Posts: 26,045
sounds liek a seal or CV, good luck.
 
  #9  
Old 06-02-2006
webs820's Avatar
Member
Thread Starter
Join Date: Apr 2006
Location: NY
Posts: 23
ford said "tire wear"
 
  #10  
Old 06-02-2006
webs820's Avatar
Member
Thread Starter
Join Date: Apr 2006
Location: NY
Posts: 23
Oh yeah, and they said I need a new drive shaft. what the hell is that? they said the drive shaft slips/bends a little when I slowly accelerate. They greased the yolks at one point and that didnt work. Has anyone else had this problem? Its annoying.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Ford04Ranger4.0
General Ford Ranger Discussion
3
12-21-2008 02:34 PM
GearBoxKevin
Suspension Tech
2
03-10-2008 09:55 AM
05Edge-04GT
General Ford Ranger Discussion
6
02-16-2008 04:54 PM
08Ranger
General Technical & Electrical
9
12-03-2007 12:14 PM
Gearhead61
General Technical & Electrical
13
08-01-2005 04:01 PM


Thread Tools
Search this Thread
Quick Reply: Thumping?


Contact Us - Sitemap - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.