Tranny Flush and Filter - Ranger-Forums - The Ultimate Ford Ranger Resource


Drivetrain Tech General discussion of drivetrain for the Ford Ranger.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-24-2011
04RangerDave's Avatar
JDM> RANGER

Thread Starter
iTrader: (3)
 
Join Date: Jul 2010
Location: RI
Posts: 5,030
Tranny Flush and Filter

Flushed my old fluid and did a filter using all ford products from work. now my tranny is shuddering and slamming into gear at times it revs up and slips into gear. also it takes about 5 seconds to get into reverse. I'm pissed not sure whats going on. the tranny tech is going to take a look at it monday. any predictions would be great.
Reply With Quote
  #2  
Old 04-24-2011
Blhde's Avatar
Member
 
Join Date: Oct 2005
Location: Northern IL
Posts: 2,804
low fluid

Or the filter is not installed correctly. Maybe you unplugged something.
Reply With Quote
  #3  
Old 04-24-2011
04RangerDave's Avatar
JDM> RANGER

Thread Starter
iTrader: (3)
 
Join Date: Jul 2010
Location: RI
Posts: 5,030
Quote:
Originally Posted by Blhde View Post
low fluid

Or the filter is not installed correctly. Maybe you unplugged something.
fluid is at the correct level. filter is in properly installed. nothing is unplugged. the job isn't hard at all. i did nothing wrong doing the job, its something going on inside the transmission.
Reply With Quote
  #4  
Old 04-25-2011
pcollins's Avatar
Member
 
Join Date: Apr 2010
Location: Walworth, NY
Posts: 493
if all you did was change the fluid, its not causing tht problem. you maybe knocked something.
Reply With Quote
  #5  
Old 04-25-2011
04RangerDave's Avatar
JDM> RANGER

Thread Starter
iTrader: (3)
 
Join Date: Jul 2010
Location: RI
Posts: 5,030
i have a pressure problem. now i gotta find that problem.
Reply With Quote
  #6  
Old 04-25-2011
SteelDirigible's Avatar
Member
iTrader: (4)
 
Join Date: May 2010
Location: Lexington, KY
Posts: 3,666
Did you flush it with a machine?
Reply With Quote
  #7  
Old 04-25-2011
04RangerDave's Avatar
JDM> RANGER

Thread Starter
iTrader: (3)
 
Join Date: Jul 2010
Location: RI
Posts: 5,030
Quote:
Originally Posted by SteelDirigible View Post
Did you flush it with a machine?
yes
Reply With Quote
  #8  
Old 04-25-2011
08rangerdan's Avatar
Member
 
Join Date: May 2009
Location: London/Cambridge Ontario
Posts: 323
Air stuck somewhere it shouldn't be? Just a guess but maybe fluid isn't getting to a vital spot
Reply With Quote
  #9  
Old 04-25-2011
04RangerDave's Avatar
JDM> RANGER

Thread Starter
iTrader: (3)
 
Join Date: Jul 2010
Location: RI
Posts: 5,030
ORC AGAIN WTF
Reply With Quote
  #10  
Old 04-26-2011
Mcleary316's Avatar
Member

 
Join Date: May 2010
Location: Lawrence, Kansas
Posts: 2,322
again? How many times before? haha
Reply With Quote
  #11  
Old 04-26-2011
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Dec 2010
Location: Flat Rock, Mi
Posts: 6,313
Sounds like Air in there.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
How-To: Radiator Flush Using a Flush Kit Redneckstone Engine & Drivetrain 3 07-22-2017 03:46 PM
Transmission Fluid, to flush or not to flush? oxchampion 4.0L OHV & SOHC V6 Tech 10 11-15-2013 01:05 PM
To Flush Or Not To Flush pjschwartz Drivetrain Tech 6 06-02-2011 06:05 PM
to flush or not to flush? wtpbmx2003 4.0L OHV & SOHC V6 Tech 7 05-19-2008 01:08 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:50 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.