1995 ranger horn not working? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-30-2008
kyle12201's Avatar
Member
Thread Starter
 
Join Date: Apr 2008
Location: East Waterboro, ME
Posts: 1,543
1995 ranger horn not working?

All of sudden the other day my horn stopped working on my 95 ranger. It did this befor, but came back now stoped working again. What could have happened? I checked the fuse box under the hood and the fuse thing wasnt loose, it still makes a clicking noise like its working but the horn just doesnt sound. Any idea why? Also where is the horn located on the 95 rangers? I looked everywhere but couldn't find it... Thanks for the help.
Reply With Quote
  #2  
Old 04-30-2008
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
One my 03 the horns are in the front on the passenger side a little lower then the radiator. The horns might just be full os crap. Do you offroad? I got mud in my horns and they fried.
Reply With Quote
  #3  
Old 04-30-2008
kyle12201's Avatar
Member
Thread Starter
 
Join Date: Apr 2008
Location: East Waterboro, ME
Posts: 1,543
Yeah I took it offroading a few times, every since that it stoped working randomly. I usually clean it after i take it in the mud though :\ I'll go check
Reply With Quote
  #4  
Old 04-30-2008
Shaklakan's Avatar
Member
 
Join Date: Jan 2008
Location: La Habra CA
Posts: 1,100
under the left fender in the wheel well thats where mine where and yeah its sounds like you have some crap in there but take this time to get a air horn!
Reply With Quote
  #5  
Old 04-30-2008
Downey's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
if they get full of water your screw too i would buy new horns and mount them up higher
Reply With Quote
  #6  
Old 04-30-2008
kyle12201's Avatar
Member
Thread Starter
 
Join Date: Apr 2008
Location: East Waterboro, ME
Posts: 1,543
yeah i found it, its under neath the battery, i ripped out the battery, tryed reconnecting the wires and stuff, things junk. Going to call my local garage and see if ican get one from the junk yard or somthing. Thats rediculous, you can't even take it off roading without killing somthing :(. I need new tires and a lift kit :(

Thanks for the help guys

Last edited by kyle12201; 04-30-2008 at 04:53 PM.
Reply With Quote
  #7  
Old 05-01-2008
Downey's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2007
Location: Muncy, PA
Posts: 8,470
go to your local parts store there like 5 bucks for a brand new one
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Ranger not charging and chime not working jfoster2505 General Technical & Electrical 3 02-14-2012 08:23 PM
1995 mustang seats in a 1995 ranger super cab nyranger95 Interior Semi-Tech 1 06-23-2011 06:50 AM
Heater not working/not shifting right conrad General Technical & Electrical 7 01-20-2011 06:35 PM
Will a bumper off of a 1995 Explorer fit a 1995 Ranger? lownslow95 Exterior Semi-Tech 7 11-05-2009 10:42 AM
Horn not working after steering column replacement. MydnightMyst General Technical & Electrical 5 03-07-2006 01:51 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:31 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.