2011 Ford Ranger Catalytic Converter Problems - Ranger-Forums - The Ultimate Ford Ranger Resource

General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.
Sponsored By:
Sponsored By:

2011 Ford Ranger Catalytic Converter Problems

Reply

 
 
 
  #1  
Old 02-12-2018
Member
Thread Starter
Join Date: Feb 2018
Location: Gastonia, NC
Posts: 3
Icon4 2011 Ford Ranger Catalytic Converter Problems

Hello all, I have a 2011 Ford Ranger 4.0 6 Cylinder. I replaced both of my catalytic converters due to them being bad and afterwards went and had my check engine light cleared. Any ideas to a next step to getting my issue solved. Any help would be greatly appreciated.
 
Reply With Quote
  #2  
Old 02-12-2018
Member
Thread Starter
Join Date: Feb 2018
Location: Gastonia, NC
Posts: 3
The check engine light is still on, left the important part out.
 
Reply With Quote
  #3  
Old 02-13-2018
Member
Join Date: Feb 2018
Location: Venice, Florida
Posts: 22
What codes are you getting?
 
Reply With Quote
  #4  
Old 02-13-2018
Member
Thread Starter
Join Date: Feb 2018
Location: Gastonia, NC
Posts: 3
Originally Posted by Ewgoetz View Post
What codes are you getting?
P0161: Heated oxygen sensor Bank 2 Sensor 2
P2272: Lack of heated oxygen sensor Bank 2 Sensor 2
Both cats and all sensors were replaced, so my issue now seems to be with The sensor on bank 2 sensor 2.
 
Reply With Quote
  #5  
Old 02-14-2018
Member
Join Date: Feb 2018
Location: Venice, Florida
Posts: 22
We’re there anymore codes before you changed the sensors?
I’d start with checking the harness and connectors going to the sensors.
or it’s possible that you got a defective O2 sensor.
 
Reply With Quote
  #6  
Old 02-15-2018
Hillyard's Avatar
Member
iTrader: (8)
Join Date: Jul 2007
Location: Evansville, Indiana
Posts: 1,023
I have a 2011 Ford Ranger 4.0 and had to replace both catalytic converters around 45k miles, luckily both were covered under warranty. I talked to an exhaust shop owner and he says he has seen an awful lot of 2010 and 2011 Rangers (4.0 SOHC) come in with bad cats.

Everything is stock and I even use an OEM Motorcraft air filter. After I had both cats replaced under warranty. I replaced the spark plugs, fuel filter, PCV valve, 02 Sensors, and spark plug wires just to be sure it wouldn't happen again. I feel like it still runs a tad rich.

Are you sure the 02 sensor is connected correctly?
 
Reply With Quote
Reply
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Rangerboy69
4.0L OHV & SOHC V6 Tech
9
01-08-2012 06:12 PM
Greatkiller
2.9L & 3.0L V6 Tech
9
05-01-2009 02:22 AM
bmfmancini
General Ford Ranger Discussion
30
03-22-2009 04:08 PM
FORZDA
2.9L & 3.0L V6 Tech
18
07-05-2007 10:08 PM
seneca
2.9L & 3.0L V6 Tech
14
01-31-2006 07:57 PM


Thread Tools
Search this Thread