ABS light comes on...sometimes - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-22-2005
jtfoxman's Avatar
Member
Thread Starter
 
Join Date: Jun 2005
Location: The Poconos
Posts: 891
ABS light comes on...sometimes

I have a slight problem. A few times a day when I first start the truck the abs light comes on, shuts off, then comes back on and stays on. Half the time if I drive it for a few miles shut it off again and restart it it will stay out. It usually comes on after it has sat for a few hours. At first i thought it was the sensor in the rear but wouldn't that make the speedo off? It isn't causing me any problems since the brakes still work but i don't like have something not working. The truck only has rabs.
Reply With Quote
  #2  
Old 07-22-2005
Shalafi49's Avatar
Member
 
Join Date: Jun 2004
Location: Altamonte Springs FL
Posts: 2,070
Do you go muddin or offroad at all? That's a common occurence in those situations. I think mud funk up the sensor but it fixes itself after a bit of road driving..if not..I have no idea
Reply With Quote
  #3  
Old 07-22-2005
jtfoxman's Avatar
Member
Thread Starter
 
Join Date: Jun 2005
Location: The Poconos
Posts: 891
No mudding, just everyday driving for a while now.
Reply With Quote
  #4  
Old 07-22-2005
birdie2000's Avatar
Member
 
Join Date: Nov 2004
Location: Abilene,Texas
Posts: 528
there is an abs sensor on the rear axle... its like $28 @ ford... that is what happened to mine. easy to change one bolt,one plug.
Reply With Quote
  #5  
Old 07-22-2005
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,831
Quote:
Originally Posted by jtfoxman
At first i thought it was the sensor in the rear but wouldn't that make the speedo off?
On your 97, the speedometer signal is taken from the transmission or transfer case. The 98~2000 Rangers use the ABS sensor for the speedometer.
Reply With Quote
  #6  
Old 07-22-2005
jtfoxman's Avatar
Member
Thread Starter
 
Join Date: Jun 2005
Location: The Poconos
Posts: 891
Quote:
Originally Posted by rwenzing
On your 97, the speedometer signal is taken from the transmission or transfer case. The 98~2000 Rangers use the ABS sensor for the speedometer.
That is good to know. I always thought the sensor sent the signal. Thanks for all your help. Now I can finally fix it. Is this just a dealer part?
Reply With Quote
  #7  
Old 07-25-2005
jtfoxman's Avatar
Member
Thread Starter
 
Join Date: Jun 2005
Location: The Poconos
Posts: 891
I replaced the sensor, all is fine now. That was a pain, sensor broke off inside the rear. had to take the cover off and pop the rest of it out that way. Then i realized i had no RTV or oil. Had to wait till the next morning to finish.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Brake lights don't work; #10 fuse keeps blowing; abs light comes on. 93 ranger Shadowsanjimaru General Technical & Electrical 1 12-03-2013 06:27 PM
battery light ABS light dim light RangerSkippyRoo General Technical & Electrical 3 05-25-2009 11:25 AM
ABS light comes on wile in 4X4 MonsterGuy Drivetrain Tech 9 03-03-2008 08:14 PM
New ABS sensor, now ABS light. 01xltranger4x4 Drivetrain Tech 32 06-26-2007 06:24 PM
Overdrive light just comes on and blinks??????? Sting00 Ranger-Forums Office 7 07-27-2006 06:41 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:32 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.