Anyone have new MAF problems? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-31-2012
leadfoot's Avatar
Member
Thread Starter
 
Join Date: Oct 2007
Location: MA
Posts: 894
Anyone have new MAF problems?

Has anyone had a problem with a new Mass Air Flow Sensor?
I ordered a Delphi replacement MAF from RockAuto but it keeps stalling and flooding the engine. It will run fine for a while but sometimes when I come to a stop it will just stall and other times when I am cruising and let off the gas it will feel like an engine brake because the motor cut out. Occasionally it will lose power, start surging, and flood the engine with fuel. Once the engine dies or starts surging and sputtering, the only way to resurrect the problem is to turn the key off for a few seconds and then restart it. It will then run fine for a while.

RockAuto sent me a replacement but the same problems occurred. I have reset the ECU and driven with it for a while but the problem only gets worse. The Delphi MAF sensor wires look different from the OEM sensor. I will try the Motorcraft MAF next.

Original:


Delphi:
Attached Thumbnails
Anyone have new MAF problems?-img_1016.jpg   Anyone have new MAF problems?-img_1009.jpg  
Reply With Quote
  #2  
Old 08-01-2012
rolsmojave3's Avatar
Level III Supporter
 
Join Date: Jun 2006
Location: Wisconsin
Posts: 2,852
Why did you replace the MAF in the first place?
Reply With Quote
  #3  
Old 08-01-2012
leadfoot's Avatar
Member
Thread Starter
 
Join Date: Oct 2007
Location: MA
Posts: 894
^ My fuel mileage dropped off from 15-16 to 12mpg and the engine has a bucking problem at low rpm and high load. With 157,000 miles I didn't think that it would hurt but I guess it did. I had cleaned the old sensor but didn't see much of an improvement. You can't tell in the picture but one of the sensor wires on the old maf seems a bit burnt.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
problems with MAF SkyRock General Ford Ranger Discussion 2 01-24-2015 12:02 PM
For Sale: 3.0 MAF sensor - brand new IL Jp7 Engine & Drivetrain 0 08-21-2009 06:28 PM
Anyone had any luck with the MAF mod? TrePaul86 4.0L OHV & SOHC V6 Tech 5 05-24-2009 04:01 PM
More MAF problems. Diltzy 4.0L OHV & SOHC V6 Tech 12 11-08-2008 12:51 PM
4.0 MAF mod "tuning" information -- new stuff n3elz 4.0L OHV & SOHC V6 Tech 70 02-06-2005 01:33 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:17 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.