Cruise control problem. - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-18-2009
jdpartsman99's Avatar
Member
Thread Starter
 
Join Date: Nov 2005
Location: osage,ia
Posts: 228
Cruise control problem.

Well, my cruise control on my truck works OK, but it makes a fairly loud buzzing sound coming from the lower dash area. What in the world could it be? Kinda hard to look around under the steering wheel while driving to take a look around you know... Thanks if you can help.
Reply With Quote
  #2  
Old 02-19-2009
Member
 
Join Date: Aug 2004
Posts: 688
Try putting slight pressure on the gas pedal and see if it goes away
Reply With Quote
  #3  
Old 03-05-2009
jdpartsman99's Avatar
Member
Thread Starter
 
Join Date: Nov 2005
Location: osage,ia
Posts: 228
I tried that, yes the noise goes away. As soon as you let off the gas it comes back. Any thoughts?

Oh yeah....the trade light on the dash is on too......
Reply With Quote
  #4  
Old 03-05-2009
Blackhawk's Avatar
Member
 
Join Date: Jun 2007
Location: WI
Posts: 586
I have heard that before too on my truck. Never bothered to figure it out though... just turn up the radio.
Reply With Quote
  #5  
Old 03-05-2009
bergs's Avatar
Member
 
Join Date: Sep 2007
Location: Arizona Bay
Posts: 151
Are you sure it's not the servo which operates the gas pedal? Not certain where it's located but it could be something to consider.
Reply With Quote
  #6  
Old 03-05-2009
north44's Avatar
Member
 
Join Date: Dec 2008
Location: Toronto, Ontario, Canada
Posts: 174
It may be a vibration in the throttle cable when the cruise was on.

Mine used to do the same thing - could feel the "buzzing" through the gas pedal when the cruise was on.

Kind of fiddled around with the throttle cable, made sure it was tight, and now it doesn't do it anymore.

Hope this can help.
Reply With Quote
  #7  
Old 03-06-2009
rolsmojave3's Avatar
Level III Supporter
 
Join Date: Jun 2006
Location: Wisconsin
Posts: 2,852
Mine does it too but only if it's cold out.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
cruise control problem Machine090767 General Technical & Electrical 3 04-06-2013 10:54 AM
Modding cruise control to a non cruise Ranger 2001fordranger General Technical & Electrical 1 07-29-2009 11:58 PM
Cruise control problem meatloaf General Technical & Electrical 9 02-22-2009 12:28 PM
Using Cruise Control buttons to control the Volume GVSU Godfather Audio & Video Tech 23 05-29-2005 07:39 PM
Cruise control problem in Rangers now Shalafi49 General Ford Ranger Discussion 44 05-04-2005 06:39 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:12 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.