Factory splash shield pic request? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-18-2009
Mykhael's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Sep 2004
Location: .
Posts: 4,197
Factory splash shield pic request?

Can some one with factory splash shields send me a picture of the front driver and front passenger one Preferably not on the truck but laying on the ground

I also then need some measurements but with the right picture I can show where I need measurements
Reply With Quote
  #2  
Old 09-19-2009
Rolldogg's Avatar
Member
 
Join Date: Jan 2006
Location: Ottawa, Ontario
Posts: 3,424
Looking to make your own? Good call.
Reply With Quote
  #3  
Old 09-19-2009
Mykhael's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Sep 2004
Location: .
Posts: 4,197
Ya but seems to be harder than I thought to get a picture

I wish I would have kept mine 2 years ago
Reply With Quote
  #4  
Old 09-20-2009
littlemcvic's Avatar
Member
 
Join Date: Aug 2008
Location: MA
Posts: 28
Hey STL I can get you some pictures in a little while if you still need them (Im stuck on service desk check in till 9am) I just pulled my passenger side one off earlier today to trace and make a second one for my drivers side (it was missing when I bought the truck). Ill snap a couple pictures when I get back to my room
Reply With Quote
  #5  
Old 09-20-2009
Bumpncarstereo's Avatar
Member
iTrader: (3)
 
Join Date: Aug 2006
Location: btwn the Buff and the Roc
Posts: 1,302
it wasn't missing, they didn't come with one on the newer trucks
Reply With Quote
  #6  
Old 09-20-2009
Mykhael's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Sep 2004
Location: .
Posts: 4,197
Y aif you can get me some pictures that would be awesome

And mine did have 2 so the and it is a 05 and his is a 04
Reply With Quote
  #7  
Old 09-20-2009
littlemcvic's Avatar
Member
 
Join Date: Aug 2008
Location: MA
Posts: 28
here's what I got:

Name:  IMG_0526.jpg
Views: 6
Size:  46.6 KB

Its roughly 31"(at its longest point) x 10"(at its widest point)
I can get you whatever measurements you need, just let me know
Reply With Quote
  #8  
Old 09-20-2009
Mykhael's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Sep 2004
Location: .
Posts: 4,197
I think those measurements will work

Thanks
Reply With Quote
  #9  
Old 09-21-2009
cmc474's Avatar
Member
 
Join Date: Nov 2008
Location: Winnipeg
Posts: 471
Hmm I seem to be missing mine on 1 side.. Are they necessary if your driving in snow for half the year?
Reply With Quote
  #10  
Old 09-21-2009
brightredford's Avatar
Member
 
Join Date: Jun 2005
Location: Ottawa, On
Posts: 186
Quote:
Originally Posted by cmc474 View Post
Hmm I seem to be missing mine on 1 side.. Are they necessary if your driving in snow for half the year?
Ford stopped installing them on the driver's side in 2005 (I think). It has something to do with the cooling of the engine in hot weather conditions.

I know my '04 had it on both sides, but when I bought my '07, I noticed it was missing.. I checked several Rangers on the dealer's lot and they were all missing it.

As for driving in the snow... it's probably not an issue unless you drive in deep snow all the time. But it would be a good idea to have one to reduce the amount salt and stuff spaying up into the engine compartment.
Reply With Quote
  #11  
Old 09-21-2009
RangOH's Avatar
Member
 
Join Date: Feb 2009
Location: Madison, Ohio
Posts: 854
I drive in snow half the year and feel the need for one. I noticed how dirty and rusty one side of my engine bay was from not having one on it a few years. now my engine is so much cleaner. I would recommend buying/making one just because of the road salt...
Reply With Quote
  #12  
Old 09-21-2009
Mykhael's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Sep 2004
Location: .
Posts: 4,197
Quote:
Originally Posted by brightredford View Post
Ford stopped installing them on the driver's side in 2005 (I think). It has something to do with the cooling of the engine in hot weather conditions.
Must have been a half year deal mind had splash shields on both sides May also have been after 05 and on the 06 rangers
Reply With Quote
  #13  
Old 09-21-2009
cmc474's Avatar
Member
 
Join Date: Nov 2008
Location: Winnipeg
Posts: 471
I'm gonna take a look to see if mine gave fallen off and if I can see the hardware cause mines a 05 to.
Reply With Quote
  #14  
Old 09-21-2009
btm757's Avatar
Member
iTrader: (5)
 
Join Date: Jun 2009
Location: Norfolk / Chesapeake, VA
Posts: 3,980
My 04 xlt does not have one on the drivers side. i just though it was missing and wondered why someone would take it off.
Reply With Quote
  #15  
Old 09-21-2009
Mykhael's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Sep 2004
Location: .
Posts: 4,197
2005 from eBay with no driver side splash shield
I know for fact mine had it there I took it off the first time I ever changed the plugs

Reply With Quote
  #16  
Old 09-21-2009
brightredford's Avatar
Member
 
Join Date: Jun 2005
Location: Ottawa, On
Posts: 186
I know it was around 05 or 06 that they stopped installing them. I think for a couple of years they were installing a smaller one on the driver's side, then they removed it altogether.
However, the holes are still there for the clips, so if you found one from an older model it should fit.
Reply With Quote
  #17  
Old 09-21-2009
Prem's Avatar
Member
 
Join Date: Sep 2009
Location: ontario mississauga
Posts: 24
my '09 fx4 has one on the driver side, but it's different (smaller, different shape and unattached at the top part) than the one on passenger side (clips everywhere and securely attached). Driver side one does not overlap so I can't attach the top and I'm assuming that when the snow falls some of that salt will end up in behind the splash shield :(
Reply With Quote
  #18  
Old 09-21-2009
Hillyard's Avatar
Member
iTrader: (8)
 
Join Date: Jul 2007
Location: Evansville, Indiana
Posts: 1,018
I just replaced both of them...They only cost 11.40 a piece and come with all the push pins. My 04 had the smaller one on the driver side, I guess the dealer grabbed the wrong part when the previous owner replaced it.
Reply With Quote
  #19  
Old 09-21-2009
cmc474's Avatar
Member
 
Join Date: Nov 2008
Location: Winnipeg
Posts: 471
I am thinking I had two and one fell off because all the holes and some hardware is still there.
Reply With Quote
  #20  
Old 09-21-2009
Mykhael's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Sep 2004
Location: .
Posts: 4,197
Quote:
Originally Posted by Hillyard View Post
I just replaced both of them...They only cost 11.40 a piece and come with all the push pins. My 04 had the smaller one on the driver side, I guess the dealer grabbed the wrong part when the previous owner replaced it.
U got part number for them? Maybe useful for someone looking to replace them
Reply With Quote
  #21  
Old 09-21-2009
Mykhael's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Sep 2004
Location: .
Posts: 4,197
found it here it is called a vent valve?

Vent valve $11.56
Reply With Quote
  #22  
Old 09-21-2009
Hillyard's Avatar
Member
iTrader: (8)
 
Join Date: Jul 2007
Location: Evansville, Indiana
Posts: 1,018
Ya, I knew they were called something crazy. Oh the left and right pieces are identical. I order the same side because one was cheaper at my local dealer (reason unknown). I freaked out and realized they just install the push pins on the opposite side. lol easy fix.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
splash guard/shield/something. I need a name to find a replacement. SeanL General Technical & Electrical 7 08-31-2016 10:41 AM
Testing my Powertrax No-Slip. PIC'S PIC'S PIC'S whitedge Snapshots 71 01-25-2010 07:29 PM
WTB front rotor splash shield ken_r_mer Engine & Drivetrain 1 06-03-2009 04:59 PM
Pic Request/ photo shop request Downey Snapshots 13 03-03-2009 10:36 PM
whats some good material for a heat shield? TippnOver New Ideas 12 12-11-2005 10:43 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:00 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.