Help!!! - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 12-12-2006
FordRangerGirl's Avatar
Member
Thread Starter
 
Join Date: Nov 2006
Location: Ft. Morgan, Colorado
Posts: 94
Help!!!

Ok today I put a new window shield in my pick-up well I got off work and was at the stop light and I looked down after I flipped on the blinker and there was nothing, the light wasn't on. So I got home and checked to see if I had blinkers I had nothing. Now don't forget that I posted recently that I had no dash lights. What do you guys think is wrong? This is something that I need to fix ASAP!!! PLEASE HELP AND GIVE ME SUGGESTIONS!!
Reply With Quote
  #2  
Old 12-12-2006
Level III Supporter
iTrader: (2)
 
Join Date: Jun 2004
Location: usa
Posts: 24,936
#1 CHECK all fuses...
Reply With Quote
  #3  
Old 12-12-2006
CanadianXLT's Avatar
Member
 
Join Date: Apr 2005
Location: Moncton
Posts: 447
check blinker fluid :P Yeah what Zach said check the fuses
Reply With Quote
  #4  
Old 12-12-2006
Blades24's Avatar
Member
 
Join Date: Oct 2006
Location: Michigan & Kansas
Posts: 994
Fuses, and blinker fluid lol cracks me up everytime time!!
Reply With Quote
  #5  
Old 12-12-2006
quest51210
Unregistered User
 
Posts: n/a
flasher
Reply With Quote
  #6  
Old 12-12-2006
RockysFord's Avatar
Member
 
Join Date: May 2005
Location: Columbus Ohio
Posts: 2,782
^Yeah the flasher relay

Rocky
Reply With Quote
  #7  
Old 12-12-2006
FordRangerGirl's Avatar
Member
Thread Starter
 
Join Date: Nov 2006
Location: Ft. Morgan, Colorado
Posts: 94
I wish there was something called blinker fluid...that would be simple! My flasher is definitly off! This just had to happen after I replace the window....eerrr....today isn't my day!
Reply With Quote
  #8  
Old 12-12-2006
CadiLLacPimPin's Avatar
Member
 
Join Date: Nov 2006
Location: Charlottesville, VA
Posts: 239
No the flasher RELAY, not the hazard flashers. The flasher relay is what makes the clicking sound when the signals blink.
Im more inclined to say its a bad switch though.
Reply With Quote
  #9  
Old 12-12-2006
TireIron's Avatar
Member
 
Join Date: Feb 2006
Location: Methuen, MA
Posts: 790
do you have brake lights or reverse lights? do your hazzards work of you put those on? do you have dash lights? parking lights? headlights? check to see if all of those are working or which ones arent and also check the fuse for the directionals.
Reply With Quote
  #10  
Old 12-12-2006
HighRollerII's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Jun 2004
Location: Charleston, SC
Posts: 10,066
its located next to the muffler bearings..
Reply With Quote
  #11  
Old 12-12-2006
LoOnaTik's Avatar
Member
 
Join Date: Oct 2006
Location: Morristown,Tn
Posts: 477
Quote:
Originally Posted by HighRollerII
its located next to the muffler bearings..
That's what I thought!
Reply With Quote
  #12  
Old 12-12-2006
SHOman86's Avatar
Member
 
Join Date: Sep 2005
Location: Lakeland, Fl
Posts: 2,469
^^^ lmfao
Reply With Quote
  #13  
Old 12-12-2006
b3kbruiser's Avatar
Member
 
Join Date: Nov 2006
Location: DFW Area, Tx
Posts: 713
Your transmition is bad. Pay $3000, do not pass GO.
Reply With Quote
  #14  
Old 12-13-2006
FordRangerGirl's Avatar
Member
Thread Starter
 
Join Date: Nov 2006
Location: Ft. Morgan, Colorado
Posts: 94
Haha....funny guys...the muffler bearings....well screw them! There is no such thing! ....the real problem is the flasher relay. Yes cadilla you were right! Then the dash lights I dunno whats wrong...its got to be a short in the wires between the stereo and lights! And I'm not good with wires...I don't have the patience!
Reply With Quote
  #15  
Old 12-13-2006
RockysFord's Avatar
Member
 
Join Date: May 2005
Location: Columbus Ohio
Posts: 2,782
Quote:
Originally Posted by FordRangerGirl
Yes cadilla you were right!

Quest said it 1st....

Then i made sure you knew it was the FLASHER relay....

then cadillac said the same thing i said...

How does he get credit????


































just kidding, sounds like you have a big electrical problem...dash lights, flashers,ect


Rocky
Reply With Quote
  #16  
Old 12-13-2006
Victory's Avatar
Member
 
Join Date: Nov 2006
Location: Pawcatuck, CT
Posts: 219
Question?

When your windshield was broken did you notice any wet carpet?
Maybe you got water in the dash somewhere? You may get lucky and be able to follow a trail of dried rain along connections. Then you can open the connections, clean and use some di-electric grease to seal when you put back together. Some electronic people could give you more complete directions.
Reply With Quote
  #17  
Old 12-13-2006
FordRangerGirl's Avatar
Member
Thread Starter
 
Join Date: Nov 2006
Location: Ft. Morgan, Colorado
Posts: 94
No, I know no water or anything got into my windshield. I just had a really bad crack across it! I know the dash lights is a short and the blinkers are the flasher relay!
Reply With Quote
  #18  
Old 12-14-2006
reelfishin's Avatar
Member
 
Join Date: Oct 2006
Location: Right here!
Posts: 157
First, check to make sure that your Hazzard switch is not partially depressed and cycle it on and off a few times to make sure, if this switch sticks it will cancel the turn signal function as well.
If not,
Fuse #5 should be your turn signal fuse. The circuit consists of the fuse, the multifunction turn signal switch, and flasher. These in turn send power to the individual lamps.
Step one is to check the fuse, if the fuse is good, try wiggling the turn signal switch a bit, try to see if moving the switch slowly lights any of the lights even if its only a short flash.
Ford has had a history of these switches failing as well.

Last edited by reelfishin; 12-15-2006 at 01:33 AM.
Reply With Quote
  #19  
Old 12-15-2006
reelfishin's Avatar
Member
 
Join Date: Oct 2006
Location: Right here!
Posts: 157
Maybe this will help,
from the 1993 Ranger shop manual:

1993 Ford Ranger Turn/Hazzard

Last edited by reelfishin; 12-16-2006 at 01:45 AM.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
HELP !HELP! HELP! 3.0 V6 Driving me insane Hunter74 2.9L & 3.0L V6 Tech 21 03-06-2016 12:08 PM
Help Help Help!!!!!!! EdgeGOBoom 2.9L & 3.0L V6 Tech 6 09-16-2007 01:01 AM
Help Help Help Gear Indicator Stuck BananaEdge General Technical & Electrical 5 06-16-2005 12:05 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:49 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.