help, head lights keep flickering and shutting off - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-18-2010
BettyVo7Ranger's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Apr 2008
Location: Niagara Falls, New York
Posts: 695
help, head lights keep flickering and shutting off

my hid's keep flickering and shutting off. i checked all the fuses and i cant seem to find the relay for the headlamps. i heard that some ballasts draw to much power causing the headlights to flicker and shut off. so my questions are, is there a relay for the headlamps, and how did you guys wire your hid's up?
Reply With Quote
  #2  
Old 02-18-2010
BettyVo7Ranger's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Apr 2008
Location: Niagara Falls, New York
Posts: 695
so no one can help me?
Reply With Quote
  #3  
Old 02-18-2010
jtslmn720's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2004
Location: Kent State, Kent Ohio
Posts: 7,367
check your grounds
Reply With Quote
  #4  
Old 02-18-2010
BettyVo7Ranger's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Apr 2008
Location: Niagara Falls, New York
Posts: 695
well this may sound stupid but where does the stock ground wire go to for the head light
Reply With Quote
  #5  
Old 02-18-2010
btm757's Avatar
Member
iTrader: (5)
 
Join Date: Jun 2009
Location: Norfolk / Chesapeake, VA
Posts: 3,980
Also it could be a ballast going bad
Reply With Quote
  #6  
Old 02-18-2010
BettyVo7Ranger's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Apr 2008
Location: Niagara Falls, New York
Posts: 695
what k do you guys run, i have 10k
Reply With Quote
  #7  
Old 02-18-2010
Casper98's Avatar
Member
iTrader: (1)
 
Join Date: Jun 2007
Location: Gresham OR
Posts: 1,789
Sounds like you need a relay kit for your HID's
Reply With Quote
  #8  
Old 02-18-2010
BettyVo7Ranger's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Apr 2008
Location: Niagara Falls, New York
Posts: 695
lol billy i was just reading you post on RPS
Reply With Quote
  #9  
Old 02-18-2010
BettyVo7Ranger's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Apr 2008
Location: Niagara Falls, New York
Posts: 695
so billy will you inform me on what a relay kit does and where to get one?
Reply With Quote
  #10  
Old 02-18-2010
ShadowRanger08's Avatar
Member
iTrader: (3)
 
Join Date: Jan 2008
Location: Ontario, Canada
Posts: 1,694
yuo can get them on e-bay for like $10 shipped, and im pretty sure they work for pretty much any application
Reply With Quote
  #11  
Old 02-18-2010
ShadowRanger08's Avatar
Member
iTrader: (3)
 
Join Date: Jan 2008
Location: Ontario, Canada
Posts: 1,694
Reply With Quote
  #12  
Old 02-18-2010
BettyVo7Ranger's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Apr 2008
Location: Niagara Falls, New York
Posts: 695
thanks man, one question, does this kit just come with the spaded wires to just plug into the stock headlight harness or is it the female plastic thing?
Reply With Quote
  #13  
Old 02-18-2010
Casper98's Avatar
Member
iTrader: (1)
 
Join Date: Jun 2007
Location: Gresham OR
Posts: 1,789
The kit should work like this

Reply With Quote
  #14  
Old 02-18-2010
jtslmn720's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Oct 2004
Location: Kent State, Kent Ohio
Posts: 7,367
Quote:
Originally Posted by BettyVo7Ranger View Post
well this may sound stupid but where does the stock ground wire go to for the head light
sounds like its not your problem, but the ground will go to the fenderwell of the engine bay. mines driver side, yours may be too.
Reply With Quote
  #15  
Old 02-18-2010
BettyVo7Ranger's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Apr 2008
Location: Niagara Falls, New York
Posts: 695
thanks guys, i got a little aggravated and went out and uninstalled my hid's and turns out for some odd reason the ballast was full of water. so why don't you guys show me where you guys mounted yours for when i get my new ballasts?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
sparks and fire after shutting off littlered General Technical & Electrical 5 11-05-2012 06:29 PM
Trouble With Truck Shutting Off BigKK 4.0L OHV & SOHC V6 Tech 6 07-19-2012 08:10 AM
Alpine stereo shutting off at certain volume? 99MazdaB4000 Audio & Video Tech 0 07-16-2011 08:58 PM
Speakers shutting off Shaklakan Audio & Video Tech 3 07-25-2008 10:45 AM
Thumpimg sound when at a stop or after shutting truck off jtfoxman 4.0L OHV & SOHC V6 Tech 2 12-13-2007 08:54 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:59 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.