Help! Speed Sensor - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-14-2008
RANGERLOVER's Avatar
Member
Thread Starter
 
Join Date: Jun 2006
Location: hampton georgia
Posts: 89
Help! Speed Sensor

my speed sensor went out in my 2000 ranger does anyone have a pic or can tell me where its located?
Reply With Quote
  #2  
Old 11-14-2008
whippersnapper02's Avatar
RF Veteran
iTrader: (1)
 
Join Date: Sep 2006
Location: Earth, Milky Way Galaxy
Posts: 7,415
Should be on top of the rear axle.
Reply With Quote
  #3  
Old 11-14-2008
robert99ranger's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Aug 2007
Location: Indiana/Mississippi
Posts: 5,807
Ya rear axle. There is one bolt holding it on. How do you know that the speed sensor went bad?
Reply With Quote
  #4  
Old 11-14-2008
RANGERLOVER's Avatar
Member
Thread Starter
 
Join Date: Jun 2006
Location: hampton georgia
Posts: 89
my check engine light is on and i got the codes ran on it
Reply With Quote
  #5  
Old 11-14-2008
robert99ranger's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Aug 2007
Location: Indiana/Mississippi
Posts: 5,807
Good then, sometimes metal shavings come off the diff and they stick to it like a magnet. My dads f150 threw a code and it was because of that.
Reply With Quote
  #6  
Old 11-14-2008
Mykhael's Avatar
Member
iTrader: (3)
 
Join Date: Sep 2004
Location: .
Posts: 4,197
Here is a picture would be a PITA with the bed still on the truck.

Name:  painted3speedsensor-2.jpg
Views: 255
Size:  69.4 KB

Last edited by Mykhael; 11-14-2008 at 08:53 PM.
Reply With Quote
  #7  
Old 11-15-2008
94Ranger355's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2005
Location: Athens, TN
Posts: 616
Icon2 Fyi:

Quote:
Originally Posted by RANGERLOVER View Post
my check engine light is on and i got the codes ran on it
-------------------------------------------------
Usually when the one in the chunk goes bad, you loose your speedo, as there is an exciter ring on the ring gear for your speedo.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Replaced ABS speed sensor in a 99 ranger still having problems. Please help Elberto1999 Drivetrain Tech 2 10-17-2014 10:32 AM
5 Speed Auto with Overdrive feels like a 6 speed? patkelly1336 Drivetrain Tech 7 10-06-2012 09:04 PM
Speed sensor plug for a 5-speed manual BlackRanger04 Drivetrain Tech 4 01-04-2011 01:07 AM
little help finding vehicle speed sensor for interior mod UNCCRang49 Interior Semi-Tech 3 02-10-2008 11:54 AM
temp sensor and speed sensor for ohc BananaEdge Exterior Semi-Tech 4 09-01-2004 11:42 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:55 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.