Loss of power 96 2.3 5 speed RWD - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-22-2014
Member
Thread Starter
 
Join Date: Apr 2014
Location: woodstock, il
Posts: 18
Loss of power 96 2.3 5 speed RWD

My 1996 ranger xlt 2.3 5 speed (8 plugs) has extreme power issues. She lacks power when im leaving a complete stop like a great hesitation to gain speed. Can almost hear like different levels of her gaining speed and through every shift (vroom vroom vroooom). the engine revs more than pulls. When I floor off the line, the pull she gives is nothing and the acceleration is slogish. to me the acceleration is slow which I don't think is right. shes a light truck and a 5 speed so the acceleration should be decent. atleast to pull away from cars. This is greatest when the temp outside is about 75 F and above. She drives much better when its below 75 F. So I have no idea what could be the problem.
OH WAIT! the accelereation and hesitation and loss of power is much much grater when the A/C is on sometimes it feels like its misfiring.
Things done to it, is a tune up (plugs, wires, air filter, oil change)
Changed both O2 sensors. Still gives o2 sensor code (bank 1 sensor 1)
sometimes Coil A pops up on the CEL and an evap code pops up everytime along with the O2 sensor 1

ANY IDEAS OF WHAT IS UP. PLEASE LET ME KNOW!
Reply With Quote
  #2  
Old 07-27-2014
Member
 
Join Date: Dec 2013
Location: cleveland, OH
Posts: 15
Maybe try changing the fuel filter. It sounds like its possibly fuel starving? Have you tried just disconnecting the battery to reset the whole truck? Also, the AC is driven by a belt so it is naturally consuming some of the engine's horsepower.
Reply With Quote
  #3  
Old 07-28-2014
Member
Thread Starter
 
Join Date: Apr 2014
Location: woodstock, il
Posts: 18
No I haven't but I was honestly thinking about it. So I might change it to see if anything changes. and no I haven't tried disconnecting the battery but Ill give tht a shot and see if anything changes. keep you posted.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1987 Ford Ranger mods/custom RWD. Kysus Project Logs 2 08-05-2011 11:43 PM
FWD vs RWD rims 08EscapeArtist Wheels & Tires Semi-Tech 12 01-19-2010 03:28 PM
RWD rims on 4x4 Iron ZooLoo Wheels & Tires Semi-Tech 8 09-19-2008 06:04 AM
Winter driving: RWD guys, need weight? JayBell General Ford Ranger Discussion 12 11-12-2007 09:17 AM
fwd rims on a rwd truck bpolly_2004 Wheels & Tires Semi-Tech 7 08-24-2007 05:16 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:51 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.