Oil in my coolant..... - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-05-2011
Member
Thread Starter
 
Join Date: Jun 2011
Location: Denver, Co.
Posts: 6
Oil in my coolant.....

I have a 2001 Ford Ranger that i just got from my Father. I picked the truck up in Houston last week and drove it to Denver. The engine felt like it had a miss in it and i figured i would tune it when i got home. It threw a miss-fire cyl # 3 code at me and i thought it was a bad injector.I went to pull the injector and Low and behold i saw Oil in my coolant overflow tank???? No antifreeze in crankcase though? Has anyone run into this problem before? Is this a common problem with the 3.0 v6? There is some water seepage coming from behind the Timing Chain Cover, also it looks as if there are pieces of gasket in the Fluid i drained from the radiator... In need of advise.....
Reply With Quote
  #2  
Old 06-05-2011
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Dec 2010
Location: Flat Rock, Mi
Posts: 6,313
Sounds like you blew a gasket.
Reply With Quote
  #3  
Old 06-05-2011
Member
Thread Starter
 
Join Date: Jun 2011
Location: Denver, Co.
Posts: 6
If it were a head gasket, then i would be seeing coolant in my crankcase oil. No coolant in oil and the truck is not overheating at all. Its runnining a little rough, like it has a miss in it. I was thinking something may be or have come apart behind the Timing cover... Water pump??? This really sucks! The truck only has 80k on it, my dad gave the truck to me because of his health, sounds like its time to start pulling things apart....
Reply With Quote
  #4  
Old 06-05-2011
Masteratarms93's Avatar
Member
iTrader: (8)
 
Join Date: Mar 2010
Location: Goose Creek SC
Posts: 4,685
The 3.0 has a coolant leak problem in the front. I'm not familiar with it or any specifics, a 3.0 or a Ford guy should chime in with more description for you.
Reply With Quote
  #5  
Old 06-05-2011
Member
Thread Starter
 
Join Date: Jun 2011
Location: Denver, Co.
Posts: 6
Thanks man! I dont think its a head gasket prob or i would have coolant in my cranckcase. Its weird that the oil is getting into the coolant somehow. To me it seems like the water pump or something behind the Timing Chain cover has let go and is coming apart. Upon closer inspection i saw that the front pan seal was squashed out. It looks like someone has been in there before because the gasket between the T.C cover and the block has too much siliconearound it and is all wet and being eaten away by the coolant seeping out. This is not how i planned my week..... Frustrated....
Reply With Quote
  #6  
Old 06-05-2011
Member
Thread Starter
 
Join Date: Jun 2011
Location: Denver, Co.
Posts: 6
Your Ranger Looks Preety Sweet! I like the way it looks with the Lift on it. I have an 01 Supercab 2wd, at, and its Red also. I was wondering what it would look like if i put a small lift on it like a pre runner. The pic of your truck gives me a good idea.
Reply With Quote
  #7  
Old 06-05-2011
Masteratarms93's Avatar
Member
iTrader: (8)
 
Join Date: Mar 2010
Location: Goose Creek SC
Posts: 4,685
Quote:
Originally Posted by DesertRattler006 View Post
Your Ranger Looks Preety Sweet! I like the way it looks with the Lift on it. I have an 01 Supercab 2wd, at, and its Red also. I was wondering what it would look like if i put a small lift on it like a pre runner. The pic of your truck gives me a good idea.
Yeah there are a few 2WDs on here running lift.

Mine is 3 inch lift in the front and 2 inch the back. It's close to level but you can tell it's squatted in the back. I like it :)
Reply With Quote
  #8  
Old 06-06-2011
buckgnarly's Avatar
Member
iTrader: (11)
 
Join Date: Jan 2005
Location: West Topsham, VT
Posts: 1,709
Is it an auto? Sure it's not ATF leaking into the cooler from the trans cooler/warmer that runs in the radiator?
Had that happen to my Explorer, tranny line in the rad burst, but it did have a red color in the coolant....might want also check the ATF if it is an auto.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Odd coolant leak / Starter oil leak?? iplayloudly 2.9L & 3.0L V6 Tech 2 12-12-2011 05:04 PM
I have Oil in my Coolant???? DesertRattler006 2.9L & 3.0L V6 Tech 3 06-21-2011 07:03 PM
coolant leak, possibly oil coleary15 General Ford Ranger Discussion 9 01-14-2011 06:28 PM
Anyone have Coolant and Oil Diagram? (4.0L SOHC) BurningRANGERtires General Technical & Electrical 0 07-30-2009 10:27 PM
What causes coolant in your oil??? Needforspeed3685 General Ford Ranger Discussion 45 08-29-2007 11:50 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:04 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.