popping/stress when turning wheels... - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 05-30-2009
kymudder08's Avatar
Member
Thread Starter
 
Join Date: Apr 2009
Location: Owensboro, KY
Posts: 838
popping/stress when turning wheels...

ok, i got the clicking/cracking noise to stop that i posted about a month ago somehow. but now when turning its like it struggles to turn for some reason. its makes multiple poping noises you can hear/feel. does it in rev and forward and sittin still... kinda like what they do in 4wd but its in 2wd. i was thinkn its the PS pump or low flud. the resevoir showes its good. im thinkn that its been goin out slowly but when i put the 33x12.50 it killed it. lol. i do need to replace front steering/susp components and shocks. need the TREs, UCAs, 5100 bilsteins, and eventually breaks.
Reply With Quote
  #2  
Old 05-30-2009
kymudder08's Avatar
Member
Thread Starter
 
Join Date: Apr 2009
Location: Owensboro, KY
Posts: 838
no ideas...
Reply With Quote
  #3  
Old 05-30-2009
Member
 
Join Date: Jul 2005
Location: College Station
Posts: 2,781
My front end was popping.. it was the inner tie rods.. sucks..
Reply With Quote
  #4  
Old 05-30-2009
kymudder08's Avatar
Member
Thread Starter
 
Join Date: Apr 2009
Location: Owensboro, KY
Posts: 838
did it pop in the steering wheel every full turn and sounds like its in a bind when turning going slow? mainly in reverse
Reply With Quote
  #5  
Old 05-31-2009
kymudder08's Avatar
Member
Thread Starter
 
Join Date: Apr 2009
Location: Owensboro, KY
Posts: 838
anyone else?
Reply With Quote
  #6  
Old 05-31-2009
mossyoak03's Avatar
Member
iTrader: (1)
 
Join Date: Oct 2006
Location: Virginia Beach, VA
Posts: 193
its your tire rod ends. see if you can get a friend under there and see if they can tell if they can hear where its coming from.
Reply With Quote
  #7  
Old 05-31-2009
Prerunner-Ranger's Avatar
Level I Supporter
 
Join Date: Feb 2008
Location: Lancaster, CA.
Posts: 2,280
x2 tie rod ends
Reply With Quote
  #8  
Old 05-31-2009
kymudder08's Avatar
Member
Thread Starter
 
Join Date: Apr 2009
Location: Owensboro, KY
Posts: 838
ok, do yall think its inner, outter, or both? cash aint a prob so im def gonna get moog and most likely gonna get both inner and outter. any idea how to get to the inner TRE bc of the boot and clamp???
Reply With Quote
  #9  
Old 05-31-2009
mossyoak03's Avatar
Member
iTrader: (1)
 
Join Date: Oct 2006
Location: Virginia Beach, VA
Posts: 193
Quote:
Originally Posted by kymudder08 View Post
ok, do yall think its inner, outter, or both? cash aint a prob so im def gonna get moog and most likely gonna get both inner and outter. any idea how to get to the inner TRE bc of the boot and clamp???
ya if i was you and money isn't an issue get the the inner and outer ones
Reply With Quote
  #10  
Old 05-31-2009
robert99ranger's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Aug 2007
Location: Indiana/Mississippi
Posts: 5,807
Sounds kinda like mine when my tie rod ends went out
Reply With Quote
  #11  
Old 05-31-2009
kymudder08's Avatar
Member
Thread Starter
 
Join Date: Apr 2009
Location: Owensboro, KY
Posts: 838
yea, it sucks and is annoying as hell. need new shocks and could use moog UCAs. hell, while im at it why dont i just do a freakin SAS...
Reply With Quote
  #12  
Old 05-31-2009
Redrocket's Avatar
Member
iTrader: (6)
 
Join Date: Jan 2007
Location: Waynesville n.c
Posts: 1,993
when you do the inners cut the band on the boot when you go to put it back on a zip tie works well to hold the boot on
Reply With Quote
  #13  
Old 05-31-2009
kymudder08's Avatar
Member
Thread Starter
 
Join Date: Apr 2009
Location: Owensboro, KY
Posts: 838
sounds like an idea but my dad is **** about using correct hardware. lol. what does that boot actually do neways???
Reply With Quote
  #14  
Old 05-31-2009
Fx4wannabe01's Avatar
RF Veteran
iTrader: (23)
 
Join Date: May 2005
Location: Boring, Oregon
Posts: 21,721
you've posted threads with front end issues over the past like month......get that front end checked out. Upper and lower balljoints, inner and outer tierods have been suggested in ALL of those threads. Sames goes for this one..
Reply With Quote
  #15  
Old 06-01-2009
kymudder08's Avatar
Member
Thread Starter
 
Join Date: Apr 2009
Location: Owensboro, KY
Posts: 838
Quote:
Originally Posted by Fx4wannabe01 View Post
you've posted threads with front end issues over the past like month......get that front end checked out. Upper and lower balljoints, inner and outer tierods have been suggested in ALL of those threads. Sames goes for this one..
i did, and they found a bad axle shaft and bearing and i had it fixed. they said that that should solve all my problems, this was at a ford dealership btw. a week or so after the fact i noticed the problems again and did have the chance to ever take it down there due to my boss bein on vacation and i was on call 24/7. and here i am. im just gonna replace IN/OUT TREs and see if that fixes it, even if it doesnt it still replaces a part w/ 113k miles on it...
Reply With Quote
  #16  
Old 06-01-2009
dixie_boysles's Avatar
Member
iTrader: (1)
 
Join Date: Jul 2006
Location: NC
Posts: 3,778
x3 on the tire rod ends
Reply With Quote
  #17  
Old 06-02-2009
kymudder08's Avatar
Member
Thread Starter
 
Join Date: Apr 2009
Location: Owensboro, KY
Posts: 838
forgot to ask something... will popping from the TREs travel through the steering column where i can hear/feel it through the steering wheel???
Reply With Quote
  #18  
Old 06-02-2009
kymudder08's Avatar
Member
Thread Starter
 
Join Date: Apr 2009
Location: Owensboro, KY
Posts: 838
i was lookin on summit at the moog IN/OUT TREs and UCAs. but theres 3 diff UCAs, 1 for drivers side, 1 for passenger, and the other one doesnt say. im guessing the 1st 2 that list what sides are the right ones, and i guess they come w/ BJs? and it lists only 2 diff TRES (IN/OUT) so sides are universal? when i searched for ranger and my yr all these parts came up, but when i selected 4.0 it just showed the allignment kit. so does that mean that it doesnt matter what engine? i just dont wanna order them and they end up not workin... when i ordered the BL from summit i asked who i was tlkn to if itd fit and they couldnt tell me ****
Reply With Quote
  #19  
Old 06-02-2009
kymudder08's Avatar
Member
Thread Starter
 
Join Date: Apr 2009
Location: Owensboro, KY
Posts: 838
could ne of it be the steering extension from the body lift???
Reply With Quote
  #20  
Old 06-02-2009
kymudder08's Avatar
Member
Thread Starter
 
Join Date: Apr 2009
Location: Owensboro, KY
Posts: 838
??
Reply With Quote
  #21  
Old 06-03-2009
Prerunner-Ranger's Avatar
Level I Supporter
 
Join Date: Feb 2008
Location: Lancaster, CA.
Posts: 2,280
NA prolly your tie rod ends
Reply With Quote
  #22  
Old 06-03-2009
mossyoak03's Avatar
Member
iTrader: (1)
 
Join Date: Oct 2006
Location: Virginia Beach, VA
Posts: 193
Quote:
Originally Posted by kymudder08 View Post
could ne of it be the steering extension from the body lift???
no it wouldn't pop it would just spin and not move the wheels
Reply With Quote
  #23  
Old 06-03-2009
kymudder08's Avatar
Member
Thread Starter
 
Join Date: Apr 2009
Location: Owensboro, KY
Posts: 838
ic, i take it that happened to you. lol
Reply With Quote
  #24  
Old 06-03-2009
kymudder08's Avatar
Member
Thread Starter
 
Join Date: Apr 2009
Location: Owensboro, KY
Posts: 838
i think imma buy the in/out TREs and try to find a place that sells the KYB shocks around here. should i get moog UCAs as well or is there nething else yall would suggest?
Reply With Quote
  #25  
Old 06-03-2009
"Monster Truck"'s Avatar
Member
 
Join Date: Jan 2008
Location: Cedar Rapids, Ia
Posts: 203
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
I hear popping when turning. HarryTasker Solid Axle Swaps 2 06-04-2010 08:26 PM
Stress crack in LCA much? eeeekkk Prerunner-Ranger Suspension Tech 9 05-25-2010 10:22 AM
once the wheels pit is there no turning back? cucukid124 Auto Detailing 101 31 03-24-2010 08:40 PM
Stress on CV shafts Yellow_edge_4x4 Suspension Tech 0 08-25-2009 06:54 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:21 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.