Well the Ranger pooped out on me - Ranger-Forums - The Ultimate Ford Ranger Resource


General Ford Ranger Discussion General discussion of the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 02-27-2010
johndeeregarner's Avatar
Member
Thread Starter
 
Join Date: Aug 2009
Location: Memphis
Posts: 157
Well the Ranger pooped out on me

I was on the way to a friends house last night in my 86 and it was mostly highways. I set the cruse for 60 and left it like that for about 20 minutes. I stopped at a stop sign and when I took off I thought I saw a little smoke, so I stopped again and smoke started pouring out of the engine compartment! Luckly there was a gas station on the corner there so I pulled off the road and called for backup (my dad and our trailer). It took him about 40 minutes to get there and it was still smoking when he got there. I was thinking I had blown a gasket or a seal or something like that, but once I got a flash light and looked at it it looked more like antifreeze. I had close to no antifreeze left in in.
I haven't gotten a chance to look at it further, but I plan to do that here in a minute.

I kinda was expecting this to happen sooner or later. I had rescued this truck from a field and it had weeds growing through it and all that good stuff. It had been sitting for 4.5 years. Surprisingly, I didn't have to do anything to the engine other than get a battery for it and it started right up! So I just focused on the outside and got it looking nice. But lately, its been showing signs of old age. So it didn't really surprise me that this happened.


Oh.....and I never got to my friends house. :P
Reply With Quote
  #2  
Old 02-27-2010
evilclown312's Avatar
Member
iTrader: (3)
 
Join Date: Dec 2008
Location: Logan ohio
Posts: 2,772
Sounds like a blown radiator hose. Sorry to hear...
Reply With Quote
  #3  
Old 02-27-2010
Tys 4x4 FTW's Avatar
RF Veteran
iTrader: (8)
 
Join Date: Jul 2008
Location: Las Vegas, Nevada
Posts: 6,575
5.0
Reply With Quote
  #4  
Old 02-27-2010
johndeeregarner's Avatar
Member
Thread Starter
 
Join Date: Aug 2009
Location: Memphis
Posts: 157
Quote:
Originally Posted by Tys 4x4 FTW View Post
5.0
No no no, its a 2.9. But nice try. lol


I found out what the problem was. It was the heater hose that hooks up to the water neck. We put water back in it and started it and it started pouring out there. So I'm getting a new heater hose and the top radiator hose had a small hose in it. So I'm replacing that too.
I'm just glad its not anything really bad. :P
Reply With Quote
  #5  
Old 02-27-2010
Shwack10's Avatar
Member
 
Join Date: Nov 2009
Location: Saskatchewan
Posts: 64
I think he meant it's time for a 5.0?
Reply With Quote
  #6  
Old 02-27-2010
annguyen1981's Avatar
Member
iTrader: (4)
 
Join Date: Apr 2009
Location: Chicopee, MA
Posts: 1,888
Heater hose? That's a cheap fix. Glad it wasn't something more serious. :)
Reply With Quote
  #7  
Old 02-27-2010
johndeeregarner's Avatar
Member
Thread Starter
 
Join Date: Aug 2009
Location: Memphis
Posts: 157
Quote:
Originally Posted by Shwack10 View Post
I think he meant it's time for a 5.0?
Oh...I knew that......

But yeah, I'm going to keep the 2.9 in my 86. The 97 however, ha! Yeah, thats a different story. Its getting it all, 5.8, tuner, drag tires, lighting exhaust, etc. The only thing that is holding me back now is that little green stuff.
Reply With Quote
  #8  
Old 02-28-2010
rolsmojave3's Avatar
Level III Supporter
 
Join Date: Jun 2006
Location: Wisconsin
Posts: 2,852
Might as well get both heater lines and upper and lower radiator lines. That way the other rotten hoses won't blow on you.
Reply With Quote
  #9  
Old 02-28-2010
johndeeregarner's Avatar
Member
Thread Starter
 
Join Date: Aug 2009
Location: Memphis
Posts: 157
Quote:
Originally Posted by rolsmojave3 View Post
Might as well get both heater lines and upper and lower radiator lines. That way the other rotten hoses won't blow on you.
Thats what I'm doing.
Reply With Quote
  #10  
Old 02-28-2010
annguyen1981's Avatar
Member
iTrader: (4)
 
Join Date: Apr 2009
Location: Chicopee, MA
Posts: 1,888
Quote:
Originally Posted by johndeeregarner View Post
Oh...I knew that......

But yeah, I'm going to keep the 2.9 in my 86. The 97 however, ha! Yeah, thats a different story. Its getting it all, 5.8, tuner, drag tires, lighting exhaust, etc. The only thing that is holding me back now is that little green stuff.
Martians? I'm confused.


lol
Reply With Quote
  #11  
Old 02-28-2010
93rangerXLT4x4's Avatar
Member
 
Join Date: Aug 2009
Location: Salmon Arm BC
Posts: 959
sure glad it was nothing serious... im hoping to fix my truck next weekend (has a really bad coolant leak, possible water pump gasket) and then im tossing it on the road finally... now that im working i need my own wheels back.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Check this out. Got my Ranger out of the garage. RazorsEDGE Snapshots 20 12-09-2011 08:16 PM
Well the civic is gone...check out the replacement Sonic04Edge Snapshots 68 11-10-2009 10:15 PM
Well think Im getting rid of the ranger Nate97Ranger General Ford Ranger Discussion 33 05-01-2007 08:23 AM
Well, I found out the problem. Wertzy 2.9L & 3.0L V6 Tech 12 01-05-2006 04:39 PM
Well Factory Warranty has Just Run Out 04lvl2 General Ford Ranger Discussion 31 12-01-2005 09:03 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:52 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.