06 xlt fog lights not working - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-13-2013
johnboytnt's Avatar
Member
Thread Starter
 
Join Date: Apr 2013
Location: north carolina
Posts: 44
06 xlt fog lights not working

hey i have just recently bought a 06 ranger and i noticed the fog lights dont work i checked they have bulbs the button is pushed in lights on all the way and on low beam and the light on the fog light switch isnt on like on my brothers 03
please help me i will answer any questions you ask
Reply With Quote
  #2  
Old 04-13-2013
06RangerXLT's Avatar
Member
iTrader: (2)
 
Join Date: Feb 2011
Location: Halton Hills, Ont
Posts: 1,685
ok so with headlight switch on, does the little LED in the fog switch on the dash light up? should be bright green.

check the fog fuse. it could be blown.

then check bolbs, they could be burnt out (if yes to the LED lighting up on switch)
Reply With Quote
  #3  
Old 04-13-2013
johnboytnt's Avatar
Member
Thread Starter
 
Join Date: Apr 2013
Location: north carolina
Posts: 44
the led light on the dash does not light up
what fuze would that be and ill check it
Reply With Quote
  #4  
Old 04-13-2013
06RangerXLT's Avatar
Member
iTrader: (2)
 
Join Date: Feb 2011
Location: Halton Hills, Ont
Posts: 1,685
not sure. check your owners n=manual, i think its like page 63.
Reply With Quote
  #5  
Old 04-14-2013
johnboytnt's Avatar
Member
Thread Starter
 
Join Date: Apr 2013
Location: north carolina
Posts: 44
I went to the dog light page and there's nothing so I wen to the fuzes and the only thing I could find in a relay in the engine compartment it's relay 38b
Reply With Quote
  #6  
Old 04-14-2013
johnboytnt's Avatar
Member
Thread Starter
 
Join Date: Apr 2013
Location: north carolina
Posts: 44
Quote:
Originally Posted by johnboytnt View Post
I went to the dog light page and there's nothing so I wen to the fuzes and the only thing I could find in a relay in the engine compartment it's relay 38b
Bumb please help me I need to fix this asap
Reply With Quote
  #7  
Old 04-14-2013
ranger4.0's Avatar
Member
iTrader: (1)
 
Join Date: Jul 2009
Location: cambridge, ontario
Posts: 3,922
check for a blown fuse as stated above. if that is good use a test light and check for power at the light sockets, if that is good connect your test light to the positive on the battery and try to send power down the ground side of the circuit for the foglights. if that works too then you need new bulbs
Reply With Quote
  #8  
Old 04-15-2013
06RangerXLT's Avatar
Member
iTrader: (2)
 
Join Date: Feb 2011
Location: Halton Hills, Ont
Posts: 1,685
fuse panel is in the passenger side foot well
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Brake lights not working. It's not the brake switch. ColinGooseHall General Technical & Electrical 3 05-01-2015 08:35 PM
fog lights not working? Otis_Ranger Exterior Semi-Tech 6 07-20-2013 07:14 PM
Installed HID lights in headlamps but now my fog lights will not work BmillerEdge General Technical & Electrical 1 12-29-2010 10:37 AM
HVAC lights, headlight switch light, 4wd lights not working.... Jwad00 General Technical & Electrical 1 09-05-2009 04:45 PM
Fog lights on a non fog light truck... melj2000 General Technical & Electrical 2 09-28-2007 12:12 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 03:46 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.