97 Ranger 4x4 Speedometer Issues HELP! - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-13-2011
Member
Thread Starter
 
Join Date: Dec 2010
Location: West Seneca NY
Posts: 2
97 Ranger 4x4 Speedometer Issues HELP!

1997 Ranger STX 4.0L 4x4 speedometer won't work, all other gauges work. Replaced sensor on the back of the tcase and the male Plug end as well to ensure they were both good. Fuses are all good as well, it was working fine for a little while then it would go in and out. Any help would be appreciated, I'm stumped and frustrated
Reply With Quote
  #2  
Old 04-13-2011
Member
 
Join Date: Jan 2010
Location: cranston,ri
Posts: 108
there is an abs/ speed sensor on top of the rear differential i think its a two pin try that one.
Reply With Quote
  #3  
Old 04-13-2011
Member
Thread Starter
 
Join Date: Dec 2010
Location: West Seneca NY
Posts: 2
I thought that was just for 2wd models On the rear diff and wouldn't the ABS light be on? Sorry for askin ?s ha but I just don't wanna buy any more parts unless I can pinpoint it definitely
Reply With Quote
  #4  
Old 04-14-2011
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,831
The ABS sensor on the diff does double duty as a VSS for speedometer input in 98~00 Ranger and 01 2.5L Ranger. Other years use this sensor for ABS only.

The 95~97 speedometer gets its signal directly from a gear driven Signal Generator. The 2WD SG is driven from the transmission; the 4x4 SG is near the top of the transfer case.

The SG uses two wires. The gray/black goes to the speedometer, PCM and speed control in parallel. The pink/orange goes to the bolted ground under the hood on the DS inner fender apron.

Possible causes for dead speedometer:

Open/grounded gr/bk wire
Open pk/or from SG to DS inner fender apron ground point
Bad speedo head/cluster
Bad Signal Generator
Stripped drive gear for SG
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Speedometer, Odometer Issues....Help! thefraze_1020 General Technical & Electrical 2 10-09-2016 05:35 PM
Tachacardic Speedometer and Engine issues ghaskins General Technical & Electrical 0 10-05-2013 06:52 PM
Removed cluster to replace burned bulbs now issues with speedometer! iponnet22 General Technical & Electrical 7 11-23-2012 02:51 PM
ABS/Speedometer Issues 1999rangerXLT General Technical & Electrical 4 09-21-2011 03:19 PM
Speedometer Issues FULLSCALE General Ford Ranger Discussion 2 09-14-2010 09:33 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 04:39 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.