ABS light? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 07-21-2008
ranger_1999's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Jan 2008
Location: spindale, NC
Posts: 1,444
Icon5 ABS light?

So my ABS light has been on a few days now, everything seems fine. Should i just disregard it or check into it?, my braking is fine also. Wonder WTF the problem is? Help me out men
Reply With Quote
  #2  
Old 07-21-2008
elementsenjoi's Avatar
Member
iTrader: (2)
 
Join Date: Aug 2007
Location: 352 Florida
Posts: 1,301
if the light is on the ABS system is probably disabled. have you checked your fuses and such?
Reply With Quote
  #3  
Old 07-21-2008
Member
 
Join Date: Oct 2004
Location: ***
Posts: 2,099
^ I had a blinking ABS light and a busted fuse was the culprit

Had it on another time cuz the brake fluid was too low

Had it on another time cuz one of the sensors was gunked up, there is one pretty much right on top on the rear diff, may wanna check it and clean it then hit it with some di-electric grease

Might wanna check things like that which are real easy before you go try to take it to a shop er somethin
Reply With Quote
  #4  
Old 07-22-2008
ranger_1999's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Jan 2008
Location: spindale, NC
Posts: 1,444
Icon4

No i havent checked the fuses yet, ill do that here soon. I didnt know there was a sensor on the diff, ill check it out too..

NEW problem, now this morning my CEL came on, so i dont know whats up..I figured id take it to a auto parts store and have them pull the codes....

Im thinking the CEL light might be b/c my alternator....My truck has been "weezing" for a while now, like a loud *** hum from the passenger side, i opened the hood and listend it souded like it was the Air box or right below it, kinda hard to pin point, so since the ALT is on that side i was thinking it could be it or my belt????
Reply With Quote
  #5  
Old 07-22-2008
ranger_1999's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Jan 2008
Location: spindale, NC
Posts: 1,444
Checked my fuses, #17 was blown, when i replaced it with another fuse i had it blew it Automatically??

The code is Data link connector and the cig lighter.

My cig lighter hasnt worked since ive had the truck, the brace doesnt keep it in place it hangs behind the hole...Im pretty sure it has no power

Well I wonder if that explains the CEL light too??? Anybody know

Could it be from where i hooked the OHC into the ECM? maybe the splices arent right, even though i put a zip tie around them??

Last edited by ranger_1999; 07-22-2008 at 06:57 AM.
Reply With Quote
  #6  
Old 07-22-2008
dakota772's Avatar
Member
 
Join Date: May 2008
Location: Tucson
Posts: 230
Quote:
Originally Posted by ranger_1999 View Post
Checked my fuses, #17 was blown, when i replaced it with another fuse i had it blew it Automatically??
Disconnect the battery before you replace the fuse. Since the fuse box had power when you tried to replace this one, you may have sparked something causing the fuse to blow. So, disconnect the battery first and you should be okay.

As far as the "data link connector", I have never had that code. One of the other guys here will have to help you with that.
Reply With Quote
  #7  
Old 07-22-2008
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
Hey Dustin, long time no talk. Any chance you have wires crossed from the OHC? This could cause the fuse to blow.
Reply With Quote
  #8  
Old 07-22-2008
ranger_1999's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Jan 2008
Location: spindale, NC
Posts: 1,444
Quote:
Originally Posted by 04blackedge View Post
Hey Dustin, long time no talk. Any chance you have wires crossed from the OHC? This could cause the fuse to blow.
Hey trent, yeah its been a while...Nice pic, like your bodylift.....

Umm, well im sure theyre not crossed or else it would blew the fuse earlier id imagine..Ill have to go buy some more 25 fuses and ill DISconncect the battery this time and try it...

I just wonder what blew the fuse the first time????, also i wonder if the CEL light is becasue the fuse or another problem??
Reply With Quote
  #9  
Old 07-22-2008
ranger_1999's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Jan 2008
Location: spindale, NC
Posts: 1,444
Quote:
Originally Posted by dakota772 View Post
Disconnect the battery before you replace the fuse. Since the fuse box had power when you tried to replace this one, you may have sparked something causing the fuse to blow. So, disconnect the battery first and you should be okay.

As far as the "data link connector", I have never had that code. One of the other guys here will have to help you with that.

I just meant i lloked up what that fuse was for and its for the DLC and the cig lighter...not i pulled the CEL code and it was that
Reply With Quote
  #10  
Old 07-22-2008
ranger_1999's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Jan 2008
Location: spindale, NC
Posts: 1,444
Bump, if i replace the fuse and it blows again then what should i do??
Cuz im just wondering what blew it in the first place?
Reply With Quote
  #11  
Old 07-22-2008
ranger_1999's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Jan 2008
Location: spindale, NC
Posts: 1,444
update::: Well i unhooked the battery then pluged a 30 amp fuse into #17, it blew it...So i dont know WTF is up, any help out there...I mean my truck is fine, its just something electrical i guess???
Reply With Quote
  #12  
Old 07-22-2008
FullThrottle02's Avatar
Member
iTrader: (3)
 
Join Date: Apr 2008
Location: McHenry,IL
Posts: 586
Is there anything in the cig lighter? I have seen pennies get in there and cause the fuse to blow, then when you put a new one in it blows right away.
Reply With Quote
  #13  
Old 07-23-2008
ranger_1999's Avatar
Member
Thread Starter
iTrader: (3)
 
Join Date: Jan 2008
Location: spindale, NC
Posts: 1,444
Update::

Well i unhooked the battery and replaced the fuse, and reconnected the battery and crunk my truck, the fuse blew again....Theres nothing in the cig lighter it doesent even work, theres no lighter in it, just the receiver part of it, but it dont work...

Now my CEL light went off?? So i hope thats good, so the ABS light is still on??

Why does #17 keep blowing, does the ABS have something to do with that???
Im sure it doesnt
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2000 Ranger 2 wheel abs or 4 wheel abs?? Please help NedoMedo Suspension Tech 6 02-23-2012 06:04 PM
4 wheel ABS or 2 wheel ABS? dirtybird819 Suspension Tech 7 02-27-2011 11:50 AM
2 wheel abs to 4 wheel abs ???? kenflash New Ideas 1 10-07-2010 06:01 AM
battery light ABS light dim light RangerSkippyRoo General Technical & Electrical 3 05-25-2009 11:25 AM
New ABS sensor, now ABS light. 01xltranger4x4 Drivetrain Tech 32 06-26-2007 06:24 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:43 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.