AC problem - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-20-2008
leadfoot's Avatar
Member
Thread Starter
 
Join Date: Oct 2007
Location: MA
Posts: 894
Icon9 AC problem

On a hot day I got into my truck and turned on the AC. It was already 90-95 degrees in the truck. I waited 5 minutes for it to start blowing cold air, it never did, instead it blew hot air like it was on heat at 135 degrees. My temp controll **** had no effect on AC or heat. Max AC works fine however.

The temp control **** tested bad and I got a new one. The problem still persisted. We dicoverd the problem to be a broken valve in the ductwork behind the glove box. The temp control **** controls a white servo, the link from the servo to the valve in the duct is busted. The heater pleum needs to be removed to fix this.

when on Max AC the valve to the heater core is shut, on ac it is open. Is this right? Any comments suggestions or help would be greatly appreciated.
Reply With Quote
  #2  
Old 04-20-2008
Rev's Avatar
Rev Rev is offline
Level I Supporter
 
Join Date: May 2005
Location: San Diego, CA
Posts: 1,179
Reply With Quote
  #3  
Old 04-21-2008
leadfoot's Avatar
Member
Thread Starter
 
Join Date: Oct 2007
Location: MA
Posts: 894
Yep, my blend door link to the electric actuator is busted.

Thanks
Reply With Quote
  #4  
Old 04-21-2008
leadfoot's Avatar
Member
Thread Starter
 
Join Date: Oct 2007
Location: MA
Posts: 894
Thank you I used this link http://www.blenddoorfix.netfirms.com/ and did what they said and now everything works fine.

Free Fix
Reply With Quote
  #5  
Old 05-08-2011
morris's Avatar
RF Veteran
iTrader: (5)
 
Join Date: Feb 2008
Location: South Detroit.
Posts: 7,833
ok, i have a similar or same problem. max ac works and reg. ac blows hot air. even when i turn the temp all hte way cold. so would this second link
(http://www.blenddoorfix.netfirms.com/) work? the first link comes up 404.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
What part is this? (pic) Blower problem, this the problem? stuck on vent! ChargerOnDavins General Technical & Electrical 4 10-03-2010 06:58 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 06:07 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.