Charge Questions - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-17-2007
Member
Thread Starter
 
Join Date: Mar 2006
Location: Spring Hope, NC
Posts: 18
Charge Questions

I think my truck might be losing power. Occaisionally while at a stop, my check gage light will come on, but there's no gage that's at a "check" level except my charging gage is right around the bottom corner of the battery icon. It's low, but not in the red. I took it to Advance and they checked the battery and alternator and they both seemed fine. The truck's cranking fine and always has, but my stereo has to be turned up more and more to be able to hear it and my power locks work erratically. The locks have been an issue for a little while and the stereo isn't the best quality, but I'm thinking they may be signs of something else. I also have a small amp and 10" sub wired to the power dist box and a couple of small lights that I rarely turn on. What can I check to see if I'm getting low volts without throwing parts at the charging system?
Reply With Quote
  #2  
Old 08-17-2007
rideac1's Avatar
Member
iTrader: (1)
 
Join Date: May 2005
Location: New Kensington, PA
Posts: 1,087
I was going to say it's your battery, but if you had it checked and it's OK, i'm not sure.
It's normal to have the battery gage at the bottom of the battery icon, so it should be ok. I don't know what to say. Are you sure no other gauges are high?
When you had it checked at Advance, it would have read the voltage.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
I need more power! Can I turbo charge it or is supercharging the only way? larsen550 4.0L OHV & SOHC V6 Tech 13 10-23-2009 04:23 PM
Battery Charge Question Mykhael General Technical & Electrical 0 06-06-2009 11:52 AM
Battery Light , Alternator bad, truck stalling, wont hold charge ......... pushdeck General Technical & Electrical 5 11-09-2006 12:17 AM
Delco-Remy Generator does not charge jorlee General Technical & Electrical 11 02-21-2006 08:40 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:10 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.