Computer messing up? - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-10-2010
LancerRevo's Avatar
Member
Thread Starter
 
Join Date: Jun 2009
Location: El Paso, TX
Posts: 262
Computer messing up?

Ok so i was leaving work, and i noticed my ABS light came on. So i was like ok.... maybe brake fluid is low, so i check and it was at the max line. So i started driving and then i noticed it was taking forever to shift, and then it did really really hard. Then i noticed the speedometer and odometer weren't moving....ok. So i called my brother, came by and unplugged the battery for a bit, same thing. So i started driving it home, and come around 45 or so the speedometer works(didn't notice if the miles were, too worried to care) so i drove and asked my brother and we were going to same speed..... Brother says it may be the speed sensors going out.

so what can all this be?

Im thinking a couple things maybe, just to throw out there that could have caused this:

Bigger tires, never programmed so speedometer is 5 miles off.

Had to change out my driver sides axel shaft in the rear(caused my brakes to go out and all)

Too late to run to autozone and plug in, so i have to wait till tomorrow morning now :/.
Reply With Quote
  #2  
Old 06-10-2010
demiseranger's Avatar
Member
iTrader: (2)
 
Join Date: May 2008
Location: Tucson , Arizona
Posts: 331
Get a new ABS/Speed Sensor. It plugs into the top of the axle. Larger tires wouldn't affect the sensor.
Reply With Quote
  #3  
Old 06-10-2010
LancerRevo's Avatar
Member
Thread Starter
 
Join Date: Jun 2009
Location: El Paso, TX
Posts: 262
Well im planning on changing both, 15 bucks each at autozone. One goes on the differential and other goes on transmission. Hopefully the abs sensor isnt bad, thats 60 bucks for one
Reply With Quote
  #4  
Old 06-10-2010
demiseranger's Avatar
Member
iTrader: (2)
 
Join Date: May 2008
Location: Tucson , Arizona
Posts: 331
You only have one VSS sensor on the axle housing. The VSS located on the transmission is for 93-97 and 01-on. The 98-00 VSS sensor is also the ABS sensor.
Reply With Quote
  #5  
Old 06-10-2010
LancerRevo's Avatar
Member
Thread Starter
 
Join Date: Jun 2009
Location: El Paso, TX
Posts: 262
Well i changed the rear sensor, and my abs light went off but my check engine light is on still. resetted the computer and still on :/. I cant find the other sensor on the tranny either, so we just gave up and went back to bed haha. damn i have work today so i cant check it at autozone again. Speedometer and all works again, shifts fine again. I just dont know whats throwing it off now
Reply With Quote
  #6  
Old 06-10-2010
demiseranger's Avatar
Member
iTrader: (2)
 
Join Date: May 2008
Location: Tucson , Arizona
Posts: 331
You do not have a sensor on the transmission. The CEL may be due to the transmission shifting hard, it happened to me when I swapped in my new axle and didn't have a speedo.

Did you disconnect the battery and turn on the headlights?
Glad you have your speedo working again
Reply With Quote
  #7  
Old 06-11-2010
LancerRevo's Avatar
Member
Thread Starter
 
Join Date: Jun 2009
Location: El Paso, TX
Posts: 262
Wow that worked haha. Thanks a bunch!!
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Threads messing up Trigger01 Ranger-Forums Office 11 03-04-2009 07:42 PM
some pics of me messing around The S-10 Killer Snapshots 2 01-10-2009 01:23 PM
Brakes messing up RockysFord Drivetrain Tech 16 03-20-2006 08:49 PM
cb whip antenna messing up radio reception? fletch12518 General Technical & Electrical 21 01-23-2006 12:59 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 07:29 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.