Cruise Control - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-07-2010
Member
Thread Starter
 
Join Date: Sep 2010
Location: Washington
Posts: 4
Cruise Control

I just bought my 1st Ford, It is a 1998 Ford Ranger (used). Anyway, I got a really good deal on it. 4.0, 4x4, one owner with only 105k on it and everything on it is solid and works like a champ BUT I'm having some problems with the cruise control. It don't work, when I look online for some insight on my issue all I find is about the recall. I called Ford it was fixed in Augest but the problem is that it won't turn on at all. I've checked the fuse and now have no other things I can think to look for or at. Anybody have any ideas?
Thanks in advance!!
Reply With Quote
  #2  
Old 09-07-2010
djfllmn's Avatar
Moderator
 
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
is your airbag light on too? could be a bad clockspring
Reply With Quote
  #3  
Old 09-07-2010
ccosgrove71's Avatar
Member
 
Join Date: Jun 2010
Location: richmond,va
Posts: 185
did you check the fuse in the harness from the recall?
Reply With Quote
  #4  
Old 09-08-2010
j99ranger4x4's Avatar
Member
iTrader: (5)
 
Join Date: Sep 2008
Location: Delaware, OH
Posts: 1,381
i was told the fuse was non servicable. ford has the switch and harness for 30 bucks.
Reply With Quote
  #5  
Old 09-08-2010
ccosgrove71's Avatar
Member
 
Join Date: Jun 2010
Location: richmond,va
Posts: 185
Get a razor blade and cut the loom back. There is a fuse in a rubber case inside the loom. you can put a new fuse in there, you just have to cut all the electrical tape and loom to get to it. I may have one laying around.
Reply With Quote
  #6  
Old 09-08-2010
rolsmojave3's Avatar
Level III Supporter
 
Join Date: Jun 2006
Location: Wisconsin
Posts: 2,852
This happened to me too. I took it in and they claimed they re did the recall. Whatever, at least my cruise works.
Reply With Quote
  #7  
Old 09-27-2010
Member
Thread Starter
 
Join Date: Sep 2010
Location: Washington
Posts: 4
Sorry for the long wait on a response. I checked all fuses and all was good BUT with this being my first Ford product I didn't realize the sensor on the top of the master cylinder was for the cruise. The clip had broke and was hanging. Instead of buying a new clip I worked some magic (a few zip ties) and put it back on. Works like a champ again! Thanks everybody for your insight on my problem
Reply With Quote
  #8  
Old 09-27-2010
j99ranger4x4's Avatar
Member
iTrader: (5)
 
Join Date: Sep 2008
Location: Delaware, OH
Posts: 1,381
i believe that sensor w the harness is only like 15 bucks
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Modding cruise control to a non cruise Ranger 2001fordranger General Technical & Electrical 1 07-29-2009 11:58 PM
fixing cruise control on 2003 model wildbill83 General Technical & Electrical 6 05-13-2006 08:44 AM
Using Cruise Control buttons to control the Volume GVSU Godfather Audio & Video Tech 23 05-29-2005 07:39 PM
Cruise control problem in Rangers now Shalafi49 General Ford Ranger Discussion 44 05-04-2005 06:39 AM
Adding LED's to cruise control pods how-to n3elz Interior Semi-Tech 4 11-21-2004 09:02 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 11:28 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.