Headlight Issue - - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-12-2010
Rooks's Avatar
Member
Thread Starter
iTrader: (7)
 
Join Date: Sep 2006
Location: Minneapolis, MN
Posts: 1,867
Headlight Issue -

So the last few mornings, I've had a problem with my headlights on my 07. I got out and start up the truck and turn on the headlights. It's of course right around 0 degrees F most morning around here (at least as of late) so it's not warm by any stretch.

Anyway, when I turn the headlights on, the "bright light indictator" turns on immediately, but it is very dim. Along the same lines, my driver side headlamp doesn't turn on. Passenger side works fine. Brights still work fine (if I switch over to Brights the indicator turns bright and both lights come on).

Most of the time by the time the engine warms up, the indicator goes off, the driver side light turns back on and all is good. So my initial thought was that it had something to do with the cold weather. Some how a relay is too cold in the morning and once some current starts going through it, it eventually warms up and all is good.

Well, today I got all the way to work without it fixing itself (about a 25 minute drive). So it seems as though the problem is getting worse, because today was actually a warmer day then normal.

I'm really beginning to think this might have something to do with the Halos that I wired into the Marker lights this past spring. Only way to test that unfortunately is to hack up my wiring job.

Let me know if you guys have any thoughts on this or have heard of something like this.
Reply With Quote
  #2  
Old 01-12-2010
Schlitter22's Avatar
Member
 
Join Date: Dec 2007
Location: W, Oregon
Posts: 90
check any of the relays and distributer blocks if you have any for them. my KC foglights did the same exact thing a few weeks ago, opened up the little distributor block and inside it was completely corroded and shorted out.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
HEADLIGHT ISSUE AND LED DASH taylor304 General Technical & Electrical 3 11-17-2014 08:12 PM
Headlight Issue Rangerboy69 4.0L OHV & SOHC V6 Tech 2 07-25-2011 09:28 PM
Electrical Issue (wiper, a/c, headlight) nissanracer007 SOHC - 2.3L & 2.5L Lima Engines 1 08-17-2010 07:27 PM
Radio and headlight issue lol. Shaklakan Audio & Video Tech 4 03-08-2010 08:47 PM
Mazda headlight vs. 98-00 ranger headlight silverfox General Technical & Electrical 8 09-23-2009 03:20 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:13 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.