Help** Idle and Start-up Issues?? **Help - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-18-2014
Member
Thread Starter
 
Join Date: Jan 2014
Location: Kelowna
Posts: 1
Icon4 Help** Idle and Start-up Issues?? **Help

Hey so im new to this forum. I have a 2wd 1997 Ranger with the 4.0L with about 255xxx km on it. This problem began when i was driving around town and found that when i stopped my truck would sometimes stall. It would start back up and be fine, i just found it a pain to drive. This persisted for about a month or two and i didnt drive it much during this time. Then until recently it stalled while i was driving so i pulled over to the shoulder. It wouldnt start back up and i had to tow it home. I have replaced the fuel filter, put in fuel cleaner, replaced canister purge because i was reading code anyways, new air filter. The pump seems fine and the check engine was on prior but has been of since i disconnected the battery. It turns over but then has high or low idle and sputters to stay alive, if i give it gas it helps but it dies eventually anyways. Ive seen similar forums that suggest IAC, MAF, vac lines, etc... any idea if this can be narrowed down so i dont throw a lot of money at it only to have no results. Thanks, any help is appreciated.
Reply With Quote
  #2  
Old 01-19-2014
Rev's Avatar
Rev Rev is offline
Level I Supporter
 
Join Date: May 2005
Location: San Diego, CA
Posts: 1,179
Quote:
Originally Posted by ltyerman View Post
Hey so im new to this forum. I have a 2wd 1997 Ranger with the 4.0L with about 255xxx km on it. This problem began when i was driving around town and found that when i stopped my truck would sometimes stall. It would start back up and be fine, i just found it a pain to drive. This persisted for about a month or two and i didnt drive it much during this time. Then until recently it stalled while i was driving so i pulled over to the shoulder. It wouldnt start back up and i had to tow it home. I have replaced the fuel filter, put in fuel cleaner, replaced canister purge because i was reading code anyways, new air filter. The pump seems fine and the check engine was on prior but has been of since i disconnected the battery. It turns over but then has high or low idle and sputters to stay alive, if i give it gas it helps but it dies eventually anyways. Ive seen similar forums that suggest IAC, MAF, vac lines, etc... any idea if this can be narrowed down so i dont throw a lot of money at it only to have no results. Thanks, any help is appreciated.
It would be helpful if you have any codes that were present. Recommend re-scanning for set codes and going from there.
Reply With Quote
  #3  
Old 02-08-2014
Member
 
Join Date: Feb 2014
Location: palm bay,fl
Posts: 1
I'm having the same problem I can't figure it out either. I changed oil an filter, changed pcv, injector cleaner, an cleaned the iac an maf, nothing has helped, the truck is running like shut it stalls an bucks an idles weird
Reply With Quote
  #4  
Old 02-17-2014
cheese_man's Avatar
Member
iTrader: (1)
 
Join Date: Nov 2009
Location: arthur
Posts: 2,100
driving around with a nearly plugged up fuel filter will over time will damage the fuel pump

2nd / when the engine is warmed up , pull EGR vacuum hose , and listen for any engine rpm changes

smooth idle / erratic idle
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Startup and idle issues when cold... phils95cobra General Ford Ranger Discussion 0 10-29-2012 10:58 AM
2011 2.3L with idle and other issues 327Panther04 DOHC - 2.3L Duratec / Mazda L Engines 8 08-04-2012 03:54 PM
Idle woes and high idle 4door 2.9L & 3.0L V6 Tech 7 12-16-2010 12:49 PM
idle, and start up issues... Coleosis85 4.0L OHV & SOHC V6 Tech 3 11-08-2009 02:53 PM
Idle Air Sensor and Shift issues JaxRanger 2.9L & 3.0L V6 Tech 0 09-24-2008 08:56 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 09:53 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.