I think it's ignition. . . - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 04-14-2015
Member
Thread Starter
 
Join Date: Apr 2014
Location: Sacramento, Ca
Posts: 2
I think it's ignition. . .

because when I turn it off and re-start, the problem goes away. The problem is, I can be driving down the road with nothing amiss, and then suddenly I start to lose power intermittently. The tranny also starts to shift erratically, especially when it downshifts. As it loses its power, I can give it more gas and then it will take-off again. So, both the engine, and the transmission go haywire at the same time. As I said, if i turn it off and re-start, the prob goes away. BTW, I just replaced the ECM which did prove to be faulty from water damage due to a leaky windshield. It helped (I though it fixed it completely), but it looks like I didn't get it all.

Advice?
Reply With Quote
  #2  
Old 04-15-2015
Member
 
Join Date: Apr 2015
Location: Tecumseh,Ok.
Posts: 26
goes on & off

Check the electrical part of ingn. switch; might be coming apart; mine did that 2 times; another check is when it does again; wiggle ign. switch( mechanical part with the key) to see if it starts running again

Quote:
Originally Posted by whatsyurprob View Post
because when I turn it off and re-start, the problem goes away. The problem is, I can be driving down the road with nothing amiss, and then suddenly I start to lose power intermittently. The tranny also starts to shift erratically, especially when it downshifts. As it loses its power, I can give it more gas and then it will take-off again. So, both the engine, and the transmission go haywire at the same time. As I said, if i turn it off and re-start, the prob goes away. BTW, I just replaced the ECM which did prove to be faulty from water damage due to a leaky windshield. It helped (I though it fixed it completely), but it looks like I didn't get it all.

Advice?
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
you might think it's retarded but I think it's a cool idea.... rangerkidSHSU Ranger-Forums Office 4 03-11-2009 09:52 PM
found a bumper i think what do you think oilersfan_39 Exterior Semi-Tech 19 01-31-2007 04:50 PM
JBA Ignition wires. Mboever General Technical & Electrical 8 05-18-2006 06:16 AM
msd 6a ignition 02rangeroffroad 4.0L OHV & SOHC V6 Tech 6 10-19-2005 07:58 PM
ignition wires/plugs afi_pilot85 4.0L OHV & SOHC V6 Tech 3 03-26-2005 05:31 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:12 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.