Ignition Broke - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 06-07-2008
DaGGer's Avatar
Member
Thread Starter
 
Join Date: Mar 2006
Location: East Windsor, CT
Posts: 919
Ignition Broke

I don't know where this belongs but my ignition just broke. the part you put the key into just spins freely, there is no resistance to it anymore. Now I was loading heavy stuff into the bed just before that but I don't think that has anything to do with it. How do I go about getting a new one of these and how do I replace it. I've never even seen this type of thing covered on here before.
Reply With Quote
  #2  
Old 06-07-2008
My05edge's Avatar
Member
 
Join Date: Dec 2006
Location: Midland, TX
Posts: 1,351
thats probably gonna have to be a dealer repair or shop repair thing unfortunatly. the dealer can get one made with the same cut as your key i think.
Reply With Quote
  #3  
Old 06-07-2008
DaGGer's Avatar
Member
Thread Starter
 
Join Date: Mar 2006
Location: East Windsor, CT
Posts: 919
I'm going to go and order one from the parts store and just have two different keys for my truck I guess. I think I'm going to end up putting in my power door locks earlier than I thought ha ha ha.
Reply With Quote
  #4  
Old 06-07-2008
DaGGer's Avatar
Member
Thread Starter
 
Join Date: Mar 2006
Location: East Windsor, CT
Posts: 919
I got the part. I got the cover off the column I just have to figure out how to take it off.
Reply With Quote
  #5  
Old 06-07-2008
DaGGer's Avatar
Member
Thread Starter
 
Join Date: Mar 2006
Location: East Windsor, CT
Posts: 919
Ok I got an update. I pulled the old iginition. Not hard at all, but I broke a little something that attaches to the ignition. Well didn't "break" I broke a clip off it so right now when I put the ignition in I have to hold it there. Now, I can start my truck just fine. Well the thing gets a little stuck going forward but i can't turn it off. When I have the keys out of the ignition all the accessory lights are on, the ones id the dash are lit up like the check engine, abs, door ajar. They all stay on. Tell me its not something deeper in there.
Reply With Quote
  #6  
Old 06-07-2008
DaGGer's Avatar
Member
Thread Starter
 
Join Date: Mar 2006
Location: East Windsor, CT
Posts: 919
Well I have a video of whats going on if it helps. Its a little dark but just watch the thing and you'll see whats going on. I'm going to get a better video tomorrow. As of right now I can drive it to work so I'm set for that for right now. Its going to be a pain but oh well.

Reply With Quote
  #7  
Old 06-08-2008
DaGGer's Avatar
Member
Thread Starter
 
Join Date: Mar 2006
Location: East Windsor, CT
Posts: 919
bump?
Reply With Quote
  #8  
Old 06-08-2008
Hot Wheels's Avatar
Member
 
Join Date: Oct 2006
Location: Maple Plain, MN
Posts: 211
I watched your video and you're right, it is moving too freely. Did you replace just the ignition plug or the housing as well? Either way, having the lights on your dash leads me to believe you did something wrong while in there. If you replaced just the plug you could have messed up your housing. If that is the case I would recommend taking it in and having it fixed. It could be a simple timing issue or a hardware issue. Try a dealership, repair shop, or even a locksmith. All should be able to help you out.
Reply With Quote
  #9  
Old 06-08-2008
DaGGer's Avatar
Member
Thread Starter
 
Join Date: Mar 2006
Location: East Windsor, CT
Posts: 919
yeah I replaced just the cylinder. I'm going to find out how to take the column apart and see if I can figure it out that way and if not then I'm going to end up getting a new column out of Junk yard.
Reply With Quote
  #10  
Old 06-09-2008
Hot Wheels's Avatar
Member
 
Join Date: Oct 2006
Location: Maple Plain, MN
Posts: 211
Knowing that you replaced the plug, take it in. You shouldn't have had to pull a cover off at all. Our ignition cylinders can be pulled with a working key and a scratch awl. You may just have a timing issue or messed up the housing. There are 2 ignition styles in our rangers, they also have 2 very different tailpieces, you could have simply gotten the wrong one. It would be less time/ difficulty having this done than replacing the column. Just my .02 though.

Last edited by Hot Wheels; 06-09-2008 at 09:27 AM.
Reply With Quote
  #11  
Old 06-09-2008
DaGGer's Avatar
Member
Thread Starter
 
Join Date: Mar 2006
Location: East Windsor, CT
Posts: 919
yeah, I do have a garage right near my house. The guy just moved in and told us if we needed anything that I could stop by. I'll give him a call tomorrow and see what he says. I'll end up bringing it in on thursday as I can walk to my other job that day. There were two kinds at the auto parts store but they describe them as either black or chrome.

This just happened out of no where. I mean my cyilnder looked like it was pushed out a bit when i got in my truck and noticed it was first broken. So thats why I figured it was the ignition cylinder. On RPS.com they say that it could be that the box under neither the dash that contorls a few of the ignition parts may be bad to. I'm not sure. All I know is I'm going to end up making a quick disconnected until i can get it fixed. I just need to know what to do lol.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Broke my Ignition Cylinder Gear.. mp-ranger General Technical & Electrical 1 03-17-2013 07:36 PM
I think I broke my upper control arms/ ball joints jimmclrk1 Suspension Tech 10 02-02-2006 04:48 PM
Broke my wheel (56k warning) (long story warning too) gvranger Wheels & Tires Semi-Tech 18 08-12-2005 09:09 PM
Tail Gate Handle Broke!! Strider0O0 General Ford Ranger Discussion 27 12-20-2004 06:13 PM
i think i broke it, lol. need help and opinions [email protected] General Ford Ranger Discussion 3 08-03-2004 08:35 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 05:08 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.