Licence Plate lights Not Working - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-11-2008
mazzman's Avatar
Member
Thread Starter
 
Join Date: Jan 2008
Location: San Diego
Posts: 251
Licence Plate lights Not Working

so i got pulled over the other night for my licence plate lights not working, both of them. today i went and figured that its a fuse. well, the fuse isnt burnt out, and both lightbulbs are fine. so what gives?
Reply With Quote
  #2  
Old 08-11-2008
Dustin S's Avatar
Member
 
Join Date: Nov 2007
Location: trenton,GA
Posts: 724
Did you check to make sure the wires weren't cut? or broke?
Reply With Quote
  #3  
Old 08-11-2008
k.blakeley's Avatar
Member
 
Join Date: Apr 2007
Location: East Texas
Posts: 2,823
fuse,bulbs,connections,wires,switch,check all that
Reply With Quote
  #4  
Old 08-11-2008
thesoundmaster's Avatar
Member
 
Join Date: Mar 2007
Location: Centennial CO
Posts: 5
I thihnk Mazzgirl did it out of spite


Nah, in all seriousness, check all your connections to them
Reply With Quote
  #5  
Old 08-11-2008
Dustin S's Avatar
Member
 
Join Date: Nov 2007
Location: trenton,GA
Posts: 724
Quote:
Originally Posted by thesoundmaster View Post
I thihnk Mazzgirl did it out of spite


Nah, in all seriousness, check all your connections to them
LOL.... I was going to start my post with: Mazzman, if that is your real name,....
Reply With Quote
  #6  
Old 08-11-2008
mazzman's Avatar
Member
Thread Starter
 
Join Date: Jan 2008
Location: San Diego
Posts: 251
wires arent cut. whats the box that the wires lead into thats right above the spare tire?
Reply With Quote
  #7  
Old 08-11-2008
Dustin S's Avatar
Member
 
Join Date: Nov 2007
Location: trenton,GA
Posts: 724
What box? Mine hook up to the tail lights, so when the headlights are turned on the tag lights are on.
Reply With Quote
  #8  
Old 08-12-2008
mazzman's Avatar
Member
Thread Starter
 
Join Date: Jan 2008
Location: San Diego
Posts: 251
on my edge i see a box right above the spare tire. ill take a pic tomorrow
Reply With Quote
  #9  
Old 08-12-2008
99MazdaB4000's Avatar
Member
 
Join Date: Apr 2008
Location: Kutztown, PA
Posts: 1,980
Yeah, Ihave the little box too, thats where my RECON bar installed into. Thats nothing but the wiring harness for a trailer. From what I gather, the license plate lights are wired directly to the tails (?) because they come on automatically. Just replace the fuse and bulbs. You should be fine.
Reply With Quote
  #10  
Old 08-22-2008
ryan_88's Avatar
Member
 
Join Date: Nov 2007
Location: Somersworth, NH
Posts: 71
don't know if you fixed this issue yet or not, but i know that one of my '01 license plate lights isnt working because the socket is all corroded. i cant seem to find the sockets anywhere, so i will have to rig something else up for inspection next month.
Reply With Quote
  #11  
Old 08-22-2008
mossyoak03's Avatar
Member
iTrader: (1)
 
Join Date: Oct 2006
Location: Virginia Beach, VA
Posts: 193
how do you know the bulbs aren't working? get new ones and you should be good to go they burn out all the time.
Reply With Quote
  #12  
Old 08-22-2008
ryan_88's Avatar
Member
 
Join Date: Nov 2007
Location: Somersworth, NH
Posts: 71
Quote:
Originally Posted by mossyoak03 View Post
how do you know the bulbs aren't working? get new ones and you should be good to go they burn out all the time.
mine was so corroded that when i was trying to clean them, the metal contacts actually fell out. i bought a generic license plate socket today at autozone for $3.99, and will rig it up tomorrow. i can include pics if necessary.
Reply With Quote
  #13  
Old 08-22-2008
GrafixGuy's Avatar
RF Veteran
iTrader: (3)
 
Join Date: Jan 2005
Location: Montgomery, AL
Posts: 8,703
Quote:
Originally Posted by mazzman View Post
on my edge i see a box right above the spare tire. ill take a pic tomorrow
trailer light hookups?
Reply With Quote
  #14  
Old 08-23-2008
rsw2159's Avatar
Member
 
Join Date: Jun 2008
Location: Stanley, NC
Posts: 473
i have mine wired up like fog lights and set on a switch in my cab. works nicely when u **** ppl off or your tryn to not get ur plates called in.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Brake lights not working. It's not the brake switch. ColinGooseHall General Technical & Electrical 3 05-01-2015 08:35 PM
HVAC lights, headlight switch light, 4wd lights not working.... Jwad00 General Technical & Electrical 1 09-05-2009 04:45 PM
WTB: OE Licence Plate Holder (Front) NVRDONE Interior, Exterior, Electrical, & Misc. 1 06-30-2009 04:10 PM
Grill Gaurd and Licence Plate malydeen Exterior Semi-Tech 13 09-13-2007 07:53 PM
Licence plate light housing? SouthernMudSlinger General Ford Ranger Discussion 4 09-10-2007 12:02 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 02:30 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.