Nothing but problems! - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 09-23-2011
Ranger4.0XLT's Avatar
Member
Thread Starter
 
Join Date: Sep 2011
Location: Northford, CT
Posts: 501
Nothing but problems!

I am very unfortunate to say that ever since I have bought my 2001 Ranger I have had nothing but problems. The truck is a daily driver and does not see any degree of abuse. I have had transmission problems, engine idle problems, radiator problems, and the list goes on. If the truck goes over 65mph it shakes like crazy side to side. I was on my way home tonight and while driving down the road while in Drive the truck starts reving up..and the accelerator no longer works so I had to coast into a parking lot. From where I stand now Drive doesn't work. Reverse doesn't work. Only manual gears 1 and 2 work. I have had enough! I do like the truck don't get me wrong but I have never had so many issues with a vehical before!
Reply With Quote
  #2  
Old 09-23-2011
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Dec 2010
Location: Flat Rock, Mi
Posts: 6,313
Did you know 04RangerDave? lol.
We can help you out, Just ask away.
Reply With Quote
  #3  
Old 09-23-2011
Ranger4.0XLT's Avatar
Member
Thread Starter
 
Join Date: Sep 2011
Location: Northford, CT
Posts: 501
I have two problems.. the first is my engine. When I first start the truck up it runs fine. After have driven it and I go to put it back in Park the rpms creep up to 2,500 on their own. I can only imagaine how much damage that is doing to the tranny which brings me to problem two. My tranny now Drive doesn't work. Reverse doesn't work. Only manual gears 1 and 2 work. No codes show up for the enigne problem and I have just about replaced every sensor possible. It doesn't make any sense and I cannot safely drive this way. Any ideas?
Reply With Quote
  #4  
Old 09-23-2011
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Dec 2010
Location: Flat Rock, Mi
Posts: 6,313
Have you checked/Cleaned your IAC (Idle Aid Control) valve. It sounds like that is whats causing your engine trouble.
Your transmission also appears to be shot. I don't know too much about them, but i think the term is the torque bands? or something along those lines.
Reply With Quote
  #5  
Old 09-23-2011
99offroadrngr's Avatar
TOYOTA
iTrader: (37)
 
Join Date: Jul 2007
Location: Massachusetts
Posts: 11,728
torque converter

x2 on the iac. clean it out and see if it idles better.
Reply With Quote
  #6  
Old 09-23-2011
04RangerDave's Avatar
JDM> RANGER

iTrader: (3)
 
Join Date: Jul 2010
Location: RI
Posts: 5,030
Quote:
Originally Posted by StxDangerRanger View Post
Did you know 04RangerDave? lol.
We can help you out, Just ask away.
JERK

Quote:
Originally Posted by Ranger4.0XLT View Post
I am very unfortunate to say that ever since I have bought my 2001 Ranger I have had nothing but problems. The truck is a daily driver and does not see any degree of abuse. I have had transmission problems, engine idle problems, radiator problems, and the list goes on. If the truck goes over 65mph it shakes like crazy side to side. I was on my way home tonight and while driving down the road while in Drive the truck starts reving up..and the accelerator no longer works so I had to coast into a parking lot. From where I stand now Drive doesn't work. Reverse doesn't work. Only manual gears 1 and 2 work. I have had enough! I do like the truck don't get me wrong but I have never had so many issues with a vehical before!
mine did the same thing b4 it grenaded hope you have around $2500
Reply With Quote
  #7  
Old 09-24-2011
99offroadrngr's Avatar
TOYOTA
iTrader: (37)
 
Join Date: Jul 2007
Location: Massachusetts
Posts: 11,728
trannys aren't bad to do. i helped my replace do the E4OD (POS) on the bronco i bought. took us about 5 hours.
Reply With Quote
  #8  
Old 09-24-2011
04RangerDave's Avatar
JDM> RANGER

iTrader: (3)
 
Join Date: Jul 2010
Location: RI
Posts: 5,030
Wirelessly posted

It's not the replacing with a complete unit it's the rebuilding. Friggen puzzle I don't like transmissions I got a C+ in that class.
Reply With Quote
  #9  
Old 09-24-2011
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Dec 2010
Location: Flat Rock, Mi
Posts: 6,313
Quote:
Originally Posted by 04RangerDave View Post
Wirelessly posted

It's not the replacing with a complete unit it's the rebuilding. Friggen puzzle I don't like transmissions I got a C+ in that class.
I think i was sick that day at UTI. Transmissions suck
Reply With Quote
  #10  
Old 09-24-2011
04RangerDave's Avatar
JDM> RANGER

iTrader: (3)
 
Join Date: Jul 2010
Location: RI
Posts: 5,030
Quote:
Originally Posted by StxDangerRanger View Post
I think i was sick that day at UTI. Transmissions suck
UTI is a useless school
Reply With Quote
  #11  
Old 09-24-2011
djfllmn's Avatar
Moderator
 
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
Quote:
Originally Posted by 04RangerDave View Post
UTI is a useless school
thats why im glad i turned them down...hella expensive too
Reply With Quote
  #12  
Old 09-24-2011
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Dec 2010
Location: Flat Rock, Mi
Posts: 6,313
Quote:
Originally Posted by 04RangerDave View Post
UTI is a useless school
Sure, How much do you make at the dealership? don't tell me i know.
Cause of UTI, I work at ROUSH. You can't just walk into one of thier buildings and say, "oh, i work at a ford dealer, i'd like a job" They'll laugh you right out of the city. I make a hell of a lot more than a dealership mechanic ever will. in 2 years, I got a certification (i'm not going to say i learned, because i knew a lot going in) in the Automotive industry. The day after i got my certificate from there, i got a job at a Dodge dealership, 3 years after graduating i'm working making twice what i started out as.
Don't bash my school. Its not useless.
Reply With Quote
  #13  
Old 09-24-2011
04RangerDave's Avatar
JDM> RANGER

iTrader: (3)
 
Join Date: Jul 2010
Location: RI
Posts: 5,030
Wirelessly posted

UTI= piece of paper saying you leaned automotive
NEIT (new England institute of technology) automotive with high performance bachelors with automotive service management. I make a solid amount working on snakes and gt500s all day so I am happy.
Reply With Quote
  #14  
Old 09-24-2011
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Dec 2010
Location: Flat Rock, Mi
Posts: 6,313
Quote:
Originally Posted by 04RangerDave View Post
Wirelessly posted

UTI= piece of paper saying you leaned automotive
NEIT (new England institute of technology) automotive with high performance bachelors with automotive service management. I make a solid amount working on snakes and gt500s all day so I am happy.
Snakes and Gt500's aren't the world.
you'll learn soon enough. I was like you once. I wanted to work on stuff that went fast.
You try and get a job somewhere else and you tell them, "oh i've only done High preformance engine work" They'll tell you to get in line with the rest of the kids who've done the same exact thing.
Reply With Quote
  #15  
Old 09-24-2011
djfllmn's Avatar
Moderator
 
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
i toured UTI in exton,pa and it is a very nice school...however i couldnt justify spending 32 grand for a one year program...glad i didnt go because my dad got a job at the college i went to and because of that i had no tuition
Reply With Quote
  #16  
Old 09-24-2011
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Dec 2010
Location: Flat Rock, Mi
Posts: 6,313
Quote:
Originally Posted by djfllmn View Post
i toured UTI in exton,pa and it is a very nice school...however i couldnt justify spending 32 grand for a one year program...glad i didnt go because my dad got a job at the college i went to and because of that i had no tuition
32 sounds wrong to me. to tell the truth, I didn't pay for it. but i know it was less than that.
I paying that for my current college i'm going to (getting my real career)
Reply With Quote
  #17  
Old 09-24-2011
djfllmn's Avatar
Moderator
 
Join Date: Mar 2009
Location: York, PA
Posts: 5,796
Quote:
Originally Posted by StxDangerRanger View Post
32 sounds wrong to me. to tell the truth, I didn't pay for it. but i know it was less than that.
I paying that for my current college i'm going to (getting my real career)
That's what the bottom line was...I had signed up for the ford FACT course too
Reply With Quote
  #18  
Old 09-24-2011
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Dec 2010
Location: Flat Rock, Mi
Posts: 6,313
Quote:
Originally Posted by djfllmn View Post
That's what the bottom line was...I had signed up for the ford FACT course too
I knew about all of those Ford sponsored things. But i wanted to do more than just work on Fords.
I took the UTI thing right out of high school because i knew i could get a job and make some money, Now that i'm making money i'm going to school to do what i really want to do. (i've already paid off my UTI bills) Which is Audio Engineering. I go to a much larger and more expensive and prestigious university now, but i would still recommend UTI to anyone who wants to get their foot in the door and do something like i do everyday, Work on prototype and experimental crash and safety cars. its a blast.
Reply With Quote
  #19  
Old 09-24-2011
04RangerDave's Avatar
JDM> RANGER

iTrader: (3)
 
Join Date: Jul 2010
Location: RI
Posts: 5,030
Wirelessly posted

True
Reply With Quote
  #20  
Old 09-30-2011
Ranger4.0XLT's Avatar
Member
Thread Starter
 
Join Date: Sep 2011
Location: Northford, CT
Posts: 501
Bad News..

I got he news today that my tranny and transfer case are both shot due to water damage. It makes sense after how it has been acting lately, but I was confused as to why . My mechanic told me there was water damage and it turns out that when hurricane Irene came the water level was so high it got into the tranny vent and flooded it with salt water ( I live by the shore in CT.) I woke up to being evacuated from high waters and to get out of my neighborhood I had to do some serious puddle driving.. I was very cautious and knew this could be a problem but I had no choice.the water was about up to the bottom of my doors.. That's enough bad news for one year..
Reply With Quote
  #21  
Old 09-30-2011
04RangerDave's Avatar
JDM> RANGER

iTrader: (3)
 
Join Date: Jul 2010
Location: RI
Posts: 5,030
Wirelessly posted

Just get it rebuilt
Reply With Quote
  #22  
Old 10-01-2011
StxDangerRanger's Avatar
RF Veteran
iTrader: (2)
 
Join Date: Dec 2010
Location: Flat Rock, Mi
Posts: 6,313
Quote:
Originally Posted by 04RangerDave View Post
Wirelessly posted

Just get it rebuilt
x2. if its only water damage, then rebuilt will solve your problem.
Reply With Quote
  #23  
Old 10-31-2011
skulldrinker's Avatar
Member
 
Join Date: Oct 2011
Location: Chicago
Posts: 15
.--cut--
Reply With Quote
  #24  
Old 10-31-2011
skulldrinker's Avatar
Member
 
Join Date: Oct 2011
Location: Chicago
Posts: 15
--cut-- some reason my comment is not going into the right thread. sorry.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
nothing big, but fun nevertheless tkennedy17 General Ford Ranger Discussion 0 02-05-2011 03:21 PM
Use nothing but the best korey89 General Ford Ranger Discussion 3 10-13-2008 09:44 AM
Maybe nothing is wrong but... l2en General Ford Ranger Discussion 13 06-06-2006 01:23 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 08:58 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.