OBD-II Port not working - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 08-09-2009
KS_FX4's Avatar
Member
Thread Starter
 
Join Date: Jun 2009
Location: Wichita, KS
Posts: 102
OBD-II Port not working

I just bought a kiwi mpg so i could figure out my gas mileage, and when i plug it into my truck it doesn't power up. I tried this on two other trucks and it worked fine. Any ideas on what could be wrong?
Reply With Quote
  #2  
Old 08-09-2009
rangerboy101's Avatar
RF Veteran
iTrader: (5)
 
Join Date: Aug 2007
Location: Winchester, Va
Posts: 8,187
Check the fuse.
Reply With Quote
  #3  
Old 08-09-2009
KS_FX4's Avatar
Member
Thread Starter
 
Join Date: Jun 2009
Location: Wichita, KS
Posts: 102
isn't it the same fuse as for the cigerette lighter? I checked it and it's good
Reply With Quote
  #4  
Old 08-09-2009
rangerboy101's Avatar
RF Veteran
iTrader: (5)
 
Join Date: Aug 2007
Location: Winchester, Va
Posts: 8,187
Not sure. Let me look something up real quick.
Reply With Quote
  #5  
Old 08-09-2009
Ford04Ranger4.0's Avatar
Member
 
Join Date: Dec 2008
Location: Plattsburgh, New York
Posts: 3,390
Yes, my cig lighter closest to the driver didnt work or the OBII because of that fuse
Reply With Quote
  #6  
Old 08-09-2009
rangerboy101's Avatar
RF Veteran
iTrader: (5)
 
Join Date: Aug 2007
Location: Winchester, Va
Posts: 8,187
You were right. It is the one that powers the cigarette lighter.
Reply With Quote
  #7  
Old 08-09-2009
KS_FX4's Avatar
Member
Thread Starter
 
Join Date: Jun 2009
Location: Wichita, KS
Posts: 102
i'll check it again to make sure, thanks guys
Reply With Quote
  #8  
Old 08-09-2009
OVERtheEDGE's Avatar
Member
 
Join Date: Mar 2008
Location: locust grove georgia
Posts: 1,441
wow thats a first. i never heard of that thing not working before
Reply With Quote
  #9  
Old 08-09-2009
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
Mine did the same thing when i first got my scangauge. The OBD port and the left hand cigar lighter are on the same circuit.
Reply With Quote
  #10  
Old 08-09-2009
Redrocket's Avatar
Member
iTrader: (6)
 
Join Date: Jan 2007
Location: Waynesville n.c
Posts: 1,993
my truck has done the same thing to me. probley just a fuse
Reply With Quote
  #11  
Old 08-09-2009
KS_FX4's Avatar
Member
Thread Starter
 
Join Date: Jun 2009
Location: Wichita, KS
Posts: 102
ya it was the fuse after i looked again, i replaced it and it blew it again in about 5 mins, any way to prevent this?
Reply With Quote
  #12  
Old 08-09-2009
04blackedge's Avatar
RF Veteran
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
Take off the bezel and look at the wires for the cigar lighter, the 2 ends might be touching causing the fuse to blow. That was my problem at least
Reply With Quote
  #13  
Old 08-09-2009
KS_FX4's Avatar
Member
Thread Starter
 
Join Date: Jun 2009
Location: Wichita, KS
Posts: 102
Quote:
Originally Posted by 04blackedge View Post
Take off the bezel and look at the wires for the cigar lighter, the 2 ends might be touching causing the fuse to blow. That was my problem at least
Thanks man i'll check it out
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
obd port flakey? 08hybridok General Technical & Electrical 2 04-25-2015 09:37 PM
Heater not working/not shifting right conrad General Technical & Electrical 7 01-20-2011 06:35 PM
Fuse Diagram Need to replace Link Port/Data Port Fuse FRXLT General Technical & Electrical 14 05-25-2009 08:48 PM
OBDII port not working. 04blackedge General Technical & Electrical 31 08-30-2008 03:49 PM
Diagonistic Port Not Workin? EdGe_wannabe General Technical & Electrical 13 04-06-2006 11:13 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:09 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.