OHC Problem - Ranger-Forums - The Ultimate Ford Ranger Resource


General Technical & Electrical General technical and electrical discussion for the Ford Ranger that does not fit in any other sub-forum.

Reply
 
LinkBack Thread Tools Search this Thread
  #1  
Old 11-14-2007
04blackedge's Avatar
RF Veteran
Thread Starter
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
OHC Problem

Ok so I finished wiring up my OHC last night and for some reason the display is blank. When I crank the truck the display flashes with all the things lit up but it quits a second after. It doesn't display direction, temperature or anything. The map lights work and everything just not the display. I'm pretty sure everything is wired up correctly since the display comes on when the truck starts and I double checked it. Anyone have any clues?
Reply With Quote
  #2  
Old 11-14-2007
V8 Level II's Avatar
RF Veteran
iTrader: (4)
 
Join Date: Nov 2004
Location: Michigan
Posts: 7,833
1) Make sure that you have the yellow/gray console wire tapped to the black/pink of the radio harness. If it is connected to the red/black instead, the console will only power up while the starter is active.

2) Occasionally, Explorer overhead consoles lose their display due to a poor solder connection. More.
Reply With Quote
  #3  
Old 11-14-2007
04blackedge's Avatar
RF Veteran
Thread Starter
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
Ok I'm thinking its probably a bad connection with the black/pink, that sounds llke it makes more sense. Thanks a lot Bob!
Reply With Quote
  #4  
Old 11-14-2007
Member
 
Join Date: May 2007
Location: Northern Il
Posts: 60
You could have turned the display off. The mode button toggles the display between F, C and OFF.
Reply With Quote
  #5  
Old 11-14-2007
04blackedge's Avatar
RF Veteran
Thread Starter
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
I know I already tried that, I was hoping it was going to be that easy lol.
Reply With Quote
  #6  
Old 11-14-2007
Lord Of War's Avatar
Member
iTrader: (2)
 
Join Date: Jan 2006
Location: Thornton, Colorado
Posts: 4,599
Just make sure like bob said that you check your connections. Also make sure your ground is in a good spot. That might make it not work.
Reply With Quote
  #7  
Old 11-14-2007
04blackedge's Avatar
RF Veteran
Thread Starter
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
No the ground is fine, cause the map lights are fine and it comes on when the truck starts. I'm 95% positive its the black/pink connection is bad. I'll go out and check it in a little bit.
Reply With Quote
  #8  
Old 11-14-2007
taknotes's Avatar
Member
iTrader: (4)
 
Join Date: Aug 2006
Location: nc
Posts: 2,104
thought you were waiting to do it with me/frank? haha jp i know how i can get and be ready to do mods without waiting
Reply With Quote
  #9  
Old 11-14-2007
04blackedge's Avatar
RF Veteran
Thread Starter
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
I was going too, but i had a free weekend and got tired of it just sitting there. Whenever yall do get together let me know so I can let Frank take a look at my radio.
Reply With Quote
  #10  
Old 11-14-2007
04blackedge's Avatar
RF Veteran
Thread Starter
iTrader: (13)
 
Join Date: Jan 2007
Location: Durham, NC
Posts: 23,426
Ok I checked the connection for the black/pink and its fine. I'm going to tear apart all the wiring and rewire everything. I hope the console isnt broken.
Reply With Quote
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
For Sale: Tan OHC , Gray OHC and Auto Dimming mirror - GA MugenCRX04 Interior, Exterior, Electrical, & Misc. 12 09-29-2009 04:18 PM
OHC problem mlw20lu General Technical & Electrical 7 12-08-2008 07:01 PM
OHC Problem Shaklakan General Technical & Electrical 24 05-02-2008 02:45 AM
OHC board problem 04blackedge General Technical & Electrical 2 12-13-2007 09:51 PM
Possible OHC temp sensor problem aftermarket General Technical & Electrical 22 06-01-2006 05:04 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 10:19 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.